SFTP connection problem with My_webapp

My YunoHost server

Hardware: VPS bought online (OVH)
YunoHost version: (stable).
I have access to my server : Through SSH as main user (not admin) with password or pubkey and through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : not really

Description of my issue

Hi everyone,

I can’t connect through SFTP with My_webapp because “Too many authentication failures” with the webapp# user or admin.

I can connect with my main user which has SSH permission, but then I don’t have write permission on /var/www/my_webapp#/www/

I though the problem could be related to the SSH permission being granted to my main user (or that I didn’t granted it the right way) so:

  • I ensured with sudo yunohost tools regen-conf ssh --force that I have the default ssh config and then added the hook:
##-> my_webapp
    # Hardening user connection
    Match User webapp1
    ChrootDirectory %h
    ForceCommand internal-sftp
    AllowTcpForwarding no
    PermitTunnel no
    X11Forwarding no
    PasswordAuthentication yes
##<- my_webapp
  • also I tried on a fresh install with all default settings and the issue is reproducing.

I just need to upload files for a static website.

Am I the only one with the issue?
Does anyone have a solution?

I think the most convenient fix for me would be to somehow transfer ownership from the webapp# user to my main user. Is this do-able?

Thanks for you help!

OK my bad, I was trying with Filezilla on my Debian Desktop.
I tried again with Gnome Nautilus and it works perfectly.
So I guess I have a bad configuration for Filezilla…

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.