Setting up deb package sources failed

#1

Hello,

I wanted to install Yunohost on my Banana Pi with Bananian (Debian 8/Jessie) as operating system, so I used the installation guide for an ARM board. Everything worked fine, but at one step it failed with an error named “Setting up deb package sources failed”. It occurs after the information on the overwritten files during the installation.

Does anyone know how to solve it?

Install failure
#2

Hi

I am running into the same issue, “Setting up deb package sources failed”.

Have you found a solution / can anybody provide a solution please?

(i had to install liberror-perl & dialog that were reported as missing in the install logs

  • systemd-sysv is already the latest version, apache 2.2 not installed)

[EDIT] forgot to mention:

[quote]beng@R2877:~$ cd /tmp/install_script && sudo ./install_yunohost
[sudo] password for beng:
Current stable only works on Debian Jessie for the moment.
Failure !
The following error was caught during YunoHost installation :

Setting up deb package sources failed

Installation logs are located in /var/log/yunohost-installation.log[/quote]

but I am on Jessie (8.6)!

Thanks

#3

Hi ! Can you post the result of the following command ? lsb_release -c | awk '{print $2}'

You could try to comment lines 143 to 149 included of the install_script file and then running it.

#4

@heyyounow: thanks, will try both and will post later on (@ work now)

#5

(Sorry but I will have to keep editing this very post when I reply as I am limited to 3 posts by topic as a beginner)

My distro is

It is the successor of Crunchbang (#!)
(https://www.bunsenlabs.org/
i’ on the latest version, that I keep updated on a regular basis.

So indeed commenting got me a little further;
I had to install postfix to meet a dependency; itself depended on ssl-cert that I installed too,
I rerun the script and got to:

[quote]…
Reading package lists…
Building dependency tree…
Reading state information…
postfix is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
yunohost : Depends: moulinette (>= 2.3.5.1) but it is not going to be installed
Depends: glances but it is not installable
Depends: netcat-openbsd but it is not installable
Depends: iproute but it is not installable
Depends: mariadb-server but it is not going to be installed or
mysql-server but it is not going to be installed
Depends: php5-mysql or
php5-mysqlnd but it is not going to be installed
Depends: slapd but it is not going to be installed
Depends: ldap-utils but it is not going to be installed
Depends: sudo-ldap but it is not going to be installed
Depends: libnss-ldapd but it is not installable
Depends: postfix-ldap but it is not installable
Depends: postfix-policyd-spf-perl but it is not installable
Depends: postfix-pcre but it is not installable
Depends: procmail but it is not installable
Depends: dovecot-ldap but it is not going to be installed
Depends: dovecot-lmtpd but it is not going to be installed
Depends: dovecot-managesieved but it is not going to be installed
Depends: dovecot-antispam but it is not going to be installed
Depends: fail2ban but it is not installable
Depends: nginx-extras (>= 1.6.2) but it is not going to be installed
Depends: php5-fpm but it is not going to be installed
Depends: php5-ldap but it is not going to be installed
Depends: php5-intl but it is not going to be installed
Depends: dnsmasq but it is not going to be installed
Depends: avahi-daemon but it is not installable
Depends: ssowat but it is not going to be installed
Depends: metronome but it is not going to be installed
Depends: rspamd (>= 1.2.0) but it is not going to be installed
Depends: rmilter (>= 1.7.0) but it is not going to be installed
Depends: redis-server but it is not going to be installed
Depends: opendkim-tools but it is not installable
Recommends: openssh-server but it is not going to be installed
Recommends: etckeeper but it is not installable
Recommends: php5-gd but it is not going to be installed
Recommends: php5-curl but it is not going to be installed
Recommends: php-gettext but it is not installable
Recommends: php5-mcrypt but it is not going to be installed
Recommends: python-pip but it is not installable
Recommends: unattended-upgrades but it is not going to be installed
Recommends: libdbd-ldap-perl but it is not installable
Recommends: libnet-dns-perl but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Failure !
The following error was caught during Yunohost installation :

Installation of Yunohost packages failed[/quote]

any quick suggestion?
thanks

#6

First I suggest a little cleanup :

apt-get -f install
apt-get update && apt-get autoclean && apt-get autoremove

What happens if you try to install this package for example ?

apt-get install php5-fpm

#7

hmmm, not limited anymore ?
:wink:
Thanks!

1st command:

2nd command (I normally update / dist-upgrade / autoremove / autoclean whenever I start my machine)

[quote]Reading package lists… Done
E: Could not open lock file /var/cache/apt/archives/lock - open (13: Permission denied)
E: Unable to lock the download directory[/quote]

tried installing php5-fpm:

[quote]Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
php5-fpm : Depends: libonig2 (>= 5.9.5) but it is not installable
Depends: libqdbm14 (>= 1.8.74) but it is not installable
Depends: php5-common (= 5.6.27+dfsg-0+deb8u1) but it is not going to be installed
Depends: php5-cli but it is not going to be installed
Depends: php5-json but it is not installable
E: Unable to correct problems, you have held broken packages.[/quote]

#8

Ok so I think what’s happening is that your distribution is not recognized by apt-get as a valid Jessie one, have you tried adding their repo ? https://pkg.bunsenlabs.org/

Or you could trick apt and manually setting your distro as “jessie”, not sure how to do though. You should go to their forums and ask for help on how to install these basic packages (php5 etc.) as it’s very specific.

#9

Thanks for your help. Posted a topic on the BunsenLabs forum.
will keep you updated if you are interested.

#10

Hi
well, thoroughly reviewed my sources.list, updated
(https://forums.bunsenlabs.org/viewtopic.php?pid=39958#p39958)

and I’m still getting

[quote]Reading package lists…
Building dependency tree…
Reading state information…
dialog is already the newest version.
lsb-release is already the newest version.
whiptail is already the newest version.
wget is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
[ 2016-11-07 15:09:07+00:00 ] ----- [ entering create_custom_config ]
[ 2016-11-07 15:09:07+00:00 ] ----- [ entering confirm_installation ]
[ 2016-11-07 15:09:10+00:00 ] ----- [ entering setup_package_source ]

Failure !
The following error was caught during Yunohost installation :

Setting up deb package sources failed[/quote]

To cut this short, is there a yunohost 2.4 jessie image somewhere I could use please?
I could not find such a link on the release page (live images are 2.2 & wheezy)
Thanks a lot in advance

Jessie Yunohost 2.4
#11

[SOLVED] (as far as I am concerned)

I could install it manually (reran the install script) after running

and I ran [quote]sudo apt-get install bunsen-os-release[/quote] afterwards

(Thanks to Head_on_a_Stick @ https://forums.bunsenlabs.org/viewtopic.php?pid=39772#p39772

1 Like
#12

Hey,
unfortunately this doesn’t solve my porblem…

The installation log says:

lsb-release ist schon die neueste Version.
whiptail ist schon die neueste Version.
wget ist schon die neueste Version.
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
[ 2017-07-09 15:52:32+02:00 ] ----- [ entering create_custom_config ]
[ 2017-07-09 15:52:32+02:00 ] ----- [ entering confirm_installation ]
[ 2017-07-09 15:52:38+02:00 ] ----- [ entering setup_package_source ]

Failure !
The following error was caught during Yunohost installation :

Setting up deb package sources failed

#13

So, finally, I installed ARMbian for my bananapi and now it seems to work.

#14

I had the same problem on a debian 8 running in LXC container. I solved it just in adding in the /etc/apt/sources.list:

deb http://deb.debian.org/debian stretch main contrib non-free
deb-src http://deb.debian.org/debian stretch main contrib non-free

deb http://deb.debian.org/debian stretch-updates main contrib non-free
deb-src http://deb.debian.org/debian stretch-updates main contrib non-free

deb http://security.debian.org/ stretch/updates main contrib non-free
deb-src http://security.debian.org/ stretch/updates main contrib non-free
#15

@pokapow

Heu, comme l’indique ce topic, YunoHost n’est pas prêt pour stretch, donc c’est une très dangereuse idée que de faire pointer ton sources.list sur stretch…

Edit: Sorry for frenchm I didnt realize you wrote in english. Here’s the translation : as highlighted by this thread, YunoHost is not ready for stretch. So that’s a pretty dangerous idea to point your sources.list to stretch :confused:

#16

bonsoir;

j’ai le message d’horreur mention en sujet de ce topic

root@bast:/tmp/install_script# lsb_release -c | awk '{print $2}'
jessie

root@bast:/tmp/install_script# lsb_release -c | awk '{print $2}'
jessie
root@bast:/tmp/install_script# cat /etc/apt/sources.list
deb http://deb.debian.org/debian jessie main contrib non-free
deb-src http://deb.debian.org/debian jessie main contrib non-free
deb http://deb.debian.org/debian jessie-updates main contrib non-free
deb-src http://deb.debian.org/debian jessie-updates main contrib non-free
deb http://security.debian.org/ jessie/updates main contrib non-free
deb-src http://security.debian.org/ jessie/updates main contrib non-free

je sais pas trop
mise a part me poser des questions