Serveur local Yunohost sur Raspberry-pi - contexte de faible connectivite internet

fr
#21

Ah oui, prudence :slight_smile: Normalement lorsque tu te connectes en SSH à Yunohost, par défaut tu es déjà Root, donc pas besoin de sudo ici.

Ok super, tu peux te référer au retour d’expérience et au résumé des procédures en anglais dans le dernier commentaire ici : Utiliser La Brique en équipe dans un LAN - serveur DNS local (connexion internet faible/inexistante) , pas besoin de modifier /etc/resolv.conf qui est de toute façon ré-écrit régulièrement. Par contre tu dois impérativement modifier /etc/hosts sur le RPI, on dirait que tu ne l’as pas fait.
Enfin il faut redémarrer dnsmasq : yunohost service stop dnsmasq et yunohost service start dnsmasq, et il te faudra le refaire à chaque reboot de la brique.

Tout dépend l’usage, si c’est pour utiliser la brique en mode “déconnecté” c’est moins nécessaire, mais ça t’évitera l’avertissement de sécurité.

#22

Par contre tu dois impérativement modifier /etc/hosts sur le RPI, on dirait que tu ne l’as pas fait.
Enfin il faut redémarrer dnsmasq : yunohost service stop dnsmasq et yunohost service start dnsmasq

Effectivement j’ai oublié ça :wink:

et il te faudra le refaire à chaque reboot de la brique

Installer un script ne peut pas aider a relancer dnsmasq ?

EDIT: Bon tjs pas d’accès a l’interface utilisateur n’y aux apps après ttes les modifs…

#23

Le contenu de resolv.conf :

resolv_conf=/etc/resolv.conf
If you run a local name server, you should uncomment the below line and
configure your subscribers configuration files below.
name_servers=10.0.242.1

Celui du dns :

Add domains which you want to force to an IP address here.
The example below send any host in double-click.net to a local
web-server.
address=/mondomaine.nohost.me/10.0.242.1

Du etc/host :
127.0.0.1 localhost
::1 localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

127.0.1.1 YunoHost
10.0.242.1 mon domaine.nohost.me

Je pense avoir bon, non ?

#24

Je veux pas faire le relou, mais j’arrive plus a avancer.
Est-il vraiment possible d’avoir accès aux applications (wiki, wordpress…) en passant uniquement par le wifi (sans internet) du raspberry ?

#25

Tu peux utiliser la mise en forme pour que les messages soient plus faciles à lire.

A priori il n’est pas nécessaire de modifier ce fichier comme expliqué à la fin de Utiliser La Brique en équipe dans un LAN - serveur DNS local (connexion internet faible/inexistante)
Et là tu as écris “name_servers” au lieu de “nameserver”.
Ensuite je ne vois pas le caractère “#” indiquant que les lignes de texte sont commentées.

Tu dois parler du fichier /etc/dnsmasq.conf
Ca à l’air bon, à part que je ne vois toujours pas les “#”

Ca à l’air bon oui !
Tu n’as pas de service VPN qui tourne, c’est bien ça ?
Tu as bien modifié le First DNS Resolver de l’application HotSpot Wifi + cliquer sur “Sauvegarder et recharger” via l’interface utilisateur ? Comme ça :

Et une fois que tu as fait tout ça, redémarrer le service dnsmasq

Bon courage !

#26

Merci @lops, je désespérais de ne pas avoir de tes nouvelles :wink:

Bon faisons le point :

Concernant les #, c’est normal que tu ne les vois pas, je les ai enlevé, car, lorsque que je les ajoutes, la police du forum devient ENORME!!! Mais, je te rassure, dans les fichiers, ils y sont :wink:

A priori il n’est pas nécessaire de modifier ce fichier comme expliqué à la fin de Utiliser La Brique en équipe dans un LAN - serveur DNS local (connexion internet faible/inexistante)

je peux laisser la conf du fichier resolv.conf : tel quel du coup ?

Et là tu as écris “name_servers” au lieu de “nameserver”.

Je vérifie ça ce soir. L’erreur vient peut-être de là…

Tu dois parler du fichier /etc/dnsmasq.conf

Oui c’est ça :wink:

Tu n’as pas de service VPN qui tourne, c’est bien ça ?

Du coup non, je n’en ai pas l’utilité, étant donné que ça restera hors ligne.

Tu as bien modifié le First DNS Resolver de l’application HotSpot Wifi + cliquer sur “Sauvegarder et recharger” via l’interface utilisateur ? Comme ça :

Oui, j’ai fait ! :smile:

Bon, je reviens plus tard donner mes résultats. Merci encore

#27

Super, ça à l’air de fonctionner maintenant ! Merci @lops !

Par contre, c’est lent pour charger les applications, c’est normal ? J’ai même parfois des page de délai trop long :confused:

On peut réparer ça ?

#28

:grin: super !
Pour la lenteur : je n’ai pas de RPI désolé mais j’ai cru voir passer plusieurs fois des fils de discussion relatifs à la lenteur des RPI, à chercher !

#29

Ok je cherche.

Je cherche avant a, lancer un script de redémarrage automatique de dnsmasq, j’aimerai éviter de devoir me connecter en ssh pour lancer la commande manuellement.

Les gens qui vont utiliser ce trucs sont des billes en informatique…

#30

J’ai l’impression que dnsmasq se lance trop tôt. J’aimerai ralentir son exécution dans la conf.

#31

J’ai trouvé pourquoi il y a de la lenteur, certains theme et autres extensions demande un accès vers l’extérieur (par exemple googlefonts ou ajax googleapis.com) et cela retarde le chargement de la page. Il faut donc les désactiver avec une extension ou a la mano dans le code.

#32

googlefonts et ajax google apis agissent comme des trackers (via l’instruction HTTP_REFERER) du coup c’est bien de les remplacer si possible en hébergeant la font ou le script soit même.