Server not available very regularly, how to fix?

Hi everybody,
thanks for such a great software that is Yunohost.

I have a yunohost instance set up on a an old macbook. For a few months it worked perfectly but since a few weeks I experience many downtime. Server is unreachable and sometimes gets back online by itself then gets again unreachable… And when I can connect it, it’s relatively slower than it used to be. I suspect there’s too much load but I don’t know what should be the next steps to fix that. Please help :slight_smile:

Here is diagnosis to start with:

{
    "host": "Debian 9.11",
    "kernel": "4.9.0-11-amd64",
    "packages": {
        "yunohost": {
            "repo": "stable",
            "version": "3.6.5.3"
        },
        "yunohost-admin": {
            "repo": "stable",
            "version": "3.6.5.1"
        },
        "moulinette": {
            "repo": "stable",
            "version": "3.6.4.1"
        },
        "ssowat": {
            "repo": "stable",
            "version": "3.6.4"
        }
    },
    "backports": [],
    "system": {
        "disks": {
            "sda2": "Mounted on /, 290.0GiB (226.2GiB free)",
            "sda1": "Mounted on /boot/efi, 511.0MiB (510.9MiB free)"
        },
        "memory": {
            "ram": "1.9GiB (439.1MiB free)",
            "swap": "2.0GiB (1.7GiB free)"
        }
    },
    "nginx": [
        "nginx: the configuration file /etc/nginx/nginx.conf syntax is ok",
        "nginx: configuration file /etc/nginx/nginx.conf test is successful"
    ],
    "services": {
        "php7.0-fpm": "running (enabled)",
        "fail2ban": "running (enabled)",
        "yunohost-api": "running (enabled)",
        "mysql": "running (enabled)",
        "monitorix": "running (enabled)",
        "glances": "running (enabled)",
        "rspamd": "running (enabled)",
        "coturn-synapse": "running (enabled)",
        "avahi-daemon": "running (enabled)",
        "dovecot": "running (enabled)",
        "uwsgi": "running (enabled)",
        "nslcd": "running (enabled)",
        "nginx": "running (enabled)",
        "ssh": "running (enabled)",
        "redis-server": "running (enabled)",
        "metronome": "running (enabled)",
        "postfix": "exited (enabled)",
        "yunohost-firewall": "exited (enabled)",
        "ttrss": "running (enabled)",
        "dnsmasq": "running (enabled)",
        "slapd": "running (enabled)",
        "matrix-synapse": "running (enabled)"
    },
    "applications": {
        "synapse": "Synapse",
        "wallabag2": "Lire plus tard",
        "monitorix": "Monitorix",
        "ttrss": "Suivre les actus de mes sites préférés",
        "rainloop": "Mon email",
        "searx": "Rechercher",
        "rss-bridge": "Générateur de flux RSS",
        "nextcloud": "Stocker, échanger, s'organiser"
    },
    "security": {
        "CVE-2017-5754": {
            "name": "meltdown",
            "vulnerable": false
        }
    }
}

I also see that postfix and yunohost-firewall are showing “exited” in diagnosis. Could be linked to that?`

I also have Monitorix running but I don’t really know what to look at in all these graphs, feel free to tell me if you want me to share some of them. Well, at least, I understand there’s something going on with system load I guess, it’s very high, no ?

No. I know it’s strange but these exited is normal for postfix and yunohost-firewall.

If we read this graph, it seems your server freeze during a long time. Do you restart it manually after or no?

May be you have configured reboot on power ?
What about the temperature, may be your mac is too hot sometimes, and shutdown and restart when it’s ok ?

Hey @ljf thanks for helping :slight_smile:
Yep I know there’s a big shutdown which happened in deed voluntarily but it’s not really what’s important to check here. I’m experiencing every day since a couple of weeks downtimes of 5 to 20 minutes during the day. I know it thanks to downnotifier.com service. But I don’t know how could that be happening, and I never had that kind of issue in the past 6 months of yunohost working.

Well sometimes it happened but then I updated the system and magically it get stable again. I suspect the latest update I did is the reasons of these ups and downs :confused:

According to downnotifier which sends me an email everytime it tries to ping my server and gets a timeout of 25 seconds, the server was unavailable at:

  • 3:30pm for 2 minutes
  • 6:17pm for 2 minutes
  • 7:02 pm for 2 minutes
  • 8:48 pm for 8 minutes
  • 6:49 am for 6 minutes
  • 7:25 am for 2 minutes
  • 8:29 am for 6 minutes
  • 12:38 am for 2 minutes

Here is what Monotorix show for these last 24hours:

Update here. Yesterday I switched off my server as everything was very slow… This morning it seems to works fine :slight_smile: Still I’d love to understand the causes of such slowdown so I can address them and try to fix it. Thing is I don’t really know where to start from in order to identify the root of the issue :confused:

Have you tried to turn off fail2ban to see if it could be some ban rules activated for some reasons ?

I think you can turn off fail2ban for some days if you have strong password.

Hi, well I’m really not confortable turning off fail2ban and I don’t see why it would be linked to the issue. But, I managed to update quiet a lot of system packages (weirdly it updated much more stuff when I did the update command through command line with ssh than on the web UI) and so far it looks like it’s working quiet well.

I’ll get back to this topic if things change.