Searx raspberry Pi2

,

hello,
i have problems setting correctly the searx.
Cant find a solution in all the web.

i have only this lines in
nano /etc/fstab

/dev/mmcblk0p1 /boot vfat defaults 0 2
/dev/mmcblk0p2 / ext4 errors=remount-ro,noatime 0 1

try to put this for swap,dont know if they are correct…

tmpfs /tmp tmpfs nodev,nosuid,size=10%,mode=1777 0 0
tmpfs /var/log tmpfs nodev,nosuid,size=20%,mode=1755 0 0

breaks uwsgi and nginx and not working,so i delete this two.

so,what can i do to make the searx works better?
change this line in nano /opt/yunohost/searx/searx/settings.yml
request_timeout : 4.0 # seconds
now i can have more results,but still have timeouts for one or two search engines.

if i tail -f /var/log/uwsgi/app/searx.log
have this message too.

InsecurePlatformWarning
/opt/yunohost/searx/local/lib/python2.7/site-packages/requests/packages/urllib3/util/ssl_.py:78: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning.

i try all the python solutions and still have the error,and not working here,cant get ride off with this message.
my plataform is a raspberry2.

What i can do more?
Thanks for helping me.

So comes the day…no fun alone!
Lets “Xposed” my little corner of the internet.
Works great,everything,only the searx a little slow,you have to click the button to search two times,but only sometimes,is like a car needs to warm up the engine,after, is good to roll:)
im in love right now with odroid u3 or xu3 lite,maybe,just maybe my next plataform,so many different labels to choose from…i have a droid in my dreams to put flying,dont know yet how and when,now i need a job and money to buy a 3d printer first!!
You can see http://pi.nohost.me/searx
and blog
http://pi.nohost.me/blog/
with music i like,just a test,be carefull my taste of music is poison,ahaha!!
Please dont hack my space,dont be bad,i check the logs and i’ll send you my “daemons --no verbose” to you:D
Just kidding:)
Just enjoy,and wish you enjoy your yunohost too: :smile:

anybody knows how i can add in my instance of searx, in preferences the “plugins” and “cookies” configurations settings,mine dont have this like in searx.me .but is the same version 0.7.0 .
i need to edit /opt/yunohost/searx/searx/settings.yml today and disable gigablast give me some problems…
seems more faster now.

hey today i update the searx to the new version now is version 0.8 ,from https://github.com/abeudin/searx_ynh
with " yunohost app upgrade searx " and gives me this error :

-su: line 0: cd: /var/cache/yunohost/from_file/searx_ynh-master/scripts: Permission denied
Erro: A instalação falhou

i try to remove searx,but now i cant install again.
always have this message permission denied

inside the folder " /var/cache/yunohost" dont have nothing there…i try remove with rm ,and still not working.
how i can install again searx?
thks

Hi, do you still have the admin user?

hey scith,
yes i have admin user,and root ,i try via painel in yunohost/admin

i update with sucess owncloud
now i found that i have same error when i do "sudo yunohost app upgrade nameofapp"
so this is not related with searx

i do yunohost app fetchlist and yunohost app upgrade
and
i have
Permission denied upgrading…

-su: line 0: cd: /var/cache/yunohost/from_file/…
Permission denied

Hey,
it was a problem of permissions in /var/cache, after i give acess to the group root and others for read the folder,i can now upgrade.i only have in the folder read and write for owner,the group “root” and “other” didnt have acess.
so i compare to a dd backup this folder and found it.
sometimes is dificult to find where is the problem,and was so easy,thks for give me that light, @scith :slight_smile:
i can upgrade all the apps now.