Searx crashed while migration to bullseye

,

My YunoHost server

Hardware: VPS
YunoHost version: 11.0.9.15 (stable)
I have access to my server : Through SSH, webadmin and direct access via screen
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : yes
If yes, please explain: Ive upgraded my old 4.x.x. Yunohost to Bullseye.

Description of my issue

Some days ago I upgraded my yunohost to bullseye. The upgrade works fine. A migration was offered. I run this. First I got some migration errors ( postinst called with unknown argument 'triggered'). Today I tried the migration again and it works - except the migration from searx. Here I got an error.

I read I ve to run the command yunohost app upgrade --force searx. I did this and got the next error.

Here comes the log
https://paste.yunohost.org/raw/kahiwohipo

Have someone an idea what I can do?
Thanks a lot

Did you notice the lines like

2022-10-05 19:06:59,350: WARNING - 33651 Oct 05 13:15:57 systemd[1]: /etc/systemd/system/uwsgi-app@.service:13: Standard output type syslog is obsolete, automatically updating to journal. Please update your unit file, and consider removing the setting altogether.

in the log?

I haven’t installed SearX in Yunohost 11 yet, but I did see it in the application list. Instead of restoring from backup, does installing a new SearX-app work?

I also had a little problem with SearX on YunoHost 11 upgrade, but as this is an app without anything stored, I just uninstalled it and re-installed it on the same domain, and everything worked again.

1 Like

Oh no, thank you!
Syslog is obsolete? Ok, … hm. Is journal easy to handel?
Ive no experience with it.

On my yunohost searx seems to be gone. Ive no installed searx app any more. Hmmm …?! What happens if I install it again? Can I crash the whole system? :thinking:

You could, if you did your best… No, joking, you couldn’t :slight_smile:

The worst thing that could happen is that the installer says: “Wait a moment, I already have searX!”, and quits.

By the way, how do you like searX? I have it running as well. The main reason was that I hoped to filter Pinterest and such sites that poison search results on other search engines, but I haven’t been able to find how to configure that :frowning:

:smile: OK, i do my best :smile:
Thank you!

I’m still not so familiar with it. I’ve installed it some weeks ago and want to use it as my default search engine. But it isnt already in my workflow :wink:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.