[Seafile] Synchronize your files

,

BTW I’ve updated the package to the last version available, Seafile 5.0.3.

Thanks for answering. Dommage

I tried to install Seattle on YH 2.4, but it didn’t work, I got the error: “Installation failed.”

in the log I could see those errors:

Job for seafile-server.service failed. See 'systemctl status seafile-server.service' and 'journalctl -xn' for details.
+ sudo service seafile-server start
+ sudo service seafile-server stop
-su: /var/www/seafile/seafile-server-latest/seahub.sh: No such file or directory

And

Have you run setup-seafile.sh before this?
Error: there is no ccnet config directory.

Yes, I did setup-Seafile before on my YH and it worked. As it did’t worked anymore with YH 2.4 I uninstalled it.

Is there a plan to upgrade to 6.0 ? This last version is compatible with SeaDrive, which creates a virtual drive to access all files, even the ones that are not synced.

Yes there is a plan to upgrade the package to the last version and to be compatible with yunohost 2.4 but don’t expect it to be soon, I have no time to work on it for now. Maybe in a month.

If somebody want to work on it and make a pull request I would gladly review it and merge if possible.

OK, I’ve tried to upgrade the package. My fork is over there.

I only tested directly installing the app, not upgrading it.
Installation is OK, server is available for client apps but on the YNH portal the Seafile tile refreshes the page without bringing me to the Seafile auth page. No problem if I go directly to https://foo.me/seafile/accounts/login/?next=/seafile/.
I guess it’s a mishap with SSOwat. I tried to put /seafile in SSOwat’s unprotected_urls but with no change.

I’m a bit at a loss, can someone have a look ?

Other problem I came across (with either current version or 6.0.4) : I get a CSRF verification error page upon login. I avoid it by using the browser private mode.

Hello,

As the maintener of the seafile package I will restart to update this topic when I realase a new version of this package.

So actually there are a new testing realase available :

  • Update to seafile 6.3.4
3 Likes

Hello,

New Update available for Seafile :

  • 29 oct 2018 :
    • Update to seafile 6.3.4
3 Likes

Hi,

Uploading large files (> 1Go or 1,5Go) fails. I’ve tried to upload files through the web interface and via the desktop client, but neither way works.

I guess I’ve to set a correct value in one of the configuration files. Can you enlighten me on this?

Addendum: I’ve edited /opt/yunohost/seafile/conf/seafile.conf to add max_upload_size = 5000. When I try to upload a 1.9GB with the desktop client, the transfer reaches 1GB and start over, again and again.

Addendum bis: yeah, it works! :grinning:
I’ve added proxy_request_buffering off; in the nginx configuration file of seafile, and replaced 5000 by 5G in seafile.conf. Don’t know if both settings are necessary.

If you do not put a unit, PHP assumes bytes. It is indeed better to use 5G. :wink:

But in documentation, default unit is mega: https://download.seafile.com/published/seafile-manual/config/seafile-conf.md :confused:

I misread, I thought you were editing it in the PHP.ini-like configuration.

Hello,

A new main version is available in the testing branch.

Main new are:

  • Upgrade to seafile 7.0
  • Add fail2ban support
  • Use new yunohost helper
  • Use systemd unit to manage seafile services. Now you have 2 service to manage seafile and seahub instead of the seafile-server service.
  • #49 : Use main email for sso. Note that implicate that you probably need to migrate your account with this command: yunohost app action run seafile migrate_user_email_to_mail_email
2 Likes

Is it planned to update this to Seafile 8?