Rmilter problem

I just got started with Yunohost and notice when sending mail, its unusually slow. I am using Gandi’s DNS and believe I have it setup correctly.

I get alot of this in the logs.

Dec 27 15:47:58 8biiit postfix/smtpd[27665]: warning: milter inet:localhost:11000: read error in initial handshake
Dec 27 15:48:27 8biiit postfix/smtpd[27668]: warning: milter inet:localhost:11000: can’t read SMFIC_OPTNEG reply packet header: Connection timed out.

The smfic_optneg errors show up every connection. For example, every time I email myself from lets say gmail, I see in the log, the connection, then a long pause, those errors, and finally it go through.

Any ideas?

J

Here is some more detail. Im sending a message from roundcube. Notice the bold times. Theres where the delay is coming from… the SMFIC_OPTNEG reply packet. I have confirmed rmilter service is running. Also confirmed /etc/postfix/main.cf shows rmilter:11000 as well.

I can comment out smtpd_milters = inet:localhost:11000 in the main.cf file and mail instantly delivers as expected.

Any help is appreciated.

Thank you,
J

Dec 27 17:12:18 8biiit postfix/smtpd[30583]: connect from localhost[127.0.0.1]
Dec 27 17:12:48 8biiit postfix/smtpd[30583]: warning: milter inet:localhost:11000: can’t read SMFIC_OPTNEG reply packet header: Connection timed out
Dec 27 17:12:48 8biiit postfix/smtpd[30583]: warning: milter inet:localhost:11000: read error in initial handshake
Dec 27 17:12:48 8biiit postfix/smtpd[30583]: Anonymous TLS connection established from localhost[127.0.0.1]: TLSv1 with cipher ECDHE-RSA-AES128-SHA (128/128 bits)
Dec 27 17:12:48 8biiit postfix/smtpd[30583]: 4F02A301130: client=localhost[127.0.0.1], sasl_method=LOGIN, sasl_username=skwid
Dec 27 17:12:48 8biiit postfix/cleanup[30587]: 4F02A301130: message-id=9f5c502c8110d88e8eb1a2d424b9fe66@webmail.8biiit.com
Dec 27 17:12:48 8biiit postfix/qmgr[5635]: 4F02A301130: from=------@8biiit.com, size=802, nrcpt=1 (queue active)
Dec 27 17:12:48 8biiit dovecot: imap-login: Login: user=<------>, method=PLAIN, rip=::1, lip=::1, mpid=30590, secured, session=
Dec 27 17:12:48 8biiit postfix/smtpd[30583]: disconnect from localhost[127.0.0.1]
Dec 27 17:12:48 8biiit dovecot: imap(skwid): Disconnected: Logged out in=684 out=568
Dec 27 17:12:49 8biiit postfix/smtp[30588]: Untrusted TLS connection established to mta7.am0.yahoodns.net[66.196.118.34]:25: TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)
Dec 27 17:12:49 8biiit dovecot: imap-login: Login: user=<------>, method=PLAIN, rip=::1, lip=::1, mpid=30595, secured, session=
Dec 27 17:12:49 8biiit dovecot: imap(skwid): Disconnected: Logged out in=70 out=519
Dec 27 17:12:50 8biiit postfix/smtp[30588]: 4F02A301130: to=------@yahoo.com, relay=mta7.am0.yahoodns.net[66.196.118.34]:25, delay=1.8, delays=0.06/0.01/0.75/0.95, dsn=2.0.0, status=sent (250 ok dirdel)
Dec 27 17:12:50 8biiit postfix/qmgr[5635]: 4F02A301130: removed
Dec 27 17:12:50 8biiit dovecot: imap-login: Login: user=<------>, method=PLAIN, rip=::1, lip=::1, mpid=30603, secured, session=
Dec 27 17:12:50 8biiit dovecot: imap-login: Login: user=<------>, method=PLAIN, rip=::1, lip=::1, mpid=30605, secured, session=<2sghJ6tEZgAAAAAAAAAAAAAAAAAAAAAB>
Dec 27 17:12:50 8biiit dovecot: imap(skwid): Disconnected: Logged out in=323 out=5139
Dec 27 17:12:50 8biiit dovecot: imap(skwid): Disconnected: Logged out in=158 out=697

Hello,
I’ve made a quick research on the web about SMFIC_OPTNEG, it could be a problem with your DKIM configuration. Have you tested your email settings with mail-tester? What’s the output?

Here are the results: (This is with rmilter disabled due to the timeout delay issue though. ) I’m not sure how to fix the rDNS issue either with my provider.

https://www.mail-tester.com/web-py3y8

Yeah so I still can’t figure out whats going on here. Maybe I’ll do a complete reload and try again but I’ve tried everything. Most suggestions say port 53 TCP mustbe opened and it is.

J