Restauration anciene sauvegarde

,

Mon serveur YunoHost

Matériel: VPS cramé à Strasbourg, reinstallation sauvegarde de Novembre sur VM debian amd 64
Version de YunoHost: inconue pour la sauvegarde, derniere version
**J’ai accès à mon serveur : Pas du tout pour celui qui a cramé, ssh pour le nouveau, webadmin si post install éffectué

Êtes-vous dans un contexte particulier ou avez-vous effectué des modificiations particulières sur votre instance ? : oui
Si oui, expliquer: Je l’avais pas vu venir le datacenter qui crame

Description du problème

Bonjour,

Je cherche a restaurer une sauvegarde complete en lieu et place de la post install.

Je pense que j’ai un souci de version de yunohost entre la sauvegarde et la nouvelle install.

La restauration se passse bien pour yunohost mais pas pour les apps (toutes les restauration d’apps echoue).

Le problème se situe au niveau des permissions des apps.

Le script de restauration de l’apps lance la création des permissions mais le script de création des permissions échoue : dans /var/log/yunohost/categories le .log est vide, le .yml contien quelque chose du genre : hastebin (fichier date-heure-permission_create_appname)

Quelles solutions s’offre a moi?

Merci d’avance

Version de YunoHost: inconue pour la sauvegarde, derniere version

Du coup ce serait quand même cool de confirmer au moins si c’était la version 3.8 ou 4.1 …

Pareil pour la version du nouveau serveur : on parle bien d’une 4.1 ?

Bonsoir,

Peut-être que tu peux essayer de réinstaller la version de YNH que tu avais en novembre ?

EDIT: ça ne semble pas si simple car les dépôts Debian ne remontent que la dernière version stable mais les .deb pour la version 3.8.5 sont dispos ici: Index of /debian/pool/stable/y/yunohost/

Oui, la nouvelle VM a été installer avec le script install.yunohost.org donc a jour.

Du coup ce serait quand même cool de confirmer au moins si c’était la version 3.8 ou 4.1 …

Je n’ai pas trouvé dans la sauvegarde si cette information été stocké quelque part?

Merci d’avance
P.S.: Je remonte une autre VM pour le moment pour remettre en route la réception des mail mais j’aimerai bien réussir a restaurer cette sauvegarde

A priori ma sauvegarde date a minima de la 3.8 voir avant :frowning:

Comment je peut faire pour installer un yunohost de cette version pour restaurer la sauvegarde?

Merci d’avance

Tu peux installer yunohost sur une debian stretch en utilisant install.yunohost.org/stretch comme script d’install … mais ça installera la 3.8, donc je ne sais pas dire si ça marchera, ça dépends de la version d’où viens ta sauvegarde pour de vrai (3.5, 3.6, 3.7, …)

J’essaie pour les mêmes raisons de réinstaller une archive datant du 4 janvier (sur un vps donc). Malheureusement les applis (wordpress et discourse) ne sont pas réinstallées.
Je me concentre d’abord sur wordpress :
J’ai l’erreur

Info: DEBUG - Restoring the app ‘wordpress’…
Info: INFO - The operation ‘Create permission ‘wordpress’’ could not be completed. Please share the full log of this operation using the command ‘yunohost log display 20210313-131741-permission_create-wordpress --share’ to get help
Info: ERROR - Could not restore wordpress

Le log est ici : https://paste.yunohost.org/raw/atatojurev
Cependant je ne sais pas quoi en faire, comment contourner le problème ?

J’ai essayé non pas de restaurer la sauvegarde wordpress mais d’installer wordpress sur mon serveur et j’obtiens le même genre d’erreur : https://paste.yunohost.org/raw/xovitugulo
Le problème vient donc de la restauration de mon système mais je ne sais pas du tout quoi faire.

J’ai reussi a restaurer l’archive mais je me questionne:
si j’installe stretch, je suis en yunohost 3.8 et je devrais pouvoir faire la migration vers buster, mais le webadmin me dit qu’elle est déjà faite c’est trés étonnant non?

EDIT : Les migrations ont le status “skipped” … je ne peut pas les lancer

Salut,

je pense avoir réussi à identifier le problème pour ton cas, j’ai créé un ticket ici: Backup from < 4.1, restore on >= 4.1 : the core doesn't re-apply the second permission group migration · Issue #1758 · YunoHost/issues · GitHub

À mon avis pour corriger le problème, il faut faire nano /etc/yunohost/migrations.yaml, enlever complètement la ligne pour la migration 0019 (de sorte à ce que yunohost souhaite executer cette migration), sauvegarder/quitter avec Ctrl+X, puis dans la webadmin tu devrais voir que la migration est proposée dans Outils > Migrations

1 Like

Merci beaucoup !
J’ai dû réinstaller le serveur parce que les applications étaient marquées comme déjà installées même si elles ne l’étaient pas. Mais ta solution a résolu le problème.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.