# \[RESOLVED\] ONLYOFFICE Half installed and DPKG issue

**URL:** https://forum.yunohost.org/t/resolved-onlyoffice-half-installed-and-dpkg-issue/19244
**Category:** Support
**Tags:** bug, french, install
**Created:** [March 21, 2022, 11:33am UTC](https://forum.yunohost.org/t/resolved-onlyoffice-half-installed-and-dpkg-issue/19244 "2022-03-21T11:33:39Z")
**Posts on this page:** 10
**Page:** 1

<div class="post-metadata">

### Author: ![nicolasbremond](https://forum.yunohost.org/letter_avatar_proxy/v4/letter/n/779978/32.png) [@nicolasbremond](https://forum.yunohost.org/u/nicolasbremond)
#### Post date: [March 21, 2022, 11:33am UTC](https://forum.yunohost.org/t/resolved-onlyoffice-half-installed-and-dpkg-issue/19244/1 "2022-03-21T11:33:39Z")

</div>

## 🇫🇷 Modèle de message (français)

### Mon serveur YunoHost

**Matériel:** VPS acheté en ligne  
**Version de YunoHost:** 4.3.6.2  
**J’ai accès à mon serveur :** En SSH  
**Êtes-vous dans un contexte particulier ou avez-vous effectué des modificiations particulières sur votre instance ?** : oui  
**Si oui, expliquer:** J’ai essayer d’installer ONLYOFFICE mais c’était très long donc j’ai raffraichi la page et depuis je n’ai plus accès à la Webadmin

### Description du problème

Bonjour à toutes et tous,

Je suis dans une me\*\*\* noir j’ai l’impression…

Après avoir installé l’app ‘OnlyOffice’ je n’ai plus accès à mon VPS par la Webadmin, plus de site Wordpress, plus rien … . L’installation ne sait pas terminée car après un certains temps ça n’avançait plus et j’ai rafraichit la page (je ne le referai plus …)

Les derniers message d’erreurs indiquait de faire :

dpkg --configure -a

```plaintext
Setting up onlyoffice-documentserver (7.0.1-37) ...
psql: FATAL: password authentication failed for user "onlyoffice"
FATAL: password authentication failed for user "onlyoffice"
dpkg: error processing package onlyoffice-documentserver (--configure):
 installed onlyoffice-documentserver package post-installation script subprocess returned error exit status 2
Errors were encountered while processing:
 onlyoffice-documentserver

```

Je ne sais plus quoi faire et j’ai peut d’avoir ‘Cassé Yunohost’ alors que c’est bien la première chose que vous dite de ne pas faire …

Que puis-je faire ? ..

Nicola

---

<div class="post-metadata">

### Author: ![nicolasbremond](https://forum.yunohost.org/letter_avatar_proxy/v4/letter/n/779978/32.png) [@nicolasbremond](https://forum.yunohost.org/u/nicolasbremond)
#### Post date: [March 21, 2022, 11:40am UTC](https://forum.yunohost.org/t/resolved-onlyoffice-half-installed-and-dpkg-issue/19244/2 "2022-03-21T11:40:22Z")

</div>

Voilà d’autres résultats

Pour dpkg --audit :

```nohighlight
The following packages are only half configured, probably due to problems
configuring them the first time. The configuration should be retried using
dpkg --configure <package> or the configure menu option in dselect:
 onlyoffice-documentserver Online editors for text documents, spreadsheets, and

```

dpkg --configure onlyoffice-documentserver

```nohighlight
Setting up onlyoffice-documentserver (7.0.1-37) ...
psql: FATAL: password authentication failed for user "onlyoffice"
FATAL: password authentication failed for user "onlyoffice"
dpkg: error processing package onlyoffice-documentserver (--configure):
 installed onlyoffice-documentserver package post-installation script subprocess returned error exit status 2
Errors were encountered while processing:
 onlyoffice-documentserver

```

Je continue mes recherches en attendant …

---

<div class="post-metadata">

### Author: ![nicolasbremond](https://forum.yunohost.org/letter_avatar_proxy/v4/letter/n/779978/32.png) [@nicolasbremond](https://forum.yunohost.org/u/nicolasbremond)
#### Post date: [March 21, 2022, 12:21pm UTC](https://forum.yunohost.org/t/resolved-onlyoffice-half-installed-and-dpkg-issue/19244/3 "2022-03-21T12:21:11Z")

</div>

Je viens juste de faire

```nohighlight
ls -l /var/lib/dpkg/info | grep -i onlyoffice-documentserver

/var/lib/dpkg/info/onlyoffice-documentserver.* /tmp

apt remove onlyoffice-documentserver

```

et redémarrer mon VPS et ça ne marche toujours pas …

Maintenant quand je fais

```nohighlight
dpkg --configure -a 
dpkg --audit

```

Plus rien ne s’affiche

---

<div class="post-metadata">

### Author: ![Kit](https://forum.yunohost.org/user_avatar/forum.yunohost.org/kit/32/1208_2.png) [@Kit](https://forum.yunohost.org/u/Kit)
#### Post date: [March 21, 2022, 12:31pm UTC](https://forum.yunohost.org/t/resolved-onlyoffice-half-installed-and-dpkg-issue/19244/4 "2022-03-21T12:31:06Z")

</div>

T’as manifestement accès en SSH, ne peux-tu pas restaurer un backup ?

Quid de tenter la désinstallation d’OnlyOffice (un truc genre `yunohost app remove onlyoffice`) puis sa réinstallation ?

---

<div class="post-metadata">

### Author: ![nicolasbremond](https://forum.yunohost.org/letter_avatar_proxy/v4/letter/n/779978/32.png) [@nicolasbremond](https://forum.yunohost.org/u/nicolasbremond)
#### Post date: [March 21, 2022, 12:33pm UTC](https://forum.yunohost.org/t/resolved-onlyoffice-half-installed-and-dpkg-issue/19244/5 "2022-03-21T12:33:25Z")

</div>

Salut Kit,

Merci de ta réponse. J’ai désinstallé OnlyOffice mais maintenant il semble que ce soit NGINX qui ne marche plus …

Quand j’ai essayé de faire une mise à jour d’une app (Gogs) il me dit

```nohighlight
 unable to upgrade apps: These required services should be running to run this action: nginx (failed)

```

Pour restaurer un backup comment je dois faire ?

---

<div class="post-metadata">

### Author: ![Kit](https://forum.yunohost.org/user_avatar/forum.yunohost.org/kit/32/1208_2.png) [@Kit](https://forum.yunohost.org/u/Kit)
#### Post date: [March 21, 2022, 12:37pm UTC](https://forum.yunohost.org/t/resolved-onlyoffice-half-installed-and-dpkg-issue/19244/6 "2022-03-21T12:37:48Z")

</div>

Un truc style (ouais j’ai pas le terminal sous les yeux là) `yunohost backup list` suivi de `yunohost backup restore nom_du_backup`

Si nginx est hs, tente de le reload ou restart : `yunohost service restart nginx`

---

<div class="post-metadata">

### Author: ![nicolasbremond](https://forum.yunohost.org/letter_avatar_proxy/v4/letter/n/779978/32.png) [@nicolasbremond](https://forum.yunohost.org/u/nicolasbremond)
#### Post date: [March 21, 2022, 1:04pm UTC](https://forum.yunohost.org/t/resolved-onlyoffice-half-installed-and-dpkg-issue/19244/7 "2022-03-21T13:04:47Z")

</div>

Je n’ai pas de backup qui marche car il me dit que les applications sont déjà installées

Ce qui semble posé problème c’est que je n’ai plus le dossier ds.conf

```nohighlight
Directory /etc/nginx/conf.d/ds.conf: no such file or directory

```

Est-ce qu’il y a un moyen de corriger ça ? A quoi sert ce dossier ?

Vraiment désolé de tatonner comme ça mais je commence à être serieusement perdu …

Merci encore pour l’aide 🙂

---

<div class="post-metadata">

### Author: ![nicolasbremond](https://forum.yunohost.org/letter_avatar_proxy/v4/letter/n/779978/32.png) [@nicolasbremond](https://forum.yunohost.org/u/nicolasbremond)
#### Post date: [March 21, 2022, 1:14pm UTC](https://forum.yunohost.org/t/resolved-onlyoffice-half-installed-and-dpkg-issue/19244/8 "2022-03-21T13:14:45Z")

</div>

> [@Problème restauration avec Borg 4.0.8 -\> 4.1 (testing)](https://forum.yunohost.org/t/probleme-restauration-avec-borg-4-0-8-4-1-testing/13502/19):
>
> Tu as onlyoffice ? Que donne : ls -l /etc/nginx/conf.d | grep "ds.conf"

J’ai trouvé sur ce sujet pas mal de réponse mais il dit

“Pour régler ton soucis il fallait supprimer le lien symbolique `/etc/nginx/conf.d/ds.conf`” mais je ne sais pas comment faire ça, une idée ?

---

<div class="post-metadata">

### Author: ![nicolasbremond](https://forum.yunohost.org/letter_avatar_proxy/v4/letter/n/779978/32.png) [@nicolasbremond](https://forum.yunohost.org/u/nicolasbremond)
#### Post date: [March 21, 2022, 1:29pm UTC](https://forum.yunohost.org/t/resolved-onlyoffice-half-installed-and-dpkg-issue/19244/9 "2022-03-21T13:29:53Z")

</div>

Bon j’ai fais

`unlink /etc/nginx/conf.d` et maintenant la commande `ls -l /etc/nginx/conf.d | grep "ds.conf"`ne renvoi plus d’erreur et en tapant `yunohost service restart nginx` j’ai de nouveau accès à la Webadmin et à mon site donc c’est résolu 😉

---

<div class="post-metadata">

### Author: ![system](https://forum.yunohost.org/uploads/default/original/2X/f/f59fe8e3ee6b100b4f574d30d6e30479c68b89f0.png) [@system](https://forum.yunohost.org/u/system)
#### Post date: [April 20, 2022, 1:30pm UTC](https://forum.yunohost.org/t/resolved-onlyoffice-half-installed-and-dpkg-issue/19244/10 "2022-04-20T13:30:12Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
