(Résolu) Messages d'erreur pendant backup

Bonsoir,

en faisant un backup de ma nouvelle installation de Yunohost 3 sur mon Pi (le boot est sur le Pi, le reste sur un disque dur branché au Pi), backup qui a réussi, j’ai ces messages d’erreur :

Yunohost encountered an internal error :confused:
Really sorry about that.
You should look for help on the forum or the chat to fix the situation, or report the bug on the bugtracker.
The following information might be useful for the person helping you :

Action
GET /backup/archives
{“locale”:“en”,“with_info”:""}
Traceback
Traceback (most recent call last):
File “/usr/lib/python2.7/dist-packages/moulinette/interfaces/api.py”, line 406, in process
ret = self.actionsmap.process(arguments, timeout=30, route=_route)
File “/usr/lib/python2.7/dist-packages/moulinette/actionsmap.py”, line 448, in process
arguments = vars(self.parser.parse_args(args, **kwargs))
File “/usr/lib/python2.7/dist-packages/moulinette/interfaces/api.py”, line 645, in parse_args
auth = msignals.authenticate(klass(), **auth_conf)
File “/usr/lib/python2.7/dist-packages/moulinette/core.py”, line 268, in authenticate
return self._authenticate(authenticator, help)
File “/usr/lib/python2.7/dist-packages/moulinette/interfaces/api.py”, line 450, in _do_authenticate
return authenticator(token=(s_id, s_hash))
File “/usr/lib/python2.7/dist-packages/moulinette/authenticators/init.py”, line 107, in call
password = self._retrieve_session(s_id, s_hash)
File “/usr/lib/python2.7/dist-packages/moulinette/authenticators/init.py”, line 155, in _retrieve_session
gpg = gnupg.GPG()
File “/usr/lib/python2.7/dist-packages/gnupg.py”, line 755, in init
raise OSError(msg)
OSError: Unable to run gpg - it may not be available.

Merci.

Bonjour,
La dernière ligne du message d’erreur semblerait dire que GPG n’est pas disponible. Est-ce que GPG est bien installé ? ça pourrait être une piste à vérifier.
Nath’

1 Like

Merci de ta réponse. Je n’ai plus ce message d’erreur depuis plusieurs jours. J’aurais du marquer résolu.