[RESOLU] Intégrer Domiticz dans YunoHost via l'application sur raspberry 3

Bonjour à tous,
Je n’ai pas eu beaucoup de retour sur mon app : je sais seulement que l’installation fonctionne pour 2 personnes sur une architecture amd64. Donc il y a des chances que ça marche pour toi si tu es sur une archi amd64 mais je ne peux rien garantir !
Le mieux comme dit Aleks est que tu testes sur un serveur de test proche de ta configuration (et me faire un retour pour pouvoir aider la prochaine personne :slight_smile: )
Pour info l’app compile depuis les sources, ce qui peut prendre pas mal de temps (>> 1/2h) si tu as une petite config.

1 Like

Ok merci pour les infos.
J’ai l’impression qu’il y a un malentendu.
Dans l’idée je ne veux pas forcément intégrer Domoticz à yunohost en tout cas pas dans ce cas-ci. Désolé anubis mais mon serveur est en prod je ne veux pas prendre le risque de tout casser car je ne saurai pas le réparer.
Non ce que je veux c’est installer domoticz sur le raspberry mais pas l’intégrer à yunohost. Ca, c’est bien possible non?
Yunohost est bien indépendant au reste du fonctionnement de la framboise?
Si oui il faut que je crée un utilisateur ?
Désolé le concept est encore très abstrait pour moi…

Ok ; oui c’est bien possible je le fais sur un serveur (installé avant que je créé l’app :stuck_out_tongue: ); de mémoire le seul truc particulier est d’ouvrir le port 8080 dans le parefeu de Yunohost, si l’accès http te suffit.
Je pense que le seul truc qui ne peut pas marcher est l’accès https comme le port 443 est déjà utilisé par Yunohost.

Bah heu oui et non, c’est à dire que yunohost permet de gérer un peu ce qui se passe sur ton système (par exemple, la conf nginx qui est le serveur web).

Tu ne peux pas vraiment installer Domoticz “sur la même machine mais en dehors de yunohost”, ça n’a pas vraiment de sens … C’est un peu comme si t’étais dans une entreprise et que tu veux “rajouter un piano dans le bureau du patron, mais sans être dans l’entreprise” :thinking: Tu peux dire que c’est pas pour l’entreprise, mais si le piano est trop gros ça gènera quand meme le boss qui veut aller s’asseoir derrière le bureau …

Tu peux installer l’app sur ton système à la main si tu veux, mais si tu casses un truc au passage, ça le cassera pour “tout le serveur” et pas juste ton app …

Il me semblait que ça n’avait pas de sens bien que ça ne me dérange pas de bousculer un peu les boss😀.
En fait pour être honnête je n’utilise yunohost qu’a 1% de ce qu’il peut faire (juste pour Nextcloud et ce qui me permet d’avoir un nom de domaine et toute une configuration qui va bien derrière et que je n’ai pas eu à faire à la main).
En ce qui concerne les autres possibilités de yunohost je verrai plus tard…
Pour l’heure j’aimerai me concentrer sur un serveur domotique.

Je pense que je vais racheter une Raspberry pour installer domoticz mais je vais effectivement avoir un soucis avec le port de l’https…(443) qui est déjà utilisé par le serveur yunohost.

De manière générale c’est vrai mais il se trouve que Domoticz fourni son propre serveur web et utilise une base de donnée locale, donc l’installation est très autonome (pour le meilleur et pour le pire).
En tout cas ce n’est pas que la théorie, ça marche bien chez moi :slight_smile:

Réflexion faite, je vais me lancer dans l’install de ton app anubis. Après tout, c’est aussi à nous utilisateurs de contribuer à l’amelioration du système et d’en faire profiter la communauté.
Un p’tit backup du serveur et c’est parti.
Je vous tiens au courant dans ce fil de l’evolution.
Je suis sur une Raspberry sur laquelle j’ai tout déporté sur un dd (plus rien ne tourne sur la sd.
Je vais croiser les doigts et serrer les miches. Je vous tiens au jus.

1 Like

Me revoilà. L’installation est terminée, j’ai bien ma tuile sur le portail yuno. Je n’ai en revanche pas accès à l’interface web et j’ai l’erreur 502 bad getaway nginx.
J’ai pourtant ouvert le port 8080 sur la box et autoriser ce port au firewall yunohost.
Pour ce qui est de la syntaxe dans le navigateur, je l’ai entrée de la manière suivante:
http://mon_Nom_De_Domaine/domoticz/:8080
Mais rien y fait.
Une erreur dans la syntaxe?
Une idée pour résoudre ce problème?

En vous remerciant.

Je suis pas sur qu’il y ai besoin de devoir ouvrir ou specifier le port, normalement c’est gere “tout seul” via le reverse proxy dans la conf nginx …

Donc http://mon_Nom_De_Domaine/domoticz/ devrait marcher (mais j’ai pas teste l’app)

Salut,
J’ai essayé avec cette syntaxe mais j’ai le même problème.
En fait, je pense que nginx me donne pas le droit de passer en http donc même si je spécifie bien http dans l’adresse du navigateur, nginx force l’utilisation de https et donc pas d’acces car je repasse sur le port 443…
Une solution pour pouvoir passer en http?
Merci

Mais quel est le probleme avec https ?

Dans le read me de l’appli d’anubis , il semblait indiquer que le support https n’est pas géré.
J’en déduit qu’il faut obligatoirement passer par le http

J’ai désinstallé et réinstallé l’appli mais je suis confronté au même message d’erreur: “502 bad getaway nginx”.
je vais attendre d’avoir un peu plus de temps pour une install à côté de yunohost pour voir ce que ça dit.

Quelques pistes :
Tu peux déjà regarder si domoticz est bien lancé :
ps aux |grep domoticz
et/ou
service domoticz status

Tu peux tenter de te connecter directement via http://ton_serveur:8080 (http://mon_Nom_De_Domaine/domoticz/:8080 me parait étrange c’est le lien qui est configuré sur le portail ? (je dois remettre en route la VM sur laquelle j’ai fait les tests pour t’aider plus ensuite)).

Merci pour ton retour,
effectivement, j’ai l’air d’avoir un problème avecle service domoticz.
Voici ce que me renvoit la commande ‘service domoticz status’:

Blockquote
● domoticz.service - Domoticz (Home automation system)
Loaded: loaded (/etc/systemd/system/domoticz.service; disabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Tue 2019-02-19 19:26:45 CET; 2h 31min ago
Process: 18758 ExecStart=/opt/yunohost/domoticz/domoticz -www PORT (code=exited, status=1/FAILURE)
Main PID: 18758 (code=exited, status=1/FAILURE)

voici pour la commande ps aux |grep domoticz

Blockquote
admin 19637 0.0 0.0 4368 576 pts/0 S+ 21:58 0:00 grep --color=auto domoticz

cela ne marche pas avec http://ton_serveur:8080 je suis presque sûr que la bonne syntaxe est: http://mon_Nom_De_Domaine/domoticz/:8080.

je veux bien que tu regardes ta VM dès que t’auras un peu de temps car je sèche de mon côté.
J’attends ton retour avant de désistaller mais je pense vraiment que le problème vient du fait que je n’arrive pas à démarrer le service, car j’ai essayer un ‘systeme start domoticz’ mais en vain.

merci

Process: 18758 ExecStart=/opt/yunohost/domoticz/domoticz -www PORT
C’est louche que tu aies PORT, tu devrais avoir 8080 à la place.
Tu peux vérifier le fichier de conf /etc/systemd/system/domoticz.service s’il y a bien le n° du port à la place de PORT.

Tu peux essayer de démarrer domoticz à la main :
cd /opt/yunohost/domoticz/
./domoticz -www 8080

(tu auras un warning disant qu’il ne peut pas démarrer le serveurs https, c’est normal car le port 443 est déjà utilisé par nginx pour YunoHost)

Dans le fichier de conf, je n’ai pas le numéro de port indiqué.
Je peux éditer ce fichier en lui indiquant le port 8080?
Sinon la commande pour redémarrer le service manuellement me renvoie des erreurs en continu…je suis obligé de forcer la fermeture du Shell.

Oui tu peux éditer pour voir.

Tu peux copier les erreurs retournées ? (car si le lancement à la main ne fonctionne pas, ça ne risque pas de marcher via le service)

Ok j’ai édité le fichier de conf et remplacé PORT par 8080 puis relancer le service via l’API Web et Bim… Itworks.
Magnifiquement résolu.

Ce que je comprends pas…Pourquoi mon URL est en https, je pensais qu’il n’y avait pas de support en https mais bon je prends quand même (peut être parce que ça passe par le serveur yunohost…). Je suis preneur pour des explications à l’occas.

PS: Anubis t’es un génie. J’aimerais tellement savoir implémenter un service à yunohost mais j’ai beaucoup à apprendre encore…Par curiosité c’est quoi le langage? Du bash?

Merci encore, je vais de ce pas acheter des capteurs pour rendre ma maison plus intelligente.

Content que ça marche pour toi :slight_smile:
Merci pour tes retours, je vais investiguer pourquoi le port n’était pas bien configuré automatiquement.

Pour voir comment faire un nouveau service tu peux te renseigner ici : https://yunohost.org/#/packaging_apps

Ce ne sont pas les capteurs qui font l’intelligence :wink:

2 Likes