Requirements for *** are not met, the package yunohost (3.4.2.4) must be> = 3.5.0

Hello I installed yunoHost on an Olinuxino LIME 2. After I have registered and want to install a program, I always get the message. Requirements for *** are not met, the package yunohost (3.4.2.4) must be> = 3.5.0
What can be the issue

Your yunohost is not up-to-date: you have version 3.4 and version 3.8 was released today. You can execute apt upgrade to upgrade.

I click on Upgrade the system, but it dident change the version

3.4 still had a weird upgrade mechanism (now fixed in more recent version)

Maybe you can try to run (through SSH) sudo apt dist-upgrade