Remove 'nextcloud' after a failed restore from a backup archive


My YunoHost server

Hardware: Old laptop or computer
YunoHost version:
I have access to my server : Through SSH | through the webadmin |
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : Yes
installed example flask app from ynh app list

Description of my issue

Tried to upgrade Nextcloud from webadmin

Expected behaviour:

App should be updated

Actual behaviour:

Update failed due to dependency issues with flask-ynh-deps.
Roll-back failed for unknown reason.
App was uninstalled.

WARNING - E: Packages need to be removed but remove is disabled.
2020-01-25 02:28:34,130: DEBUG - flask-ynh-deps
Not sure if I should expect to have lost all my files, ampache still plays files linked in nextcloud but searching the file system doesn’t return what I expect.

@mackemint welcome back.

Sorry to hear about your problem. The nextcloud upgrade seems to have be distrurbed by an unfinished apt operation. Can you try doing sudo apt -uVf install on your server to see if you can finish the apt operations, and maybe follow apt suggestions if it proposes to remove some “broken” packages ?

Does the example flask app have a github where we can check if the issue is known ?

@arthurlutz hi!
I solved it pretty quickly actually, took another look at the logs and saw this

2020-01-25 02:28:34,130: DEBUG - flask-ynh-deps

Ran pip remove on the flask-ynh-deps and could reinstall Nextcloud with all my files still intact.
The shared links i had no longer work unfortunately but that’s not that big of a deal.

The repo can be found here, seems like it’s pretty much abandoned:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.