Redémarrage ynh-vpnclient après mise à jour ficher.qube

#1

Mon serveur YunoHost

Matériel: Brique Internet avec VPN

Version de YunoHost:
yunohost
3.5.2.1 (now)
yunohost-admin
3.5.2 (stable)
moulinette
3.5.2 (stable)
ssowat
3.5.2.1 (stable)

J’ai accès à mon serveur : En SSH | Par la webadmin | uniquement en local pas d’accès depuis l’extérieur

Êtes-vous dans un contexte particulier ou avez-vous effectué des modificiations particulières sur votre instance ? : oui

Si oui, expliquer:
mise à jour vpn avec fichier.qube la mise à jour c’est passer sans problème et le soir tout fonctionnait et le lendemain cela ne fonctionnait plus et impossible de réactiver le service VPN dans l’interface web administrateur démarrage de l’application dans l’interface web utilisateur se solde par un échec message suivant:

erreur: configuration mise à jour mais le rechargement du service à échoué.

Description du problème

Plus d’accès VPN suite à mise à jour VPN avec ficher.qube
Je cherche à redémarrer l’application ynh-vpnclient et impossible de la redémarrer
voici le résutat obtenue après l’essai:

Impossible de démarrer le service ‘ynh-vpnclient’

Journaux historisés récents : – Logs begin at Fri 2019-05-10 20:00:08 CEST, end at Fri 2019-05-10 20:50:19 CEST. –
May 10 20:03:34 didiercl.me systemd[1]: Starting YunoHost VPN Client…
– Subject: Unit ynh-vpnclient.service has begun start-up
– Defined-By: systemd
– Support: https://www.debian.org/support

– Unit ynh-vpnclient.service has begun starting up.
May 10 20:03:35 didiercl.me ynh-vpnclient[30304]: Retrieving Yunohost settings… OK
May 10 20:03:35 didiercl.me ynh-vpnclient[30304]: [vpnclient] Starting…
May 10 20:03:35 didiercl.me ynh-vpnclient[30304]: Run openvpn
May 10 20:04:00 didiercl.me ynh-vpnclient[30304]: The firewall has been reloaded
May 10 20:04:00 didiercl.me ynh-vpnclient[30304]: opened_ports:
May 10 20:04:00 didiercl.me ynh-vpnclient[30304]: - 22
May 10 20:04:00 didiercl.me ynh-vpnclient[30304]: - 25
May 10 20:04:00 didiercl.me ynh-vpnclient[30304]: - 53
May 10 20:04:00 didiercl.me ynh-vpnclient[30304]: - 67
May 10 20:04:00 didiercl.me ynh-vpnclient[30304]: - 80
May 10 20:04:00 didiercl.me ynh-vpnclient[30304]: - 443
May 10 20:04:00 didiercl.me ynh-vpnclient[30304]: - 547
May 10 20:04:00 didiercl.me ynh-vpnclient[30304]: - 587
May 10 20:04:00 didiercl.me ynh-vpnclient[30304]: - 993
May 10 20:04:00 didiercl.me ynh-vpnclient[30304]: - 4253
May 10 20:04:00 didiercl.me ynh-vpnclient[30304]: - 4280

Quelqu’un à une idée?

Merci d’avance pour vos idées.

Bonne soirée.

didier58

#2

Il faudrait jeter un œil sur le contenu du fichier /var/log/openvpn-client.log, il y aura plus d’informations utiles pour comprendre pourquoi la connexion vpn ne s’établit pas.

#3

Bonsoir pitchum,

Je vais voir cela demain au courant de la journée.

Merci pour le conseil.

didier58

#4

Bonsoir pitchum,

Je reviens vers toi tardivement n’étant pas sur place je suis obligé d’intervenir à distance pour consulter et cela est un peu lourd la connexion n’étant pas au top là ou je suis.
Voici le résultat dans le fichier openvpn-client.log les dernières lignes:

Tue May 14 21:51:04 2019 WARNING: file ‘/etc/openvpn/keys/user.key’ is group or others accessible
Tue May 14 21:51:04 2019 OpenVPN 2.4.0 arm-unknown-linux-gnueabihf [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] built on Oct 14 2018
Tue May 14 21:51:04 2019 library versions: OpenSSL 1.0.2r 26 Feb 2019, LZO 2.08
Tue May 14 21:51:04 2019 TCP/UDP: Preserving recently used remote address: [AF_INET]89.234.141.4:443
Tue May 14 21:51:04 2019 Socket Buffers: R=[163840->163840] S=[163840->163840]
Tue May 14 21:51:04 2019 UDP link local: (not bound)
Tue May 14 21:51:04 2019 UDP link remote: [AF_INET]89.234.141.4:443
Tue May 14 21:51:25 2019 event_wait : Interrupted system call (code=4)
Tue May 14 21:51:25 2019 SIGTERM received, sending exit notification to peer
Tue May 14 21:51:27 2019 SIGTERM[soft,exit-with-notification] received, process exiting

Mais je ne vois pas comment continuer?

Bonne soirée.

didier58

#5

Re bonsoir pitchum,

j’ai également ce retour avec le client vpn en cliquant sur plus de détail:

[INFO] Autodetected internet interface: eth0 (last start: eth0)
[INFO] Autodetected IPv6 address for the VPN server: (last start: 2a00:5881:8100:1002::1)
[INFO] IPv6 delegated prefix found
[INFO] IPv6 address computed from the delegated prefix: 2a00:5881:8118:400::42
[INFO] Hotspot app detected
[INFO] No IPv6 address to set
[INFO] No native IPv6 detected
[INFO] No IPv6 server route to set
[ERR] No IPv6/IPv4 firewall set
[ERR] No host DNS set
[ERR] Openvpn is not running

les trois dernières lignes indique erreur.

didier58

#6

Essaye de remplacer UDP par TCP dans la configuration de vpnclient pour voir. Je suppute que si le serveur VPN écoute sur le port 443 c’est probablement en TCP pour pouvoir ressembler à du trafic HTTPS.

#7

Bonsoir Pitchum,

Malgré le changement de protocole TCP au lieu de UDP voir réponse du clientvpn:

Erreur: Configuration mise à jour mais le rechargement du service a échoué

En finale j’ai recharger le fichier cube (et non qube comme je lai ecrit précédament) là tout est rentré dans l’ordre mais c’est le protocole UDP qui est actif? A voir pour la suite.

Merci pour ton aide et bonne nuit.

didier58

1 Like