Raspberrypi - postinstall - unable to change main domain


I am installing yunohost on a raspberrypi using the raspbian base image.
On postinstall I get an error, that the main domain can’t be changed:

yunohost tools postinstall

Main domain: mydomain.org
New administration password: 
Confirm new administration password: 
Installing YunoHost...
Generating a 2048 bit RSA private key
writing new private key to '/usr/share/yunohost/yunohost-config/ssl/yunoCA/ca/cakey.pem'
Updating certificates in /etc/ssl/certs... 0 added, 0 removed; done.
Running hooks in /etc/ca-certificates/update.d....done.
Success! LDAP successfully initialized
The base directory '/home/yunohost.backup/tahoe' is not empty.
To avoid clobbering anything, I am going to quit now.
Please use a different directory, or empty this one.
[ ok ] Restarting Metronome XMPP Server: metronome.
[ ok ] Stopping Postfix Mail Transport Agent: postfix.
[ ok ] Starting Postfix Mail Transport Agent: postfix.
[ ok ] Restarting IMAP/POP3 mail server: dovecot.
Stopping amavisd: amavisd-new.
Starting amavisd: amavisd-new.
[....] Restarting nginx: nginxError: Unable to change main domain

Any idea, what causes this problem?

Thank you in advance.



Damn, I though this issue was solved… It’s due to an incompatible default nginx configuration for your system.
The similar main issue happens on system on which IPv6 support is disabled. As the default configuration defines to listen on IPv6 localhost, it causes failure on service restart. But this should be solved now…

You can try to have a look at your *.conf files in /etc/nginx/conf.d, or paste it here the one of your main domain if you don’t find anything.

Did you try with the YunoHost image for Raspberry Pi?


And here is the way to finish the installation manually, until this issue is fixed or at least managed in a better way:

  1. Tell that YunoHost is installed in order to be able to execute commands with the moulinette: sudo touch /etc/yunohost/installed
  2. If you’re using DynDNS - i.e. a subdomain offered by YunoHost - subscribe to it: sudo yunohost dyndns subscribe yourdomain.nohost.me /!\ replace yourdomain.nohost.me with the domain that you entered just before
  3. Generate SSOwat configuration: sudo yunohost app ssowatconf
  4. Set the administration password: sudo yunohost tools adminpw (the current one is yunohost)
  5. If you’re using uPnP - see https://doc.yunohost.org/#/isp_box_config - enable it: sudo yunohost firewall upnp enable
  6. Reload the firewall: sudo yunohost firewall reload
  7. Done!

Hi Jerome, thank you for your answer.

With you information I am able to connect, but get an error about a bad gateway when connecting to the api.

So far I haven’t tried the yunohost image. I don’t have a monitor for my Pi, and in the install documents it is said that you may have to change the network device. That’s why I didn’t try.

Kind regards.



I have the same problem with a Pi 1 without screen (I unfortunately did not arrive to connect with ssh with YunoHost image, so I used the big 3Go Raspian one).
@Jerome You forgot the ‘-d’ option for ‘yunohost dyndns subscribe’. Unfortunately, after your instructions I can not connect me throught the web interface, because yunohost/api/installed gives a bad gateway error. I created ‘/var/www/yunohost/api/installed’ and ‘/usr/share/yunohost/api/installed’ (in the 2 cases even the api folder did not exist), but I had the same error.