Problems migrating to V3.x / updating Nextcloud

Hardware :Raspberry Pi V3
Internet access :ethernet at home
YunoHost version:
yunohost (stable)
yunohost-admin 2.7.14 (stable)
moulinette 2.7.14 (stable)
ssowat 2.7.14 (stable)

If personalized, how:
Running Nextcloud with the data on a USB stick.

I tried migrating to stretch via the web interface (thanks to @ppr for the great help here). When I tried migrating, I got an error saying that
the current system was not totally up to date and the migration had thus failed.
Having already updated to YunoHost I checked again on the updates screen and the only thing which was not up to date was my Nextcloud app.

I tried updating this (again via the web interface; this is too good for me to go through the bother of sshing in and remembering the commands…).
I get a reply from the interface telling me than nextcloud could not be updated and had been reset to the previous state before the attempted update.

I found this line in the logs shown on the update applications screen:

  • datadir=/home/

My data is, however, not located there but here:
USB Stick with the data directory for Nextcloud
“sda1”: “Mounted on /media/OwncloudUSB, 58.3GiB (42.4GiB free)”
Could that maybe be the problem?

According to the Nextcloud manual which got installed in my data directory I’m running version 12 (installation was march of this year).

I guess that I probably need to do an apt-get update to get around this if that may be the problem but I guess that the sense of Yunohost is making it
easier for people who don’t want to dig into the innards of Linux to host their own data so maybe this info will help…

I have copied all the information out of the update screen if this should be required or I can ssh into the pi and get any other information / logs
which may help solve this for me and maybe others.

I just saw also this info - not quite sure where it came from but maybe it helps:
Die Konfigurationsdatei sollte für den Service dnsmasq aktualisiert werden

This sort of means that the config file for dnsmasq should be updated but I have no idea as to how and where I should do this.

Thanks in advance for your help getting my beloved Yunohost up to date.

Best regards


Hi all,

I got this fixed the brutal way by doing a new install with 3.1.
Best regards