# Problème première connexion phpLDAPadmin

**URL:** https://forum.yunohost.org/t/probleme-premiere-connexion-phpldapadmin/29557
**Category:** Support apps
**Tags:** phpldapadmin, french
**Created:** [May 5, 2024, 1:48pm UTC](https://forum.yunohost.org/t/probleme-premiere-connexion-phpldapadmin/29557 "2024-05-05T13:48:13Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![remy713705](https://forum.yunohost.org/letter_avatar_proxy/v4/letter/r/ee7513/32.png) [@remy713705](https://forum.yunohost.org/u/remy713705)
#### Post date: [May 5, 2024, 1:48pm UTC](https://forum.yunohost.org/t/probleme-premiere-connexion-phpldapadmin/29557/1 "2024-05-05T13:48:13Z")

</div>

### Mon serveur YunoHost

**Matériel:** Vieil ordinateur  
**Version de YunoHost:** 11.2.11.3  
**J’ai accès à mon serveur :** En SSH | Par la webadmin | En direct avec un clavier/écran  
**Si votre requête est liée à une application, précisez son nom et sa version:**  
**Version installée :** app phpLDAPadmin 1.2.6.7~ynh1

### Description du problème

Problème à la connexion de l’application.  
Nota : Les autres applications php (hors GLPI) fonctionnent bien.

**Deprecated** : Creation of dynamic property page::$index is deprecated in **/var/www/phpldapadmin/lib/page.php** on line **38**  
**Deprecated** : Creation of dynamic property page::$sysmsg is deprecated in **/var/www/phpldapadmin/lib/page.php** on line **468**  
**Deprecated** : Creation of dynamic property page::$\_block is deprecated in **/var/www/phpldapadmin/lib/page.php** on line **241**

```
Erreur

```

Numéro d’erreur inconnu: 8192: Creation of dynamic property page::$index is deprecated

PHP Debug Backtrace  
**Fichier** /var/www/phpldapadmin/lib/functions.php (192)  
**Chiffrement** error ([a:5:{i:0;s:87:"Numéro d’erreur inconnu: 8192: Cre…](https://patate.local/phpldapadmin/tools/unserialize.php?index=0))  
**Fichier** /var/www/phpldapadmin/lib/page.php (38)  
**Chiffrement** app\_error\_handler ([a:4:{i:0;i:8192;i:1;s:55:"Creation of dynamic prop…](https://patate.local/phpldapadmin/tools/unserialize.php?index=1))  
**Fichier** /var/www/phpldapadmin/htdocs/cmd.php (41)  
**Chiffrement** \_\_construct ([a:1:{i:0;i:1;}](https://patate.local/phpldapadmin/tools/unserialize.php?index=2))  
**Fichier** /var/www/phpldapadmin/htdocs/index.php (153)  
**Chiffrement** include ([a:1:{i:0;s:36:"/var/www/phpldapadmin/htdocs/cmd.ph…](https://patate.local/phpldapadmin/tools/unserialize.php?index=3))

quelqu’un à une idée ?

---

<div class="post-metadata">

### Author: ![rodinux](https://forum.yunohost.org/user_avatar/forum.yunohost.org/rodinux/32/7029_2.png) [@rodinux](https://forum.yunohost.org/u/rodinux)
#### Post date: [May 5, 2024, 7:46pm UTC](https://forum.yunohost.org/t/probleme-premiere-connexion-phpldapadmin/29557/2 "2024-05-05T19:46:12Z")

</div>

Depuis la dernière version il y a cette erreur, elle est signalée et une proposition de revenir à php7 pour ce soucis est toujours en attente

> <https://github.com/YunoHost-Apps/phpldapadmin_ynh/issues/28>
>
> \*\*How to post a meaningful bug report\*\*
> 1. \*Read this whole template first.\*
> 2…. \*Determine if you are on the right place:\*
> - \*If you were performing an action on the app from the webadmin or the CLI (install, update, backup, restore, change\_url...), you are on the right place!\*
> - \*Otherwise, the issue may be due to the app itself. Refer to its documentation or repository for help.\*
> - \*When in doubt, post here and we will figure it out together.\*
> 3. \*Delete the italic comments as you write over them below, and remove this guide.\*
> \--- 
> 
> \### Describe the bug
> 
> I've newly installed this app and it doesn't seem able to load any page. When I try to load it, I get three errors:
> 
> \* Deprecated: Creation of dynamic property page::$index is deprecated in /var/www/phpldapadmin/lib/page.php on line 38
> \* Deprecated: Creation of dynamic property page::$sysmsg is deprecated in /var/www/phpldapadmin/lib/page.php on line 468
> \* Deprecated: Creation of dynamic property page::$\_block is deprecated in /var/www/phpldapadmin/lib/page.php on line 241
> 
> Then, inside the page itself, I get a more extensive stack trace:
> 
> !\[Screenshot\_20240120-192249~2\](https://github.com/YunoHost-Apps/phpldapadmin\_ynh/assets/8678015/52f1d448-b791-4708-8634-f26cf3e58a1e)
> 
> (Screenshot from mobile, I'm trying to use the app because I currently don't have access to a laptop)
> 
> \### Context
> 
> \- Hardware: VPS bought online
> \- YunoHost version: 11.2.9.1
> \- I have access to my server: currently only through the webadmin, normally I also have SSH access
> \- Are you in a special context or did you perform some particular tweaking on your YunoHost instance?: no
> 
> \### Steps to reproduce
> 
> It happens when opening a newly installed instance.
> 
> \### Expected behavior
> 
> The page is loaded without errors.
> 
> \### Logs
> 
> There are no error logs, but here are the installation logs: https://paste.yunohost.org/raw/avoluyahac

Tu peux essayer le patch que est dans le PR

```auto
yunohost app install https://github.com/rodinux/phpldapadmin_ynh/tree/patch-1

```

ou en upgrade (là je ne suis pas sûr que ça fonctionne…

```auto
yunohost app upgrade phpldapadmin -u https://github.com/rodinux/phpldapadmin_ynh/tree/patch-1

```

---

<div class="post-metadata">

### Author: ![remy713705](https://forum.yunohost.org/letter_avatar_proxy/v4/letter/r/ee7513/32.png) [@remy713705](https://forum.yunohost.org/u/remy713705)
#### Post date: [May 5, 2024, 8:35pm UTC](https://forum.yunohost.org/t/probleme-premiere-connexion-phpldapadmin/29557/3 "2024-05-05T20:35:38Z")

</div>

Merci beaucoup pour la célérité de la réponse.

J’ai testé le patch en installation via SSH :

> [@rodinux](#):
>
> `yunohost app install https://github.com/rodinux/phpldapadmin_ynh/tree/patch-1`

Cela a très bien fonctionné

Merci beaucoup

---

<div class="post-metadata">

### Author: ![system](https://forum.yunohost.org/uploads/default/original/2X/f/f59fe8e3ee6b100b4f574d30d6e30479c68b89f0.png) [@system](https://forum.yunohost.org/u/system)
#### Post date: [May 20, 2024, 8:36pm UTC](https://forum.yunohost.org/t/probleme-premiere-connexion-phpldapadmin/29557/4 "2024-05-20T20:36:17Z")

</div>

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.
