# Probleme lors de la migration vers YH 3 / erreur dpkg-deb

**URL:** https://forum.yunohost.org/t/probleme-lors-de-la-migration-vers-yh-3-erreur-dpkg-deb/12163
**Category:** Support
**Tags:** french
**Created:** [July 22, 2020, 11:38pm UTC](https://forum.yunohost.org/t/probleme-lors-de-la-migration-vers-yh-3-erreur-dpkg-deb/12163 "2020-07-22T23:38:20Z")
**Posts on this page:** 20
**Page:** 2

<div class="post-metadata">

### Author: ![bouba](https://forum.yunohost.org/letter_avatar_proxy/v4/letter/b/a8b319/32.png) [@bouba](https://forum.yunohost.org/u/bouba)
#### Post date: [August 5, 2020, 12:59pm UTC](https://forum.yunohost.org/t/probleme-lors-de-la-migration-vers-yh-3-erreur-dpkg-deb/12163/21 "2020-08-05T12:59:27Z")

</div>

> [@Aleks](#):
>
> apt policy dovecot-sieve

Effectivement, il confirme qu’il y a une nouvelle version candidate…

```auto
dovecot-sieve:
  Installé : 1:2.2.13-12~deb8u6
  Candidat : 1:2.2.27-3+deb9u5
 Table de version :
     1:2.2.27-3+deb9u5 500
        500 http://ftp.fr.debian.org/debian stretch/main amd64 Packages
        500 http://security.debian.org stretch/updates/main amd64 Packages
 *** 1:2.2.13-12~deb8u6 100
        100 /var/lib/dpkg/status

```

pourtant je suis bien sur la debian 9 😕

```auto
Distributor ID: Debian
Description: Debian GNU/Linux 9.13 (n/a)
Release: 9.13
Codename: n/a

```

---

<div class="post-metadata">

### Author: ![Aleks](https://forum.yunohost.org/user_avatar/forum.yunohost.org/aleks/32/1704_2.png) [@Aleks](https://forum.yunohost.org/u/Aleks)
#### Post date: [August 5, 2020, 2:14pm UTC](https://forum.yunohost.org/t/probleme-lors-de-la-migration-vers-yh-3-erreur-dpkg-deb/12163/22 "2020-08-05T14:14:33Z")

</div>

Oké alors essayons de l’installer avec

```auto
apt install dovecot-managesieved dovecot-sieve

```

---

<div class="post-metadata">

### Author: ![bouba](https://forum.yunohost.org/letter_avatar_proxy/v4/letter/b/a8b319/32.png) [@bouba](https://forum.yunohost.org/u/bouba)
#### Post date: [August 5, 2020, 2:35pm UTC](https://forum.yunohost.org/t/probleme-lors-de-la-migration-vers-yh-3-erreur-dpkg-deb/12163/23 "2020-08-05T14:35:33Z")

</div>

J’ai essayé ta commande et suivi les conseils donnés à l’écran :

```auto
root@yunohostdlna:/home/mrbouba# apt install dovecot-managesieved dovecot-sieve
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 dovecot-antispam : Dépend: dovecot-abi-2.2.abiv13 mais il n'est pas installable
 dovecot-imapd : Dépend: dovecot-core (= 1:2.2.13-12~deb8u6) mais 1:2.2.27-3+deb9u5 devra être installé
 dovecot-ldap : Dépend: dovecot-core (= 1:2.2.13-12~deb8u6) mais 1:2.2.27-3+deb9u5 devra être installé
 dovecot-lmtpd : Dépend: dovecot-core (= 1:2.2.13-12~deb8u6) mais 1:2.2.27-3+deb9u5 devra être installé
 dovecot-sieve : Casse: dovecot-imapd (< 1:2.2.26.0-1~) mais 1:2.2.13-12~deb8u6 devra être installé
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).
root@yunohostdlna:/home/mrbouba# apt --fix-broken install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  fonts-droid-fallback libbind9-90 libdns100 libisc95 libisccc90 libisccfg90 liblwres90 libntdb1 libpth20 libxss1
  python-ntdb python-pyinotify x11-common
Veuillez utiliser « apt autoremove » pour les supprimer.
The following additional packages will be installed:
  dovecot-antispam dovecot-imapd dovecot-ldap dovecot-lmtpd dovecot-managesieved dovecot-sieve
Paquets suggérés :
  crm114 ufw
Les paquets suivants seront mis à jour :
  dovecot-antispam dovecot-imapd dovecot-ldap dovecot-lmtpd dovecot-managesieved dovecot-sieve
6 mis à jour, 0 nouvellement installés, 0 à enlever et 342 non mis à jour.
58 partiellement installés ou enlevés.
Il est nécessaire de prendre 4 085 ko dans les archives.
Après cette opération, 1 326 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n]
Réception de:1 http://ftp.fr.debian.org/debian stretch/main amd64 dovecot-imapd amd64 1:2.2.27-3+deb9u5 [814 kB]
Réception de:2 http://ftp.fr.debian.org/debian stretch/main amd64 dovecot-sieve amd64 1:2.2.27-3+deb9u5 [971 kB]
Réception de:3 http://ftp.fr.debian.org/debian stretch/main amd64 dovecot-managesieved amd64 1:2.2.27-3+deb9u5 [709 kB]
Réception de:4 http://ftp.fr.debian.org/debian stretch/main amd64 dovecot-ldap amd64 1:2.2.27-3+deb9u5 [878 kB]
Réception de:5 http://ftp.fr.debian.org/debian stretch/main amd64 dovecot-lmtpd amd64 1:2.2.27-3+deb9u5 [692 kB]
Réception de:6 http://ftp.fr.debian.org/debian stretch/main amd64 dovecot-antispam amd64 2.0+20170109-1 [21,6 kB]
4 085 ko réceptionnés en 1s (3 659 ko/s)
Lecture des fichiers de modifications (« changelog »)... Terminé
Paramétrage de dovecot-core (1:2.2.27-3+deb9u5) ...
Job for dovecot.service failed because the control process exited with error code.
See "systemctl status dovecot.service" and "journalctl -xe" for details.
invoke-rc.d: initscript dovecot, action "start" failed.
● dovecot.service - Dovecot IMAP/POP3 email server
   Loaded: loaded (/lib/systemd/system/dovecot.service; enabled; vendor preset: enabled)
  Drop-In: /etc/systemd/system/dovecot.service.d
           └─override.conf
   Active: failed (Result: exit-code) since Wed 2020-08-05 16:29:13 CEST; 10ms ago
     Docs: man:dovecot(1)
           http://wiki2.dovecot.org/
  Process: 24620 ExecStart=/usr/sbin/dovecot (code=exited, status=89)
 Main PID: 807 (code=exited, status=0/SUCCESS)

août 05 16:29:13 yunohostdlna systemd[1]: Starting Dovecot IMAP/POP3 email server...
août 05 16:29:13 yunohostdlna dovecot[24620]: doveconf: Error: Couldn't load plugin /usr/lib/dovecot/modules/…pend_c
août 05 16:29:13 yunohostdlna dovecot[24620]: doveconf: Error: Couldn't load plugin /usr/lib/dovecot/modules/…2.27))
août 05 16:29:13 yunohostdlna dovecot[24620]: doveconf: Fatal: Error in configuration file /etc/dovecot/dovec… sieve
août 05 16:29:13 yunohostdlna systemd[1]: dovecot.service: Control process exited, code=exited status=89
août 05 16:29:13 yunohostdlna systemd[1]: Failed to start Dovecot IMAP/POP3 email server.
août 05 16:29:13 yunohostdlna systemd[1]: dovecot.service: Unit entered failed state.
août 05 16:29:13 yunohostdlna systemd[1]: dovecot.service: Failed with result 'exit-code'.
Hint: Some lines were ellipsized, use -l to show in full.
dpkg: erreur de traitement du paquet dovecot-core (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 dovecot-core
E: Sub-process /usr/bin/dpkg returned an error code (1)

```

J’en ai profité pour sortir les logs signalés :

```auto
root@yunohostdlna:/home/mrbouba# systemctl status dovecot.service
● dovecot.service - Dovecot IMAP/POP3 email server
   Loaded: loaded (/lib/systemd/system/dovecot.service; enabled; vendor preset: enabled)
  Drop-In: /etc/systemd/system/dovecot.service.d
           └─override.conf
   Active: failed (Result: exit-code) since Wed 2020-08-05 16:29:13 CEST; 1min 40s ago
     Docs: man:dovecot(1)
           http://wiki2.dovecot.org/
  Process: 24620 ExecStart=/usr/sbin/dovecot (code=exited, status=89)
 Main PID: 807 (code=exited, status=0/SUCCESS)

août 05 16:29:13 yunohostdlna systemd[1]: Starting Dovecot IMAP/POP3 email server...
août 05 16:29:13 yunohostdlna dovecot[24620]: doveconf: Error: Couldn't load plugin /usr/lib/dovecot/modules/settings
août 05 16:29:13 yunohostdlna dovecot[24620]: doveconf: Error: Couldn't load plugin /usr/lib/dovecot/modules/settings
août 05 16:29:13 yunohostdlna dovecot[24620]: doveconf: Fatal: Error in configuration file /etc/dovecot/dovecot.conf:
août 05 16:29:13 yunohostdlna systemd[1]: dovecot.service: Control process exited, code=exited status=89
août 05 16:29:13 yunohostdlna systemd[1]: Failed to start Dovecot IMAP/POP3 email server.
août 05 16:29:13 yunohostdlna systemd[1]: dovecot.service: Unit entered failed state.
août 05 16:29:13 yunohostdlna systemd[1]: dovecot.service: Failed with result 'exit-code'.

```

et aussi :

```auto
root@yunohostdlna:/home/mrbouba# journalctl -xe
août 05 16:33:02 yunohostdlna sshd[25125]: Failed password for root from 178.128.14.102 port 45302 ssh2
août 05 16:33:03 yunohostdlna sshd[25125]: Received disconnect from 178.128.14.102 port 45302:11: Bye Bye [preauth]
août 05 16:33:03 yunohostdlna sshd[25125]: Disconnected from 178.128.14.102 port 45302 [preauth]
août 05 16:33:05 yunohostdlna sshd[25123]: reprocess config line 31: Deprecated option RSAAuthentication
août 05 16:33:05 yunohostdlna sshd[25123]: reprocess config line 38: Deprecated option RhostsRSAAuthentication
août 05 16:33:05 yunohostdlna sshd[25123]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh
août 05 16:33:07 yunohostdlna sshd[25127]: rexec line 19: Deprecated option KeyRegenerationInterval
août 05 16:33:07 yunohostdlna sshd[25127]: rexec line 20: Deprecated option ServerKeyBits
août 05 16:33:07 yunohostdlna sshd[25127]: rexec line 31: Deprecated option RSAAuthentication
août 05 16:33:07 yunohostdlna sshd[25127]: rexec line 38: Deprecated option RhostsRSAAuthentication
août 05 16:33:08 yunohostdlna sshd[25123]: Failed password for root from 133.242.52.96 port 55578 ssh2
août 05 16:33:08 yunohostdlna sshd[25123]: Received disconnect from 133.242.52.96 port 55578:11: Bye Bye [preauth]
août 05 16:33:08 yunohostdlna sshd[25123]: Disconnected from 133.242.52.96 port 55578 [preauth]
août 05 16:33:08 yunohostdlna sshd[25127]: reprocess config line 31: Deprecated option RSAAuthentication
août 05 16:33:08 yunohostdlna sshd[25127]: reprocess config line 38: Deprecated option RhostsRSAAuthentication
août 05 16:33:08 yunohostdlna sshd[25127]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh
août 05 16:33:09 yunohostdlna sshd[25127]: Failed password for root from 59.144.48.34 port 38290 ssh2
août 05 16:33:10 yunohostdlna sshd[25127]: Received disconnect from 59.144.48.34 port 38290:11: Bye Bye [preauth]
août 05 16:33:10 yunohostdlna sshd[25127]: Disconnected from 59.144.48.34 port 38290 [preauth]
août 05 16:33:48 yunohostdlna sshd[25129]: rexec line 19: Deprecated option KeyRegenerationInterval
août 05 16:33:48 yunohostdlna sshd[25129]: rexec line 20: Deprecated option ServerKeyBits
août 05 16:33:48 yunohostdlna sshd[25129]: rexec line 31: Deprecated option RSAAuthentication
août 05 16:33:48 yunohostdlna sshd[25129]: rexec line 38: Deprecated option RhostsRSAAuthentication
août 05 16:33:49 yunohostdlna sshd[25129]: reprocess config line 31: Deprecated option RSAAuthentication
août 05 16:33:49 yunohostdlna sshd[25129]: reprocess config line 38: Deprecated option RhostsRSAAuthentication
août 05 16:33:49 yunohostdlna sshd[25129]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh
août 05 16:33:51 yunohostdlna sshd[25129]: Failed password for root from 200.169.6.206 port 37116 ssh2
août 05 16:33:52 yunohostdlna sshd[25129]: Received disconnect from 200.169.6.206 port 37116:11: Bye Bye [preauth]
août 05 16:33:52 yunohostdlna sshd[25129]: Disconnected from 200.169.6.206 port 37116 [preauth]
août 05 16:33:53 yunohostdlna sshd[25131]: rexec line 19: Deprecated option KeyRegenerationInterval
août 05 16:33:53 yunohostdlna sshd[25131]: rexec line 20: Deprecated option ServerKeyBits
août 05 16:33:53 yunohostdlna sshd[25131]: rexec line 31: Deprecated option RSAAuthentication
août 05 16:33:53 yunohostdlna sshd[25131]: rexec line 38: Deprecated option RhostsRSAAuthentication
août 05 16:33:56 yunohostdlna sshd[25131]: reprocess config line 31: Deprecated option RSAAuthentication
août 05 16:33:56 yunohostdlna sshd[25131]: reprocess config line 38: Deprecated option RhostsRSAAuthentication
août 05 16:33:56 yunohostdlna sshd[25131]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh
août 05 16:33:58 yunohostdlna sshd[25131]: Failed password for root from 104.236.112.52 port 50575 ssh2
août 05 16:33:58 yunohostdlna sshd[25131]: Received disconnect from 104.236.112.52 port 50575:11: Bye Bye [preauth]
août 05 16:33:58 yunohostdlna sshd[25131]: Disconnected from 104.236.112.52 port 50575 [preauth]
août 05 16:34:01 yunohostdlna CRON[25133]: pam_unix(cron:session): session opened for user root by (uid=0)
août 05 16:34:01 yunohostdlna CRON[25134]: (root) CMD (yunohost dyndns update >> /dev/null)
août 05 16:34:03 yunohostdlna sshd[25139]: rexec line 19: Deprecated option KeyRegenerationInterval
août 05 16:34:03 yunohostdlna sshd[25139]: rexec line 20: Deprecated option ServerKeyBits
août 05 16:34:03 yunohostdlna sshd[25139]: rexec line 31: Deprecated option RSAAuthentication
août 05 16:34:03 yunohostdlna sshd[25139]: rexec line 38: Deprecated option RhostsRSAAuthentication
août 05 16:34:03 yunohostdlna CRON[25133]: pam_unix(cron:session): session closed for user root
août 05 16:34:03 yunohostdlna postfix/pickup[19097]: 9895C201F5A: uid=0 from=<root>
août 05 16:34:03 yunohostdlna slapd[28119]: <= mdb_equality_candidates: (mail) not indexed
août 05 16:34:03 yunohostdlna slapd[28119]: <= mdb_equality_candidates: (mail) not indexed
août 05 16:34:03 yunohostdlna postfix/cleanup[25143]: 9895C201F5A: message-id=<20200805143403.9895C201F5A@bouba.nohos
août 05 16:34:03 yunohostdlna postfix/qmgr[3626]: 9895C201F5A: from=<root@bouba.nohost.me>, size=630, nrcpt=1 (queue
août 05 16:34:03 yunohostdlna slapd[28119]: <= mdb_equality_candidates: (virtualdomain) not indexed
août 05 16:34:03 yunohostdlna dovecot[25145]: lda(bouba@bouba.nohost.me): Error: Couldn't load required plugin /usr/l
août 05 16:34:03 yunohostdlna dovecot[25145]: lda: Fatal: Internal error occurred. Refer to server log for more infor
août 05 16:34:03 yunohostdlna postfix/pipe[25144]: 9895C201F5A: to=<bouba@bouba.nohost.me>, orig_to=<root>, relay=dov
août 05 16:34:04 yunohostdlna sshd[25139]: reprocess config line 31: Deprecated option RSAAuthentication
août 05 16:34:04 yunohostdlna sshd[25139]: reprocess config line 38: Deprecated option RhostsRSAAuthentication
août 05 16:34:04 yunohostdlna sshd[25139]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh
août 05 16:34:06 yunohostdlna sshd[25139]: Failed password for root from 189.187.186.161 port 35513 ssh2
août 05 16:34:07 yunohostdlna sshd[25139]: Received disconnect from 189.187.186.161 port 35513:11: Bye Bye [preauth]
août 05 16:34:07 yunohostdlna sshd[25139]: Disconnected from 189.187.186.161 port 35513 [preauth]

```

---

<div class="post-metadata">

### Author: ![Aleks](https://forum.yunohost.org/user_avatar/forum.yunohost.org/aleks/32/1704_2.png) [@Aleks](https://forum.yunohost.org/u/Aleks)
#### Post date: [August 5, 2020, 3:28pm UTC](https://forum.yunohost.org/t/probleme-lors-de-la-migration-vers-yh-3-erreur-dpkg-deb/12163/24 "2020-08-05T15:28:05Z")

</div>

Bon, tentons une autre approche : éditons le fichier de conf de dovecot avec :

```auto
nano /etc/dovecot/dovecot.conf

```

puis à peu près vers le début, tu devrais trouver une ligne avec genre :

```auto
protocols = imap sieve

```

et l’objectif est d’enlever le mot “sieve”, puis d’enregister/quiter avec Ctrl+X (puis Y/Entrée pour valider)

Ensuite tu fait un `systemctl restart dovecot` puis `systemctl status dovecot` pour voir si il est content

---

<div class="post-metadata">

### Author: ![bouba](https://forum.yunohost.org/letter_avatar_proxy/v4/letter/b/a8b319/32.png) [@bouba](https://forum.yunohost.org/u/bouba)
#### Post date: [August 5, 2020, 4:04pm UTC](https://forum.yunohost.org/t/probleme-lors-de-la-migration-vers-yh-3-erreur-dpkg-deb/12163/25 "2020-08-05T16:04:09Z")

</div>

J’ai bien enlevé le mot sieve, mais toujours pas content ☹

```auto
root@yunohostdlna:/home/mrbouba# systemctl restart dovecot
Job for dovecot.service failed because the control process exited with error code.
See "systemctl status dovecot.service" and "journalctl -xe" for details.
root@yunohostdlna:/home/mrbouba# systemctl status dovecot
● dovecot.service - Dovecot IMAP/POP3 email server
   Loaded: loaded (/lib/systemd/system/dovecot.service; enabled; vendor preset: enabled)
  Drop-In: /etc/systemd/system/dovecot.service.d
           └─override.conf
   Active: failed (Result: exit-code) since Wed 2020-08-05 17:42:41 CEST; 14s ago
     Docs: man:dovecot(1)
           http://wiki2.dovecot.org/
  Process: 31755 ExecStart=/usr/sbin/dovecot (code=exited, status=89)
 Main PID: 807 (code=exited, status=0/SUCCESS)

août 05 17:42:41 yunohostdlna systemd[1]: Starting Dovecot IMAP/POP3 email server...
août 05 17:42:41 yunohostdlna dovecot[31755]: doveconf: Error: Couldn't load plugin /usr/lib/dovecot/modules/settings
août 05 17:42:41 yunohostdlna dovecot[31755]: doveconf: Error: Couldn't load plugin /usr/lib/dovecot/modules/settings
août 05 17:42:41 yunohostdlna dovecot[31755]: Fatal: service(imap-hibernate) access(/usr/lib/dovecot/imap-hibernate)
août 05 17:42:41 yunohostdlna dovecot[31755]: master: Fatal: service(imap-hibernate) access(/usr/lib/dovecot/imap-hib
août 05 17:42:41 yunohostdlna systemd[1]: dovecot.service: Control process exited, code=exited status=89
août 05 17:42:41 yunohostdlna systemd[1]: Failed to start Dovecot IMAP/POP3 email server.
août 05 17:42:41 yunohostdlna systemd[1]: dovecot.service: Unit entered failed state.
août 05 17:42:41 yunohostdlna systemd[1]: dovecot.service: Failed with result 'exit-code'.

```

---

<div class="post-metadata">

### Author: ![Aleks](https://forum.yunohost.org/user_avatar/forum.yunohost.org/aleks/32/1704_2.png) [@Aleks](https://forum.yunohost.org/u/Aleks)
#### Post date: [August 5, 2020, 5:53pm UTC](https://forum.yunohost.org/t/probleme-lors-de-la-migration-vers-yh-3-erreur-dpkg-deb/12163/26 "2020-08-05T17:53:12Z")

</div>

Est-ce que tu peux faire un

`journalctl -u dovecot --no-pager --no-hostname -n 30`

pour qu’on ai les messages complets ?

---

<div class="post-metadata">

### Author: ![bouba](https://forum.yunohost.org/letter_avatar_proxy/v4/letter/b/a8b319/32.png) [@bouba](https://forum.yunohost.org/u/bouba)
#### Post date: [August 5, 2020, 6:07pm UTC](https://forum.yunohost.org/t/probleme-lors-de-la-migration-vers-yh-3-erreur-dpkg-deb/12163/27 "2020-08-05T18:07:47Z")

</div>

voili voilou 🙂 et bien sûr toujours merci de ton aide !

```auto
-- Logs begin at Wed 2020-08-05 16:12:47 CEST, end at Wed 2020-08-05 20:06:46 CE ST. --
août 05 16:29:13 systemd[1]: Failed to start Dovecot IMAP/POP3 email server.
août 05 16:29:13 systemd[1]: dovecot.service: Unit entered failed state.
août 05 16:29:13 systemd[1]: dovecot.service: Failed with result 'exit-code'.
août 05 17:42:41 systemd[1]: Starting Dovecot IMAP/POP3 email server...
août 05 17:42:41 dovecot[31755]: doveconf: Error: Couldn't load plugin /usr/lib/ dovecot/modules/settings/libmanagesieve_login_settings.so: dlopen() failed: /usr /lib/dovecot/modules/settings/libmanagesieve_login_settings.so: undefined symbol : str_append_c
août 05 17:42:41 dovecot[31755]: doveconf: Error: Couldn't load plugin /usr/lib/ dovecot/modules/settings/libmanagesieve_settings.so: Module is for different ABI version 2.2.ABIv13(2.2.13) (we have 2.2.ABIv27(2.2.27))
août 05 17:42:41 dovecot[31755]: Fatal: service(imap-hibernate) access(/usr/lib/ dovecot/imap-hibernate) failed: No such file or directory
août 05 17:42:41 dovecot[31755]: master: Fatal: service(imap-hibernate) access(/ usr/lib/dovecot/imap-hibernate) failed: No such file or directory
août 05 17:42:41 systemd[1]: dovecot.service: Control process exited, code=exite d status=89
août 05 17:42:41 systemd[1]: Failed to start Dovecot IMAP/POP3 email server.
août 05 17:42:41 systemd[1]: dovecot.service: Unit entered failed state.
août 05 17:42:41 systemd[1]: dovecot.service: Failed with result 'exit-code'.
août 05 17:45:32 systemd[1]: Starting Dovecot IMAP/POP3 email server...
août 05 17:45:32 dovecot[31826]: doveconf: Error: Couldn't load plugin /usr/lib/ dovecot/modules/settings/libmanagesieve_login_settings.so: dlopen() failed: /usr /lib/dovecot/modules/settings/libmanagesieve_login_settings.so: undefined symbol : str_append_c
août 05 17:45:32 dovecot[31826]: doveconf: Error: Couldn't load plugin /usr/lib/ dovecot/modules/settings/libmanagesieve_settings.so: Module is for different ABI version 2.2.ABIv13(2.2.13) (we have 2.2.ABIv27(2.2.27))
août 05 17:45:32 dovecot[31826]: Fatal: service(imap-hibernate) access(/usr/lib/ dovecot/imap-hibernate) failed: No such file or directory
août 05 17:45:32 dovecot[31826]: master: Fatal: service(imap-hibernate) access(/ usr/lib/dovecot/imap-hibernate) failed: No such file or directory
août 05 17:45:32 systemd[1]: dovecot.service: Control process exited, code=exite d status=89
août 05 17:45:32 systemd[1]: Failed to start Dovecot IMAP/POP3 email server.
août 05 17:45:32 systemd[1]: dovecot.service: Unit entered failed state.
août 05 17:45:32 systemd[1]: dovecot.service: Failed with result 'exit-code'.
août 05 17:45:55 systemd[1]: Starting Dovecot IMAP/POP3 email server...
août 05 17:45:55 dovecot[31836]: doveconf: Error: Couldn't load plugin /usr/lib/ dovecot/modules/settings/libmanagesieve_login_settings.so: dlopen() failed: /usr /lib/dovecot/modules/settings/libmanagesieve_login_settings.so: undefined symbol : str_append_c
août 05 17:45:55 dovecot[31836]: doveconf: Error: Couldn't load plugin /usr/lib/ dovecot/modules/settings/libmanagesieve_settings.so: Module is for different ABI version 2.2.ABIv13(2.2.13) (we have 2.2.ABIv27(2.2.27))
août 05 17:45:55 dovecot[31836]: Fatal: service(imap-hibernate) access(/usr/lib/ dovecot/imap-hibernate) failed: No such file or directory
août 05 17:45:55 dovecot[31836]: master: Fatal: service(imap-hibernate) access(/ usr/lib/dovecot/imap-hibernate) failed: No such file or directory
août 05 17:45:55 systemd[1]: dovecot.service: Control process exited, code=exite d status=89
août 05 17:45:55 systemd[1]: Failed to start Dovecot IMAP/POP3 email server.
août 05 17:45:55 systemd[1]: dovecot.service: Unit entered failed state.
août 05 17:45:55 systemd[1]: dovecot.service: Failed with result 'exit-code'.

```

---

<div class="post-metadata">

### Author: ![Aleks](https://forum.yunohost.org/user_avatar/forum.yunohost.org/aleks/32/1704_2.png) [@Aleks](https://forum.yunohost.org/u/Aleks)
#### Post date: [August 5, 2020, 6:52pm UTC](https://forum.yunohost.org/t/probleme-lors-de-la-migration-vers-yh-3-erreur-dpkg-deb/12163/28 "2020-08-05T18:52:55Z")

</div>

Hmpf bon c’est relou

On va s’y prendre autrement et faire un :

```auto
systemctl edit dovecot

```

tu va te retrouver dans un éditeur de texte (normalement comme nano)

Normalement c’est initialement vide et tu rajoutes les deux lignes suivantes :

```auto
[Service]
ExecStart=/bin/true

```

Puis `systemctl daemon-reload`, et `systemctl restart dovecot`

Ensuite on peut tenter un `apt install --fix-broken`

Et ça devrait déjà débloquer la situation

(Et à un moment il faudra refaire un `systemctl edit dovecot`, enlever les deux lignes et refaire un `systemctl daemon-reload && systemctl restart dovecot`, mais déjà voyons où les trucs d’avant nous ammènent)

---

<div class="post-metadata">

### Author: ![bouba](https://forum.yunohost.org/letter_avatar_proxy/v4/letter/b/a8b319/32.png) [@bouba](https://forum.yunohost.org/u/bouba)
#### Post date: [August 5, 2020, 7:16pm UTC](https://forum.yunohost.org/t/probleme-lors-de-la-migration-vers-yh-3-erreur-dpkg-deb/12163/29 "2020-08-05T19:16:39Z")

</div>

Oui c’est relou… Et c’est pas fini ☹  
J’ai fait l’edit. Mis les 2 lignes (copier/coller pour éviter les erreurs de frappe)  
Ensuite, j’ai fait le reload/restart et j’ai eu une erreur 😢  
J’ai sorti le status comme indiqué dans le message réponse et j’ai enchainé malgré tout sur la commande install --fix-broken  
Malheureusement, cela plante…  
Je te joins l’ensemble de ce que j’ai fait :

```auto
root@yunohostdlna:/home/mrbouba# systemctl edit dovecot
root@yunohostdlna:/home/mrbouba# systemctl daemon-reload
root@yunohostdlna:/home/mrbouba# systemctl restart dovecot
Failed to restart dovecot.service: Unit dovecot.service is not loaded properly: Invalid argument.
See system logs and 'systemctl status dovecot.service' for details.
root@yunohostdlna:/home/mrbouba# systemctl status dovecot.service
● dovecot.service - Dovecot IMAP/POP3 email server
   Loaded: error (Reason: Invalid argument)
  Drop-In: /etc/systemd/system/dovecot.service.d
           └─override.conf
   Active: failed (Result: exit-code) since Wed 2020-08-05 17:45:55 CEST; 3h 24min ago
     Docs: man:dovecot(1)
           http://wiki2.dovecot.org/
 Main PID: 807 (code=exited, status=0/SUCCESS)

août 05 17:45:55 yunohostdlna dovecot[31836]: doveconf: Error: Couldn't load plugin /usr/lib/dovecot/modules/settings
août 05 17:45:55 yunohostdlna dovecot[31836]: doveconf: Error: Couldn't load plugin /usr/lib/dovecot/modules/settings
août 05 17:45:55 yunohostdlna dovecot[31836]: Fatal: service(imap-hibernate) access(/usr/lib/dovecot/imap-hibernate)
août 05 17:45:55 yunohostdlna dovecot[31836]: master: Fatal: service(imap-hibernate) access(/usr/lib/dovecot/imap-hib
août 05 17:45:55 yunohostdlna systemd[1]: dovecot.service: Control process exited, code=exited status=89
août 05 17:45:55 yunohostdlna systemd[1]: Failed to start Dovecot IMAP/POP3 email server.
août 05 17:45:55 yunohostdlna systemd[1]: dovecot.service: Unit entered failed state.
août 05 17:45:55 yunohostdlna systemd[1]: dovecot.service: Failed with result 'exit-code'.
août 05 21:09:55 yunohostdlna systemd[1]: dovecot.service: Service has more than one ExecStart= setting, which is onl
août 05 21:10:09 yunohostdlna systemd[1]: dovecot.service: Service has more than one ExecStart= setting, which is onl
root@yunohostdlna:/home/mrbouba# systemctl restart dovecot
Failed to restart dovecot.service: Unit dovecot.service is not loaded properly: Invalid argument.
See system logs and 'systemctl status dovecot.service' for details.
root@yunohostdlna:/home/mrbouba# apt install --fix-broken
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  fonts-droid-fallback libbind9-90 libdns100 libisc95 libisccc90 libisccfg90 liblwres90 libntdb1 libpth20 libxss1
  python-ntdb python-pyinotify x11-common
Veuillez utiliser « apt autoremove » pour les supprimer.
The following additional packages will be installed:
  dovecot-antispam dovecot-imapd dovecot-ldap dovecot-lmtpd dovecot-managesieved dovecot-sieve
Paquets suggérés :
  crm114 ufw
Les paquets suivants seront mis à jour :
  dovecot-antispam dovecot-imapd dovecot-ldap dovecot-lmtpd dovecot-managesieved dovecot-sieve
6 mis à jour, 0 nouvellement installés, 0 à enlever et 342 non mis à jour.
58 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/4 085 ko dans les archives.
Après cette opération, 1 326 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Lecture des fichiers de modifications (« changelog »)... Terminé
Paramétrage de dovecot-core (1:2.2.27-3+deb9u5) ...
Failed to start dovecot.service: Unit dovecot.service is not loaded properly: Invalid argument.
See system logs and 'systemctl status dovecot.service' for details.
invoke-rc.d: initscript dovecot, action "start" failed.
● dovecot.service - Dovecot IMAP/POP3 email server
   Loaded: error (Reason: Invalid argument)
  Drop-In: /etc/systemd/system/dovecot.service.d
           └─override.conf
   Active: failed (Result: exit-code) since Wed 2020-08-05 17:45:55 CEST; 3h 25min ago
     Docs: man:dovecot(1)
           http://wiki2.dovecot.org/
 Main PID: 807 (code=exited, status=0/SUCCESS)

août 05 17:45:55 yunohostdlna dovecot[31836]: Fatal: service(imap-hibernate) access(/usr/lib/dovecot/imap-hib…ectory
août 05 17:45:55 yunohostdlna dovecot[31836]: master: Fatal: service(imap-hibernate) access(/usr/lib/dovecot/…ectory
août 05 17:45:55 yunohostdlna systemd[1]: dovecot.service: Control process exited, code=exited status=89
août 05 17:45:55 yunohostdlna systemd[1]: Failed to start Dovecot IMAP/POP3 email server.
août 05 17:45:55 yunohostdlna systemd[1]: dovecot.service: Unit entered failed state.
août 05 17:45:55 yunohostdlna systemd[1]: dovecot.service: Failed with result 'exit-code'.
août 05 21:09:55 yunohostdlna systemd[1]: dovecot.service: Service has more than one ExecStart= setting, whi…fusing.
août 05 21:10:09 yunohostdlna systemd[1]: dovecot.service: Service has more than one ExecStart= setting, whi…fusing.
août 05 21:11:14 yunohostdlna systemd[1]: dovecot.service: Service has more than one ExecStart= setting, whi…fusing.
août 05 21:11:14 yunohostdlna systemd[1]: dovecot.service: Service has more than one ExecStart= setting, whi…fusing.
Hint: Some lines were ellipsized, use -l to show in full.
dpkg: erreur de traitement du paquet dovecot-core (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 dovecot-core
E: Sub-process /usr/bin/dpkg returned an error code (1)

```

---

<div class="post-metadata">

### Author: ![bouba](https://forum.yunohost.org/letter_avatar_proxy/v4/letter/b/a8b319/32.png) [@bouba](https://forum.yunohost.org/u/bouba)
#### Post date: [August 5, 2020, 7:18pm UTC](https://forum.yunohost.org/t/probleme-lors-de-la-migration-vers-yh-3-erreur-dpkg-deb/12163/30 "2020-08-05T19:18:54Z")

</div>

J’oubliais de demander… Faut-il que je laisse ou j’enlève les modif faites lors de l’edit ?

---

<div class="post-metadata">

### Author: ![Aleks](https://forum.yunohost.org/user_avatar/forum.yunohost.org/aleks/32/1704_2.png) [@Aleks](https://forum.yunohost.org/u/Aleks)
#### Post date: [August 5, 2020, 11:22pm UTC](https://forum.yunohost.org/t/probleme-lors-de-la-migration-vers-yh-3-erreur-dpkg-deb/12163/31 "2020-08-05T23:22:27Z")

</div>

Zblerg mon idée était en fait foireuse (systemd veut pas plusieurs arguments ExecStart)

Donc on défaut les modifs avec `systemctl edit dovecot` (enlever les lignes puis sauvegarder)

Ensuite on va plutot faire les modifs directement dans le “vrai” fichier :

```auto
nano /lib/systemd/system/dovecot.service

```

Tu vas trouver dans le fichier, dans la section [Service] :

```auto
ExecStart=/usr/sbin/dovecot -F

```

Tu la commentes (rajouter un # devant) et rajoute `ExecStart=/bin/true` :

```nohighlight
#ExecStart=/usr/sbin/dovecot -F
ExecStart=/bin/true

```

Tu sauvegardes/quitte, puis `systemctl daemon-reload`, puis `systemctl restart dovecot` et on peut retenter le `apt install --fix-broken`

---

<div class="post-metadata">

### Author: ![bouba](https://forum.yunohost.org/letter_avatar_proxy/v4/letter/b/a8b319/32.png) [@bouba](https://forum.yunohost.org/u/bouba)
#### Post date: [August 6, 2020, 7:25am UTC](https://forum.yunohost.org/t/probleme-lors-de-la-migration-vers-yh-3-erreur-dpkg-deb/12163/32 "2020-08-06T07:25:46Z")

</div>

Toujours une erreur au démarrage.

```auto
root@yunohostdlna:/home/mrbouba# systemctl restart dovecot
Job for dovecot.service failed because of unavailable resources or another system error.
See "systemctl status dovecot.service" and "journalctl -xe" for details.
root@yunohostdlna:/home/mrbouba# apt install --fix-broken
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  fonts-droid-fallback libbind9-90 libdns100 libisc95 libisccc90 libisccfg90 liblwres90 libntdb1 libpth20 libxss1
  python-ntdb python-pyinotify x11-common
Veuillez utiliser « apt autoremove » pour les supprimer.
The following additional packages will be installed:
  dovecot-antispam dovecot-imapd dovecot-ldap dovecot-lmtpd dovecot-managesieved dovecot-sieve
Paquets suggérés :
  crm114 ufw
Les paquets suivants seront mis à jour :
  dovecot-antispam dovecot-imapd dovecot-ldap dovecot-lmtpd dovecot-managesieved dovecot-sieve
6 mis à jour, 0 nouvellement installés, 0 à enlever et 342 non mis à jour.
58 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/4 085 ko dans les archives.
Après cette opération, 1 326 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Lecture des fichiers de modifications (« changelog »)... Terminé
Paramétrage de dovecot-core (1:2.2.27-3+deb9u5) ...
Job for dovecot.service failed because of unavailable resources or another system error.
See "systemctl status dovecot.service" and "journalctl -xe" for details.
invoke-rc.d: initscript dovecot, action "start" failed.
● dovecot.service - Dovecot IMAP/POP3 email server
   Loaded: loaded (/lib/systemd/system/dovecot.service; enabled; vendor preset: enabled)
  Drop-In: /etc/systemd/system/dovecot.service.d
           └─override.conf
   Active: failed (Result: resources) since Thu 2020-08-06 09:11:35 CEST; 9ms ago
     Docs: man:dovecot(1)
           http://wiki2.dovecot.org/
  Process: 2556 ExecStart=/bin/true (code=exited, status=0/SUCCESS)
 Main PID: 807 (code=exited, status=0/SUCCESS)

août 06 09:11:35 yunohostdlna systemd[1]: Starting Dovecot IMAP/POP3 email server...
août 06 09:11:35 yunohostdlna systemd[1]: dovecot.service: PID file /var/run/dovecot/master.pid not readable…rectory
août 06 09:11:35 yunohostdlna systemd[1]: Failed to start Dovecot IMAP/POP3 email server.
août 06 09:11:35 yunohostdlna systemd[1]: dovecot.service: Unit entered failed state.
août 06 09:11:35 yunohostdlna systemd[1]: dovecot.service: Failed with result 'resources'.
Hint: Some lines were ellipsized, use -l to show in full.
dpkg: erreur de traitement du paquet dovecot-core (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 dovecot-core
E: Sub-process /usr/bin/dpkg returned an error code (1)

```

Ceci dit ce n’est pas la même erreur qu’avant… Est-ce une avancée ?

---

<div class="post-metadata">

### Author: ![Aleks](https://forum.yunohost.org/user_avatar/forum.yunohost.org/aleks/32/1704_2.png) [@Aleks](https://forum.yunohost.org/u/Aleks)
#### Post date: [August 6, 2020, 5:11pm UTC](https://forum.yunohost.org/t/probleme-lors-de-la-migration-vers-yh-3-erreur-dpkg-deb/12163/33 "2020-08-06T17:11:22Z")

</div>

Hmpf ~\_~

Bon refaisons `nano /lib/systemd/system/dovecot.service`

Puis tu commentes la ligne juste en dessous du ExecStart qui commence par PIDFile=

(en rajoutant un #) devant

Tu sauvegardes/quitte, puis `systemctl daemon-reload` , puis `systemctl restart dovecot` et on peut retenter le `apt install --fix-broken`

---

<div class="post-metadata">

### Author: ![bouba](https://forum.yunohost.org/letter_avatar_proxy/v4/letter/b/a8b319/32.png) [@bouba](https://forum.yunohost.org/u/bouba)
#### Post date: [August 13, 2020, 5:29pm UTC](https://forum.yunohost.org/t/probleme-lors-de-la-migration-vers-yh-3-erreur-dpkg-deb/12163/34 "2020-08-13T17:29:36Z")

</div>

Salut Aleks,

J’ai dû m’absenter et je n’avais pas internet pour faire les manip, donc je les fait seulement aujourd’hui 🙂

Voici les logs de ce qu’il s’est passé à partir du restart.

```auto
root@yunohostdlna:/home/mrbouba# systemctl restart dovecot
Job for dovecot.service failed because the control process exited with error code.
See "systemctl status dovecot.service" and "journalctl -xe" for details.
root@yunohostdlna:/home/mrbouba# apt install --fix-broken
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  fonts-droid-fallback libbind9-90 libdns100 libisc95 libisccc90 libisccfg90 liblwres90 libntdb1 libpth20 libxss1
  python-ntdb python-pyinotify x11-common
Veuillez utiliser « apt autoremove » pour les supprimer.
The following additional packages will be installed:
  dovecot-antispam dovecot-imapd dovecot-ldap dovecot-lmtpd dovecot-managesieved dovecot-sieve
Paquets suggérés :
  crm114 ufw
Les paquets suivants seront mis à jour :
  dovecot-antispam dovecot-imapd dovecot-ldap dovecot-lmtpd dovecot-managesieved dovecot-sieve
6 mis à jour, 0 nouvellement installés, 0 à enlever et 342 non mis à jour.
58 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/4 085 ko dans les archives.
Après cette opération, 1 326 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n]
Lecture des fichiers de modifications (« changelog »)... Terminé
Paramétrage de dovecot-core (1:2.2.27-3+deb9u5) ...
Job for dovecot.service failed because the control process exited with error code.
See "systemctl status dovecot.service" and "journalctl -xe" for details.
invoke-rc.d: initscript dovecot, action "start" failed.
● dovecot.service - Dovecot IMAP/POP3 email server
   Loaded: loaded (/lib/systemd/system/dovecot.service; enabled; vendor preset: enabled)
  Drop-In: /etc/systemd/system/dovecot.service.d
           └─override.conf
   Active: failed (Result: exit-code) since Thu 2020-08-13 19:27:02 CEST; 10ms ago
     Docs: man:dovecot(1)
           http://wiki2.dovecot.org/
  Process: 22708 ExecStop=/usr/bin/doveadm stop (code=exited, status=75)
  Process: 22706 ExecStart=/bin/true (code=exited, status=0/SUCCESS)
 Main PID: 807 (code=exited, status=0/SUCCESS)

août 13 19:27:02 yunohostdlna systemd[1]: Starting Dovecot IMAP/POP3 email server...
août 13 19:27:02 yunohostdlna doveadm[22708]: doveconf: Error: Couldn't load plugin /usr/lib/dovecot/modules/…pend_c
août 13 19:27:02 yunohostdlna doveadm[22708]: doveconf: Error: Couldn't load plugin /usr/lib/dovecot/modules/…2.27))
août 13 19:27:02 yunohostdlna doveadm[22708]: Fatal: Dovecot is not running (read from /var/run/dovecot/master.pid)
août 13 19:27:02 yunohostdlna systemd[1]: dovecot.service: Control process exited, code=exited status=75
août 13 19:27:02 yunohostdlna systemd[1]: Failed to start Dovecot IMAP/POP3 email server.
août 13 19:27:02 yunohostdlna systemd[1]: dovecot.service: Unit entered failed state.
août 13 19:27:02 yunohostdlna systemd[1]: dovecot.service: Failed with result 'exit-code'.
Hint: Some lines were ellipsized, use -l to show in full.
dpkg: erreur de traitement du paquet dovecot-core (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 dovecot-core
E: Sub-process /usr/bin/dpkg returned an error code (1)

```

A très vite !  
Bouba

---

<div class="post-metadata">

### Author: ![Aleks](https://forum.yunohost.org/user_avatar/forum.yunohost.org/aleks/32/1704_2.png) [@Aleks](https://forum.yunohost.org/u/Aleks)
#### Post date: [August 14, 2020, 10:25am UTC](https://forum.yunohost.org/t/probleme-lors-de-la-migration-vers-yh-3-erreur-dpkg-deb/12163/35 "2020-08-14T10:25:13Z")

</div>

Zblerg bon on va essayer autre chose :

à la place de /bin/true, on va mettre `/bin/sleep 120`

Tu sauvegardes/quitte, puis `systemctl daemon-reload` , puis `systemctl restart dovecot` et on peut retenter le `apt install --fix-broken`

---

<div class="post-metadata">

### Author: ![bouba](https://forum.yunohost.org/letter_avatar_proxy/v4/letter/b/a8b319/32.png) [@bouba](https://forum.yunohost.org/u/bouba)
#### Post date: [August 14, 2020, 1:09pm UTC](https://forum.yunohost.org/t/probleme-lors-de-la-migration-vers-yh-3-erreur-dpkg-deb/12163/36 "2020-08-14T13:09:01Z")

</div>

J’ai modifié la ligne execstart comme tu le disais mais par contre j’ai laissé l’autre ligne en commenté. Est ce que c’est bon ?

Lors du restart, cela a bien mis deux minutes à me mettre le message d’erreur. et lors du reinstall aussi cela a mis un délai à me mettre les message d’erreur.

```auto
root@yunohostdlna:/home/mrbouba# systemctl restart dovecot
Job for dovecot.service failed because a timeout was exceeded.
See "systemctl status dovecot.service" and "journalctl -xe" for details.
root@yunohostdlna:/home/mrbouba# apt install --fix-broken
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  fonts-droid-fallback libbind9-90 libdns100 libisc95 libisccc90 libisccfg90 liblwres90 libntdb1 libpth20 libxss1
  python-ntdb python-pyinotify x11-common
Veuillez utiliser « apt autoremove » pour les supprimer.
The following additional packages will be installed:
  dovecot-antispam dovecot-imapd dovecot-ldap dovecot-lmtpd dovecot-managesieved dovecot-sieve
Paquets suggérés :
  crm114 ufw
Les paquets suivants seront mis à jour :
  dovecot-antispam dovecot-imapd dovecot-ldap dovecot-lmtpd dovecot-managesieved dovecot-sieve
6 mis à jour, 0 nouvellement installés, 0 à enlever et 342 non mis à jour.
58 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/4 085 ko dans les archives.
Après cette opération, 1 326 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n]
Lecture des fichiers de modifications (« changelog »)... Terminé
Paramétrage de dovecot-core (1:2.2.27-3+deb9u5) ...
Job for dovecot.service failed because a timeout was exceeded.
See "systemctl status dovecot.service" and "journalctl -xe" for details.
invoke-rc.d: initscript dovecot, action "start" failed.
● dovecot.service - Dovecot IMAP/POP3 email server
   Loaded: loaded (/lib/systemd/system/dovecot.service; enabled; vendor preset: enabled)
  Drop-In: /etc/systemd/system/dovecot.service.d
           └─override.conf
   Active: failed (Result: timeout) since Fri 2020-08-14 15:03:28 CEST; 11ms ago
     Docs: man:dovecot(1)
           http://wiki2.dovecot.org/
  Process: 23983 ExecStart=/bin/sleep 120 (code=killed, signal=TERM)
 Main PID: 807 (code=exited, status=0/SUCCESS)

août 14 15:01:58 yunohostdlna systemd[1]: Starting Dovecot IMAP/POP3 email server...
août 14 15:03:28 yunohostdlna systemd[1]: dovecot.service: Start operation timed out. Terminating.
août 14 15:03:28 yunohostdlna systemd[1]: Failed to start Dovecot IMAP/POP3 email server.
août 14 15:03:28 yunohostdlna systemd[1]: dovecot.service: Unit entered failed state.
août 14 15:03:28 yunohostdlna systemd[1]: dovecot.service: Failed with result 'timeout'.
dpkg: erreur de traitement du paquet dovecot-core (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 dovecot-core
E: Sub-process /usr/bin/dpkg returned an error code (1)

```

retour du journalctl -xe au cas où cela puisse aider…

```auto
root@yunohostdlna:/home/mrbouba# journalctl -xe
août 14 15:06:00 yunohostdlna dovecot[24594]: lda: Fatal: Internal error occurred. Refer to server log for more infor
août 14 15:06:00 yunohostdlna postfix/pipe[24129]: 55C81200B6B: to=<bouba@bouba.nohost.me>, orig_to=<root@bouba.nohos
août 14 15:06:00 yunohostdlna postfix/pipe[24190]: 57880201C2C: to=<bouba@bouba.nohost.me>, orig_to=<root>, relay=dov
août 14 15:06:00 yunohostdlna dovecot[24595]: lda(bouba@bouba.nohost.me): Error: Couldn't load required plugin /usr/l
août 14 15:06:00 yunohostdlna dovecot[24595]: lda: Fatal: Internal error occurred. Refer to server log for more infor
août 14 15:06:00 yunohostdlna postfix/pipe[24149]: 56A542027D6: to=<bouba@bouba.nohost.me>, orig_to=<root>, relay=dov
août 14 15:06:00 yunohostdlna postfix/pipe[24093]: 5A23520279E: to=<bouba@bouba.nohost.me>, orig_to=<root>, relay=dov
août 14 15:06:00 yunohostdlna postfix/pipe[24116]: 95CE320094A: to=<bouba@bouba.nohost.me>, orig_to=<root@bouba.nohos
août 14 15:06:00 yunohostdlna postfix/pipe[24078]: 7DAFD200944: to=<bouba@bouba.nohost.me>, orig_to=<root@bouba.nohos
août 14 15:06:00 yunohostdlna postfix/pipe[24162]: 59FDE201A8A: to=<bouba@bouba.nohost.me>, orig_to=<root>, relay=dov
août 14 15:06:01 yunohostdlna CRON[24596]: pam_unix(cron:session): session opened for user root by (uid=0)
août 14 15:06:01 yunohostdlna CRON[24597]: (root) CMD (yunohost dyndns update >> /dev/null)
août 14 15:06:04 yunohostdlna postfix/pickup[17532]: 42B5B2019F0: uid=0 from=<root>
août 14 15:06:04 yunohostdlna CRON[24596]: pam_unix(cron:session): session closed for user root
août 14 15:06:04 yunohostdlna slapd[28119]: <= mdb_equality_candidates: (mail) not indexed
août 14 15:06:04 yunohostdlna slapd[28119]: <= mdb_equality_candidates: (mail) not indexed
août 14 15:06:04 yunohostdlna postfix/cleanup[24428]: 42B5B2019F0: message-id=<20200814130604.42B5B2019F0@bouba.nohos
août 14 15:06:04 yunohostdlna postfix/qmgr[5967]: 42B5B2019F0: from=<root@bouba.nohost.me>, size=630, nrcpt=1 (queue
août 14 15:06:04 yunohostdlna slapd[28119]: <= mdb_equality_candidates: (virtualdomain) not indexed
août 14 15:06:04 yunohostdlna dovecot[24605]: lda(bouba@bouba.nohost.me): Error: Couldn't load required plugin /usr/l
août 14 15:06:04 yunohostdlna dovecot[24605]: lda: Fatal: Internal error occurred. Refer to server log for more infor
août 14 15:06:04 yunohostdlna postfix/pipe[24208]: 42B5B2019F0: to=<bouba@bouba.nohost.me>, orig_to=<root>, relay=dov
août 14 15:06:14 yunohostdlna sshd[24606]: rexec line 19: Deprecated option KeyRegenerationInterval
août 14 15:06:14 yunohostdlna sshd[24606]: rexec line 20: Deprecated option ServerKeyBits
août 14 15:06:14 yunohostdlna sshd[24606]: rexec line 31: Deprecated option RSAAuthentication
août 14 15:06:14 yunohostdlna sshd[24606]: rexec line 38: Deprecated option RhostsRSAAuthentication
août 14 15:06:15 yunohostdlna sshd[24606]: reprocess config line 31: Deprecated option RSAAuthentication
août 14 15:06:15 yunohostdlna sshd[24606]: reprocess config line 38: Deprecated option RhostsRSAAuthentication
août 14 15:06:15 yunohostdlna sshd[24606]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh
août 14 15:06:16 yunohostdlna sshd[24608]: rexec line 19: Deprecated option KeyRegenerationInterval
août 14 15:06:16 yunohostdlna sshd[24608]: rexec line 20: Deprecated option ServerKeyBits
août 14 15:06:16 yunohostdlna sshd[24608]: rexec line 31: Deprecated option RSAAuthentication
août 14 15:06:16 yunohostdlna sshd[24608]: rexec line 38: Deprecated option RhostsRSAAuthentication
août 14 15:06:17 yunohostdlna sshd[24606]: Failed password for root from 167.249.66.0 port 3905 ssh2
août 14 15:06:17 yunohostdlna sshd[24606]: Received disconnect from 167.249.66.0 port 3905:11: Bye Bye [preauth]
août 14 15:06:17 yunohostdlna sshd[24606]: Disconnected from 167.249.66.0 port 3905 [preauth]
août 14 15:06:18 yunohostdlna sshd[24608]: reprocess config line 31: Deprecated option RSAAuthentication
août 14 15:06:18 yunohostdlna sshd[24608]: reprocess config line 38: Deprecated option RhostsRSAAuthentication
août 14 15:06:18 yunohostdlna nslcd[28592]: [33b07f] <passwd="123456QW!"> request denied by validnames option
août 14 15:06:18 yunohostdlna sshd[24608]: Invalid user 123456QW! from 200.7.217.185 port 36900
août 14 15:06:18 yunohostdlna sshd[24608]: input_userauth_request: invalid user 123456QW! [preauth]
août 14 15:06:18 yunohostdlna sshd[24608]: pam_unix(sshd:auth): check pass; user unknown
août 14 15:06:18 yunohostdlna sshd[24608]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh
août 14 15:06:18 yunohostdlna nslcd[28592]: [700e5f] <authc="123456QW!"> request denied by validnames option
août 14 15:06:20 yunohostdlna sshd[24608]: Failed password for invalid user 123456QW! from 200.7.217.185 port 36900 s
août 14 15:06:20 yunohostdlna sshd[24608]: Received disconnect from 200.7.217.185 port 36900:11: Bye Bye [preauth]
août 14 15:06:20 yunohostdlna sshd[24608]: Disconnected from 200.7.217.185 port 36900 [preauth]
août 14 15:06:26 yunohostdlna sshd[24611]: rexec line 19: Deprecated option KeyRegenerationInterval
août 14 15:06:26 yunohostdlna sshd[24611]: rexec line 20: Deprecated option ServerKeyBits
août 14 15:06:26 yunohostdlna sshd[24611]: rexec line 31: Deprecated option RSAAuthentication
août 14 15:06:26 yunohostdlna sshd[24611]: rexec line 38: Deprecated option RhostsRSAAuthentication
août 14 15:06:28 yunohostdlna sshd[24611]: reprocess config line 31: Deprecated option RSAAuthentication
août 14 15:06:28 yunohostdlna sshd[24611]: reprocess config line 38: Deprecated option RhostsRSAAuthentication
août 14 15:06:28 yunohostdlna sshd[24611]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh
août 14 15:06:28 yunohostdlna sshd[24613]: rexec line 19: Deprecated option KeyRegenerationInterval
août 14 15:06:28 yunohostdlna sshd[24613]: rexec line 20: Deprecated option ServerKeyBits
août 14 15:06:28 yunohostdlna sshd[24613]: rexec line 31: Deprecated option RSAAuthentication
août 14 15:06:28 yunohostdlna sshd[24613]: rexec line 38: Deprecated option RhostsRSAAuthentication
août 14 15:06:29 yunohostdlna sshd[24613]: reprocess config line 31: Deprecated option RSAAuthentication
août 14 15:06:29 yunohostdlna sshd[24613]: reprocess config line 38: Deprecated option RhostsRSAAuthentication
août 14 15:06:29 yunohostdlna sshd[24613]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh

```

---

<div class="post-metadata">

### Author: ![bouba](https://forum.yunohost.org/letter_avatar_proxy/v4/letter/b/a8b319/32.png) [@bouba](https://forum.yunohost.org/u/bouba)
#### Post date: [August 21, 2020, 8:47pm UTC](https://forum.yunohost.org/t/probleme-lors-de-la-migration-vers-yh-3-erreur-dpkg-deb/12163/37 "2020-08-21T20:47:23Z")

</div>

Salut salut 🙂

Je suis désolé de relancer, mais je voudrais savoir si tu avais une autre idée pour forcer la mise à jour de devcot ?

Tcho et encore et toujours un grand merci pour toute l’aide apportée !

---

<div class="post-metadata">

### Author: ![bouba](https://forum.yunohost.org/letter_avatar_proxy/v4/letter/b/a8b319/32.png) [@bouba](https://forum.yunohost.org/u/bouba)
#### Post date: [August 29, 2020, 10:31am UTC](https://forum.yunohost.org/t/probleme-lors-de-la-migration-vers-yh-3-erreur-dpkg-deb/12163/38 "2020-08-29T10:31:57Z")

</div>

Up 😊

---

<div class="post-metadata">

### Author: ![bouba](https://forum.yunohost.org/letter_avatar_proxy/v4/letter/b/a8b319/32.png) [@bouba](https://forum.yunohost.org/u/bouba)
#### Post date: [September 5, 2020, 3:41pm UTC](https://forum.yunohost.org/t/probleme-lors-de-la-migration-vers-yh-3-erreur-dpkg-deb/12163/39 "2020-09-05T15:41:35Z")

</div>

Salut à tous,

Si quelqu’un a pouvait me conseiller la suite des opérations ? Même s’il s’agit de tout réinstaller… Je suis ouvert à tout conseil 🙂

---

<div class="post-metadata">

### Author: ![Aleks](https://forum.yunohost.org/user_avatar/forum.yunohost.org/aleks/32/1704_2.png) [@Aleks](https://forum.yunohost.org/u/Aleks)
#### Post date: [September 5, 2020, 3:47pm UTC](https://forum.yunohost.org/t/probleme-lors-de-la-migration-vers-yh-3-erreur-dpkg-deb/12163/40 "2020-09-05T15:47:54Z")

</div>

Zblerg j’ai quelques idées en tête mais le plus simple serait que tu viennes sur le chat de support pour qu’on puisse en discuter et itérer facilement ?

[https://yunohost.org/#/chat\_rooms](https://yunohost.org/#/chat_rooms)

[Previous page](https://forum.yunohost.org/t/probleme-lors-de-la-migration-vers-yh-3-erreur-dpkg-deb/12163.md?page=1)

[Next page](https://forum.yunohost.org/t/probleme-lors-de-la-migration-vers-yh-3-erreur-dpkg-deb/12163.md?page=3)
