Problème installation Discourse

Bonjour,

Je rencontre un problème lors de l’installation de Discourse.
Je ne réussis pas non plus à installer Mattermost (je vais créer une autre entrée pour ça) mais peut-être est-ce lié ? (pour info, j’ai réussi à installer Nextcloud sans problème).
Merci d’avance pour vos lumières !

Mon serveur YunoHost

Matériel: VPS acheté en ligne
Version de YunoHost: 4.04
J’ai accès à mon serveur : En SSH | Par la webadmin
Êtes-vous dans un contexte particulier ou avez-vous effectué des modificiations particulières sur votre instance ? : non

2020-08-30 09:53:42,243: DEBUG - Suggested packages:
2020-08-30 09:53:42,243: DEBUG -   clang-7-doc debtags libcurl4-doc libidn11-dev libkrb5-dev libldap2-dev
2020-08-30 09:53:42,243: DEBUG -   librtmp-dev libssh2-1-dev pkg-config gpm icu-doc ncurses-doc libomp-7-doc
2020-08-30 09:53:42,243: WARNING - E: Packages need to be removed but remove is disabled.
2020-08-30 09:53:42,244: DEBUG -   postgresql-doc-11 readline-doc libssl-doc libyaml-doc llvm-7-doc ctags
2020-08-30 09:53:42,244: DEBUG -   vim-doc vim-scripts
2020-08-30 09:53:42,244: DEBUG - The following packages will be REMOVED:
2020-08-30 09:53:42,244: DEBUG -   libcurl4-nss-dev onlyoffice-ynh-deps
2020-08-30 09:53:42,244: DEBUG - The following NEW packages will be installed:
2020-08-30 09:53:42,244: DEBUG -   binfmt-support brotli clang-7 dctrl-tools gifsicle icu-devtools jhead
2020-08-30 09:53:42,245: DEBUG -   jpegoptim lib32gcc1 lib32stdc++6 libapr1 libapr1-dev libc6-i386
2020-08-30 09:53:42,245: DEBUG -   libclang-common-7-dev libclang1-7 libcurl4-openssl-dev libffi-dev libgpm2
2020-08-30 09:53:42,245: DEBUG -   libicu-dev libjemalloc-dev libjpeg-turbo-progs libncurses-dev libobjc-8-dev
2020-08-30 09:53:42,245: DEBUG -   libobjc4 libomp-7-dev libomp5-7 libpq-dev libreadline-dev libsctp-dev
2020-08-30 09:53:42,245: DEBUG -   libssl-dev libturbojpeg0 libxml2-dev libxslt1-dev libyaml-dev llvm-7
2020-08-30 09:53:42,245: DEBUG -   llvm-7-dev llvm-7-runtime optipng postgresql-contrib
2020-08-30 09:53:42,246: DEBUG -   postgresql-server-dev-11 postgresql-server-dev-all uuid-dev vim vim-runtime
2020-08-30 09:53:42,246: DEBUG -   zlib1g-dev
2020-08-30 09:53:42,246: DEBUG - 0 upgraded, 45 newly installed, 2 to remove and 0 not upgraded.
2020-08-30 09:53:42,246: DEBUG - ++ dpkg --info /tmp/tmp.oBIAjLS1IG/discourse-ynh-deps_2.3.10~ynh2_all.deb
2020-08-30 09:53:42,246: DEBUG - ++ sed 's/^ Depends: //'
2020-08-30 09:53:42,246: DEBUG - ++ sed s/,//g
2020-08-30 09:53:42,347: DEBUG - ++ grep Depends
2020-08-30 09:53:42,347: DEBUG - + local 'dependencies=g++ libjemalloc1 | libjemalloc2 libjemalloc-dev zlib1g-dev libreadline-dev libpq-dev libssl-dev libyaml-dev libcurl4-openssl-dev libapr1-dev libxslt1-dev libxml2-dev vim imagemagick postgresql postgresql-server-dev-all postgresql-contrib optipng jhead jpegoptim gifsicle brotli'
2020-08-30 09:53:42,347: DEBUG - + sed --quiet '/--fix-broken/,$p'
2020-08-30 09:53:42,347: DEBUG - + ynh_package_install g++ libjemalloc1 '|' libjemalloc2 libjemalloc-dev zlib1g-dev libreadline-dev libpq-dev libssl-dev libyaml-dev libcurl4-openssl-dev libapr1-dev libxslt1-dev libxml2-dev vim imagemagick postgresql postgresql-server-dev-all postgresql-contrib optipng jhead jpegoptim gifsicle brotli --dry-run
2020-08-30 09:53:42,348: DEBUG - + ynh_apt --no-remove --option Dpkg::Options::=--force-confdef --option Dpkg::Options::=--force-confold install g++ libjemalloc1 '|' libjemalloc2 libjemalloc-dev zlib1g-dev libreadline-dev libpq-dev libssl-dev libyaml-dev libcurl4-openssl-dev libapr1-dev libxslt1-dev libxml2-dev vim imagemagick postgresql postgresql-server-dev-all postgresql-contrib optipng jhead jpegoptim gifsicle brotli --dry-run
2020-08-30 09:53:42,348: DEBUG - + ynh_wait_dpkg_free
2020-08-30 09:53:42,449: DEBUG - + return 0
2020-08-30 09:53:42,449: DEBUG - + LC_ALL=C
2020-08-30 09:53:42,449: DEBUG - + DEBIAN_FRONTEND=noninteractive
2020-08-30 09:53:42,449: DEBUG - + apt-get --assume-yes --quiet -o=Acquire::Retries=3 -o=Dpkg::Use-Pty=0 --no-remove --option Dpkg::Options::=--force-confdef --option Dpkg::Options::=--force-confold install g++ libjemalloc1 '|' libjemalloc2 libjemalloc-dev zlib1g-dev libreadline-dev libpq-dev libssl-dev libyaml-dev libcurl4-openssl-dev libapr1-dev libxslt1-dev libxml2-dev vim imagemagick postgresql postgresql-server-dev-all postgresql-contrib optipng jhead jpegoptim gifsicle brotli --dry-run
2020-08-30 09:53:42,951: DEBUG - + ynh_die '--message=Unable to install dependencies'
2020-08-30 09:53:42,951: WARNING - E: Package 'libjemalloc1' has no installation candidate
2020-08-30 09:53:42,952: WARNING - Unable to install dependencies
2020-08-30 09:53:42,953: DEBUG - + ret_code=1
2020-08-30 09:53:42,953: DEBUG - + echo 'Unable to install dependencies'
2020-08-30 09:53:42,953: DEBUG - + exit 1
2020-08-30 09:53:42,953: DEBUG - + ynh_exit_properly
2020-08-30 09:53:42,953: DEBUG - + local exit_code=1
2020-08-30 09:53:42,954: DEBUG - + '[' 1 -eq 0 ']'
2020-08-30 09:53:42,954: DEBUG - + trap '' EXIT
2020-08-30 09:53:42,954: DEBUG - + set +o errexit
2020-08-30 09:53:42,954: DEBUG - + set +o nounset
2020-08-30 09:53:42,954: DEBUG - + sleep 0.5
2020-08-30 09:53:43,456: DEBUG - + type -t ynh_clean_setup
2020-08-30 09:53:43,456: DEBUG - + ynh_clean_setup
2020-08-30 09:53:43,456: DEBUG - + ynh_clean_check_starting
2020-08-30 09:53:43,456: DEBUG - + '[' -n '' ']'
2020-08-30 09:53:43,456: DEBUG - + '[' -n '' ']'
2020-08-30 09:53:43,457: DEBUG - + exit 1
2020-08-30 09:53:43,489: ERROR - Impossible d’installer discourse : Une erreur est survenue dans le script d’installation de l’application

Est-ce que tu peux partager le log complet de l’installation ? (Accessible dans ta webadmin, dans Outils > Journaux > [l’etape d’install échouée] > Partager avec Yunopaste)

comme ça ?
Et sinon, Mattermost, c’est bon !! mon erreur était de mettre un login et nom un email complet lors de la procédure d’installation…

args:
  app: discourse
  args: domain=forum.maindomain.tld&path=%2F&admin=adepetigny&is_public=1
  force: false
  label: Forum
  no_remove_on_failure: false
ended_at: 2020-08-30 13:53:43.489841
env:
  YNH_APP_ARG_ADMIN: adepetigny
  YNH_APP_ARG_DOMAIN: forum.maindomain.tld
  YNH_APP_ARG_IS_PUBLIC: 1
  YNH_APP_ARG_PATH: /
  YNH_APP_ID: discourse
  YNH_APP_INSTANCE_NAME: discourse
  YNH_APP_INSTANCE_NUMBER: '1'
  YNH_CWD: /var/cache/yunohost/from_file/discourse_ynh-bb90548957788dde5e6fc83f61fb5c28b3e4a469/scripts
  YNH_INTERFACE: api
  YNH_STDINFO: /tmp/tmpsvvuwO/stdinfo
  YNH_STDRETURN: /tmp/tmpdTTq5t/stdreturn
error: "Une erreur est survenue dans le script d\u2019installation de l\u2019application"
operation: app_install
related_to:
- - app
  - discourse
started_at: 2020-08-30 13:53:36.561652
success: false
yunohost_version: 4.0.4

============

2020-08-30 09:53:36,570: INFO - Installation de l’application discourse …
2020-08-30 09:53:36,613: DEBUG - The permission database has been resynchronized
2020-08-30 09:53:36,632: DEBUG - La configuration de SSOwat générée
2020-08-30 09:53:36,641: DEBUG - No default hook for action 'post_app_addaccess' in /usr/share/yunohost/hooks/
2020-08-30 09:53:36,642: DEBUG - No custom hook for action 'post_app_addaccess' in /etc/yunohost/hooks.d/
2020-08-30 09:53:36,642: DEBUG - Permission 'discourse.main' créée
2020-08-30 09:53:36,643: DEBUG - Journal complet de cette opération : '<a href="#/tools/logs/20200830-135336-permission_create-discourse" style="text-decoration:underline"> Créer permission 'discourse' </a>'
2020-08-30 09:53:36,653: DEBUG - Exécution de la commande 'sh -c YNH_APP_INSTANCE_NUMBER=1 YNH_CWD=/var/cache/yunohost/from_file/discourse_ynh-bb90548957788dde5e6fc83f61fb5c28b3e4a469/scripts YNH_APP_ARG_IS_PUBLIC=1 YNH_STDINFO=/tmp/tmpsvvuwO/stdinfo YNH_APP_INSTANCE_NAME=discourse YNH_APP_ARG_ADMIN=adepetigny YNH_INTERFACE=api YNH_APP_ID=discourse YNH_APP_ARG_PATH=/ YNH_STDRETURN=/tmp/tmpdTTq5t/stdreturn YNH_APP_ARG_DOMAIN=forum.maindomain.tld BASH_XTRACEFD=7 /bin/bash -x "./install" forum.maindomain.tld / adepetigny 1 discourse 7>&1' …
2020-08-30 09:53:36,653: DEBUG - About to run the command '['sh', '-c', 'YNH_APP_INSTANCE_NUMBER=1 YNH_CWD=/var/cache/yunohost/from_file/discourse_ynh-bb90548957788dde5e6fc83f61fb5c28b3e4a469/scripts YNH_APP_ARG_IS_PUBLIC=1 YNH_STDINFO=/tmp/tmpsvvuwO/stdinfo YNH_APP_INSTANCE_NAME=discourse YNH_APP_ARG_ADMIN=adepetigny YNH_INTERFACE=api YNH_APP_ID=discourse YNH_APP_ARG_PATH=/ YNH_STDRETURN=/tmp/tmpdTTq5t/stdreturn YNH_APP_ARG_DOMAIN=forum.maindomain.tld BASH_XTRACEFD=7 /bin/bash -x "./install" forum.maindomain.tld / adepetigny 1 discourse 7>&1']'
2020-08-30 09:53:36,767: DEBUG - + source _common.sh
2020-08-30 09:53:36,767: DEBUG - ++ pkg_dependencies='g++ libjemalloc1|libjemalloc2 libjemalloc-dev zlib1g-dev libreadline-dev libpq-dev libssl-dev libyaml-dev libcurl4-openssl-dev libapr1-dev libxslt1-dev libxml2-dev vim imagemagick postgresql postgresql-server-dev-all postgresql-contrib optipng jhead jpegoptim gifsicle brotli'
2020-08-30 09:53:36,768: DEBUG - ++ RUBY_VERSION=2.6.5
2020-08-30 09:53:36,768: DEBUG - ++ rbenv_install_dir=/opt/rbenv
2020-08-30 09:53:36,768: DEBUG - ++ export RBENV_ROOT=/opt/rbenv
2020-08-30 09:53:36,768: DEBUG - ++ RBENV_ROOT=/opt/rbenv
2020-08-30 09:53:36,768: DEBUG - + source /usr/share/yunohost/helpers
2020-08-30 09:53:36,768: DEBUG - +++ run-parts --list /usr/share/yunohost/helpers.d
2020-08-30 09:53:36,769: DEBUG - ++ for helper in $(run-parts --list /usr/share/yunohost/helpers.d 2>/dev/null)
2020-08-30 09:53:36,769: DEBUG - ++ '[' -r /usr/share/yunohost/helpers.d/apt ']'
2020-08-30 09:53:36,769: DEBUG - ++ . /usr/share/yunohost/helpers.d/apt
2020-08-30 09:53:36,769: DEBUG - ++ for helper in $(run-parts --list /usr/share/yunohost/helpers.d 2>/dev/null)
2020-08-30 09:53:36,769: DEBUG - ++ '[' -r /usr/share/yunohost/helpers.d/backup ']'
2020-08-30 09:53:36,769: DEBUG - ++ . /usr/share/yunohost/helpers.d/backup
2020-08-30 09:53:36,770: DEBUG - +++ CAN_BIND=1
2020-08-30 09:53:36,770: DEBUG - ++ for helper in $(run-parts --list /usr/share/yunohost/helpers.d 2>/dev/null)
2020-08-30 09:53:36,770: DEBUG - ++ '[' -r /usr/share/yunohost/helpers.d/fail2ban ']'
2020-08-30 09:53:36,770: DEBUG - ++ . /usr/share/yunohost/helpers.d/fail2ban
2020-08-30 09:53:36,770: DEBUG - ++ for helper in $(run-parts --list /usr/share/yunohost/helpers.d 2>/dev/null)
2020-08-30 09:53:36,770: DEBUG - ++ '[' -r /usr/share/yunohost/helpers.d/getopts ']'
2020-08-30 09:53:36,771: DEBUG - ++ . /usr/share/yunohost/helpers.d/getopts
2020-08-30 09:53:36,771: DEBUG - ++ for helper in $(run-parts --list /usr/share/yunohost/helpers.d 2>/dev/null)
2020-08-30 09:53:36,771: DEBUG - ++ '[' -r /usr/share/yunohost/helpers.d/hardware ']'
2020-08-30 09:53:36,771: DEBUG - ++ . /usr/share/yunohost/helpers.d/hardware
2020-08-30 09:53:36,771: DEBUG - ++ for helper in $(run-parts --list /usr/share/yunohost/helpers.d 2>/dev/null)
2020-08-30 09:53:36,771: DEBUG - ++ '[' -r /usr/share/yunohost/helpers.d/logging ']'
2020-08-30 09:53:36,771: DEBUG - ++ . /usr/share/yunohost/helpers.d/logging
2020-08-30 09:53:36,772: DEBUG - +++ increment_progression=0
2020-08-30 09:53:36,772: DEBUG - +++ previous_weight=0
2020-08-30 09:53:36,772: DEBUG - +++ max_progression=-1
2020-08-30 09:53:36,772: DEBUG - +++ progress_scale=20
2020-08-30 09:53:36,772: DEBUG - +++ progress_string2='####################'
2020-08-30 09:53:36,772: DEBUG - +++ progress_string1=++++++++++++++++++++
2020-08-30 09:53:36,773: DEBUG - +++ progress_string0=....................
2020-08-30 09:53:36,773: DEBUG - ++++ date +%s
2020-08-30 09:53:36,773: DEBUG - +++ base_time=1598795616
2020-08-30 09:53:36,773: DEBUG - ++ for helper in $(run-parts --list /usr/share/yunohost/helpers.d 2>/dev/null)
2020-08-30 09:53:36,773: DEBUG - ++ '[' -r /usr/share/yunohost/helpers.d/logrotate ']'
2020-08-30 09:53:36,773: DEBUG - ++ . /usr/share/yunohost/helpers.d/logrotate
2020-08-30 09:53:36,773: DEBUG - ++ for helper in $(run-parts --list /usr/share/yunohost/helpers.d 2>/dev/null)
2020-08-30 09:53:36,774: DEBUG - ++ '[' -r /usr/share/yunohost/helpers.d/mysql ']'
2020-08-30 09:53:36,774: DEBUG - ++ . /usr/share/yunohost/helpers.d/mysql
2020-08-30 09:53:36,774: DEBUG - +++ MYSQL_ROOT_PWD_FILE=/etc/yunohost/mysql
2020-08-30 09:53:36,774: DEBUG - ++ for helper in $(run-parts --list /usr/share/yunohost/helpers.d 2>/dev/null)
2020-08-30 09:53:36,774: DEBUG - ++ '[' -r /usr/share/yunohost/helpers.d/network ']'
2020-08-30 09:53:36,774: DEBUG - ++ . /usr/share/yunohost/helpers.d/network
2020-08-30 09:53:36,775: DEBUG - ++ for helper in $(run-parts --list /usr/share/yunohost/helpers.d 2>/dev/null)
2020-08-30 09:53:36,775: DEBUG - ++ '[' -r /usr/share/yunohost/helpers.d/nginx ']'
2020-08-30 09:53:36,775: DEBUG - ++ . /usr/share/yunohost/helpers.d/nginx
2020-08-30 09:53:36,775: DEBUG - ++ for helper in $(run-parts --list /usr/share/yunohost/helpers.d 2>/dev/null)
2020-08-30 09:53:36,775: DEBUG - ++ '[' -r /usr/share/yunohost/helpers.d/nodejs ']'
2020-08-30 09:53:36,775: DEBUG - ++ . /usr/share/yunohost/helpers.d/nodejs
2020-08-30 09:53:36,775: DEBUG - +++ n_version=6.5.1
2020-08-30 09:53:36,776: DEBUG - +++ n_install_dir=/opt/node_n
2020-08-30 09:53:36,776: DEBUG - +++ node_version_path=/opt/node_n/n/versions/node
2020-08-30 09:53:36,776: DEBUG - +++ export N_PREFIX=/opt/node_n
2020-08-30 09:53:36,776: DEBUG - +++ N_PREFIX=/opt/node_n
2020-08-30 09:53:36,776: DEBUG - ++ for helper in $(run-parts --list /usr/share/yunohost/helpers.d 2>/dev/null)
2020-08-30 09:53:36,776: DEBUG - ++ '[' -r /usr/share/yunohost/helpers.d/php ']'
2020-08-30 09:53:36,777: DEBUG - ++ . /usr/share/yunohost/helpers.d/php
2020-08-30 09:53:36,777: DEBUG - +++ readonly YNH_DEFAULT_PHP_VERSION=7.3
2020-08-30 09:53:36,777: DEBUG - +++ YNH_DEFAULT_PHP_VERSION=7.3
2020-08-30 09:53:36,777: DEBUG - +++ YNH_PHP_VERSION=7.3
2020-08-30 09:53:36,777: DEBUG - ++ for helper in $(run-parts --list /usr/share/yunohost/helpers.d 2>/dev/null)
2020-08-30 09:53:36,777: DEBUG - ++ '[' -r /usr/share/yunohost/helpers.d/postgresql ']'
2020-08-30 09:53:36,778: DEBUG - ++ . /usr/share/yunohost/helpers.d/postgresql
2020-08-30 09:53:36,778: DEBUG - +++ PSQL_ROOT_PWD_FILE=/etc/yunohost/psql
2020-08-30 09:53:36,778: DEBUG - +++ PSQL_VERSION=11
2020-08-30 09:53:36,778: DEBUG - ++ for helper in $(run-parts --list /usr/share/yunohost/helpers.d 2>/dev/null)
2020-08-30 09:53:36,779: DEBUG - ++ '[' -r /usr/share/yunohost/helpers.d/setting ']'
2020-08-30 09:53:36,779: DEBUG - ++ . /usr/share/yunohost/helpers.d/setting
2020-08-30 09:53:36,779: DEBUG - ++ for helper in $(run-parts --list /usr/share/yunohost/helpers.d 2>/dev/null)
2020-08-30 09:53:36,779: DEBUG - ++ '[' -r /usr/share/yunohost/helpers.d/string ']'
2020-08-30 09:53:36,779: DEBUG - ++ . /usr/share/yunohost/helpers.d/string
2020-08-30 09:53:36,779: DEBUG - ++ for helper in $(run-parts --list /usr/share/yunohost/helpers.d 2>/dev/null)
2020-08-30 09:53:36,780: DEBUG - ++ '[' -r /usr/share/yunohost/helpers.d/systemd ']'
2020-08-30 09:53:36,780: DEBUG - ++ . /usr/share/yunohost/helpers.d/systemd
2020-08-30 09:53:36,780: DEBUG - ++ for helper in $(run-parts --list /usr/share/yunohost/helpers.d 2>/dev/null)
2020-08-30 09:53:36,780: DEBUG - ++ '[' -r /usr/share/yunohost/helpers.d/user ']'
2020-08-30 09:53:36,780: DEBUG - ++ . /usr/share/yunohost/helpers.d/user
2020-08-30 09:53:36,780: DEBUG - ++ for helper in $(run-parts --list /usr/share/yunohost/helpers.d 2>/dev/null)
2020-08-30 09:53:36,781: DEBUG - ++ '[' -r /usr/share/yunohost/helpers.d/utils ']'
2020-08-30 09:53:36,781: DEBUG - ++ . /usr/share/yunohost/helpers.d/utils
2020-08-30 09:53:36,781: DEBUG - + ynh_abort_if_errors
2020-08-30 09:53:36,781: DEBUG - + set -o errexit
2020-08-30 09:53:36,781: DEBUG - + set -o nounset
2020-08-30 09:53:36,781: DEBUG - + trap ynh_exit_properly EXIT
2020-08-30 09:53:36,781: DEBUG - + domain=forum.maindomain.tld
2020-08-30 09:53:36,782: DEBUG - + path_url=/
2020-08-30 09:53:36,782: DEBUG - + admin=adepetigny
2020-08-30 09:53:36,782: DEBUG - + is_public=1
2020-08-30 09:53:36,782: DEBUG - + app=discourse
2020-08-30 09:53:36,783: DEBUG - + echo '[....................] > Validating installation parameters...'
2020-08-30 09:53:36,783: DEBUG - + final_path=/var/www/discourse
2020-08-30 09:53:36,783: DEBUG - + test '!' -e /var/www/discourse
2020-08-30 09:53:36,784: DEBUG - + ynh_webpath_register --app=discourse --domain=forum.maindomain.tld --path_url=/
2020-08-30 09:53:36,885: DEBUG - + yunohost app register-url discourse forum.maindomain.tld /
2020-08-30 09:53:36,886: INFO - [....................] > Validating installation parameters...
2020-08-30 09:53:37,188: DEBUG - + check_memory_requirements
2020-08-30 09:53:37,188: DEBUG - + is_swap_present
2020-08-30 09:53:37,188: DEBUG - ++ awk '/^SwapTotal:/{print $2}' /proc/meminfo
2020-08-30 09:53:37,189: DEBUG - + '[' 4192252 -gt 0 ']'
2020-08-30 09:53:37,189: DEBUG - + is_swappiness_sufficient
2020-08-30 09:53:37,189: DEBUG - ++ cat /proc/sys/vm/swappiness
2020-08-30 09:53:37,189: DEBUG - + '[' 60 -gt 50 ']'
2020-08-30 09:53:37,189: DEBUG - + is_memory_available 1000000
2020-08-30 09:53:37,189: DEBUG - + local needed_memory=1000000
2020-08-30 09:53:37,190: DEBUG - ++ awk '/^MemAvailable:/{print $2}' /proc/meminfo
2020-08-30 09:53:37,190: DEBUG - + local freemem=2550124
2020-08-30 09:53:37,190: DEBUG - ++ awk '/^SwapFree:/{print $2}' /proc/meminfo
2020-08-30 09:53:37,190: DEBUG - + local freeswap=4186316
2020-08-30 09:53:37,190: DEBUG - + '[' 6736440 -gt 1000000 ']'
2020-08-30 09:53:37,191: DEBUG - + echo '[+...................] > Storing installation settings...'
2020-08-30 09:53:37,191: DEBUG - + ynh_app_setting_set --app=discourse --key=domain --value=forum.maindomain.tld
2020-08-30 09:53:37,293: DEBUG - + ynh_app_setting set discourse domain forum.maindomain.tld
2020-08-30 09:53:37,293: INFO - [+...................] > Storing installation settings...
2020-08-30 09:53:37,294: DEBUG - + [[ set == \d\e\l\e\t\e ]]
2020-08-30 09:53:37,294: DEBUG - + ACTION=set
2020-08-30 09:53:37,294: DEBUG - + APP=discourse
2020-08-30 09:53:37,294: DEBUG - + KEY=domain
2020-08-30 09:53:37,294: DEBUG - + VALUE=forum.maindomain.tld
2020-08-30 09:53:37,295: DEBUG - + python2.7 -
2020-08-30 09:53:37,395: DEBUG - + [[ domain =~ ^(unprotected|skipped)_ ]]
2020-08-30 09:53:37,395: DEBUG - + ynh_app_setting_set --app=discourse --key=path --value=/
2020-08-30 09:53:37,397: DEBUG - + ynh_app_setting set discourse path /
2020-08-30 09:53:37,397: DEBUG - + [[ set == \d\e\l\e\t\e ]]
2020-08-30 09:53:37,397: DEBUG - + ACTION=set
2020-08-30 09:53:37,397: DEBUG - + APP=discourse
2020-08-30 09:53:37,397: DEBUG - + KEY=path
2020-08-30 09:53:37,398: DEBUG - + VALUE=/
2020-08-30 09:53:37,398: DEBUG - + python2.7 -
2020-08-30 09:53:37,498: DEBUG - + [[ path =~ ^(unprotected|skipped)_ ]]
2020-08-30 09:53:37,498: DEBUG - + ynh_app_setting_set --app=discourse --key=admin --value=adepetigny
2020-08-30 09:53:37,600: DEBUG - + ynh_app_setting set discourse admin adepetigny
2020-08-30 09:53:37,600: DEBUG - + [[ set == \d\e\l\e\t\e ]]
2020-08-30 09:53:37,601: DEBUG - + ACTION=set
2020-08-30 09:53:37,601: DEBUG - + APP=discourse
2020-08-30 09:53:37,601: DEBUG - + KEY=admin
2020-08-30 09:53:37,601: DEBUG - + VALUE=adepetigny
2020-08-30 09:53:37,601: DEBUG - + python2.7 -
2020-08-30 09:53:37,702: DEBUG - + [[ admin =~ ^(unprotected|skipped)_ ]]
2020-08-30 09:53:37,702: DEBUG - + ynh_app_setting_set --app=discourse --key=is_public --value=1
2020-08-30 09:53:37,703: DEBUG - + ynh_app_setting set discourse is_public 1
2020-08-30 09:53:37,703: DEBUG - + [[ set == \d\e\l\e\t\e ]]
2020-08-30 09:53:37,704: DEBUG - + ACTION=set
2020-08-30 09:53:37,704: DEBUG - + APP=discourse
2020-08-30 09:53:37,704: DEBUG - + KEY=is_public
2020-08-30 09:53:37,704: DEBUG - + VALUE=1
2020-08-30 09:53:37,704: DEBUG - + python2.7 -
2020-08-30 09:53:37,805: DEBUG - + [[ is_public =~ ^(unprotected|skipped)_ ]]
2020-08-30 09:53:37,806: DEBUG - + echo '[#+..................] > Installing dependencies...'
2020-08-30 09:53:37,806: DEBUG - + ynh_install_app_dependencies g++ 'libjemalloc1|libjemalloc2' libjemalloc-dev zlib1g-dev libreadline-dev libpq-dev libssl-dev libyaml-dev libcurl4-openssl-dev libapr1-dev libxslt1-dev libxml2-dev vim imagemagick postgresql postgresql-server-dev-all postgresql-contrib optipng jhead jpegoptim gifsicle brotli
2020-08-30 09:53:37,806: DEBUG - + local 'dependencies=g++ libjemalloc1|libjemalloc2 libjemalloc-dev zlib1g-dev libreadline-dev libpq-dev libssl-dev libyaml-dev libcurl4-openssl-dev libapr1-dev libxslt1-dev libxml2-dev vim imagemagick postgresql postgresql-server-dev-all postgresql-contrib optipng jhead jpegoptim gifsicle brotli'
2020-08-30 09:53:37,807: DEBUG - ++ echo 'g++ libjemalloc1|libjemalloc2 libjemalloc-dev zlib1g-dev libreadline-dev libpq-dev libssl-dev libyaml-dev libcurl4-openssl-dev libapr1-dev libxslt1-dev libxml2-dev vim imagemagick postgresql postgresql-server-dev-all postgresql-contrib optipng jhead jpegoptim gifsicle brotli'
2020-08-30 09:53:37,807: DEBUG - ++ sed 's/\([^\<=\>]\)\ \([^(]\)/\1, \2/g'
2020-08-30 09:53:37,807: DEBUG - + dependencies='g++, libjemalloc1|libjemalloc2, libjemalloc-dev, zlib1g-dev, libreadline-dev, libpq-dev, libssl-dev, libyaml-dev, libcurl4-openssl-dev, libapr1-dev, libxslt1-dev, libxml2-dev, vim, imagemagick, postgresql, postgresql-server-dev-all, postgresql-contrib, optipng, jhead, jpegoptim, gifsicle, brotli'
2020-08-30 09:53:37,807: DEBUG - + local 'dependencies=g++, libjemalloc1 | libjemalloc2, libjemalloc-dev, zlib1g-dev, libreadline-dev, libpq-dev, libssl-dev, libyaml-dev, libcurl4-openssl-dev, libapr1-dev, libxslt1-dev, libxml2-dev, vim, imagemagick, postgresql, postgresql-server-dev-all, postgresql-contrib, optipng, jhead, jpegoptim, gifsicle, brotli'
2020-08-30 09:53:37,807: DEBUG - + local manifest_path=../manifest.json
2020-08-30 09:53:37,807: DEBUG - + '[' '!' -e ../manifest.json ']'
2020-08-30 09:53:37,808: DEBUG - ++ grep '\"version\": ' ../manifest.json
2020-08-30 09:53:37,808: DEBUG - ++ cut '--delimiter="' --fields=4
2020-08-30 09:53:37,808: DEBUG - + local version=2.3.10~ynh2
2020-08-30 09:53:37,808: DEBUG - + '[' 11 -eq 0 ']'
2020-08-30 09:53:37,808: DEBUG - + local dep_app=discourse
2020-08-30 09:53:37,808: DEBUG - + [[ g++, libjemalloc1 | libjemalloc2, libjemalloc-dev, zlib1g-dev, libreadline-dev, libpq-dev, libssl-dev, libyaml-dev, libcurl4-openssl-dev, libapr1-dev, libxslt1-dev, libxml2-dev, vim, imagemagick, postgresql, postgresql-server-dev-all, postgresql-contrib, optipng, jhead, jpegoptim, gifsicle, brotli =~ [<=>] ]]
2020-08-30 09:53:37,809: DEBUG - + echo g++, libjemalloc1 '|' libjemalloc2, libjemalloc-dev, zlib1g-dev, libreadline-dev, libpq-dev, libssl-dev, libyaml-dev, libcurl4-openssl-dev, libapr1-dev, libxslt1-dev, libxml2-dev, vim, imagemagick, postgresql, postgresql-server-dev-all, postgresql-contrib, optipng, jhead, jpegoptim, gifsicle, brotli
2020-08-30 09:53:37,809: DEBUG - + grep --quiet php
2020-08-30 09:53:37,809: DEBUG - + cat
2020-08-30 09:53:37,809: DEBUG - + ynh_package_install_from_equivs /tmp/discourse-ynh-deps.control
2020-08-30 09:53:37,809: DEBUG - + local controlfile=/tmp/discourse-ynh-deps.control
2020-08-30 09:53:37,809: DEBUG - ++ grep '^Package: ' /tmp/discourse-ynh-deps.control
2020-08-30 09:53:37,810: DEBUG - ++ cut '--delimiter= ' --fields=2
2020-08-30 09:53:37,810: DEBUG - + local pkgname=discourse-ynh-deps
2020-08-30 09:53:37,810: DEBUG - ++ grep '^Version: ' /tmp/discourse-ynh-deps.control
2020-08-30 09:53:37,810: DEBUG - ++ cut '--delimiter= ' --fields=2
2020-08-30 09:53:37,910: DEBUG - + local pkgversion=2.3.10~ynh2
2020-08-30 09:53:37,911: INFO - [#+..................] > Installing dependencies...
2020-08-30 09:53:37,911: DEBUG - + [[ -z discourse-ynh-deps ]]
2020-08-30 09:53:37,911: DEBUG - + [[ -z 2.3.10~ynh2 ]]
2020-08-30 09:53:37,912: DEBUG - + ynh_package_update
2020-08-30 09:53:37,912: DEBUG - + ynh_apt update
2020-08-30 09:53:37,912: DEBUG - + ynh_wait_dpkg_free
2020-08-30 09:53:38,013: DEBUG - + return 0
2020-08-30 09:53:38,013: DEBUG - + LC_ALL=C
2020-08-30 09:53:38,013: DEBUG - + DEBIAN_FRONTEND=noninteractive
2020-08-30 09:53:38,013: DEBUG - + apt-get --assume-yes --quiet -o=Acquire::Retries=3 -o=Dpkg::Use-Pty=0 update
2020-08-30 09:53:38,114: DEBUG - Hit:1 http://security.debian.org/debian-security buster/updates InRelease
2020-08-30 09:53:38,114: DEBUG - Hit:2 http://deb.debian.org/debian buster InRelease
2020-08-30 09:53:38,114: DEBUG - Hit:3 http://deb.debian.org/debian buster-updates InRelease
2020-08-30 09:53:38,115: DEBUG - Hit:4 http://forge.yunohost.org/debian buster InRelease
2020-08-30 09:53:38,115: DEBUG - Hit:5 https://deb.nodesource.com/node_10.x stretch InRelease
2020-08-30 09:53:38,616: DEBUG - Hit:6 http://download.onlyoffice.com/repo/debian squeeze InRelease
2020-08-30 09:53:39,518: DEBUG - Reading package lists...
2020-08-30 09:53:39,519: DEBUG - ++ mktemp --directory
2020-08-30 09:53:39,519: DEBUG - + local TMPDIR=/tmp/tmp.oBIAjLS1IG
2020-08-30 09:53:39,519: DEBUG - + echo 10
2020-08-30 09:53:39,519: DEBUG - + ynh_wait_dpkg_free
2020-08-30 09:53:39,720: DEBUG - + return 0
2020-08-30 09:53:39,720: DEBUG - + cp /tmp/discourse-ynh-deps.control /tmp/tmp.oBIAjLS1IG/control
2020-08-30 09:53:39,720: DEBUG - + cd /tmp/tmp.oBIAjLS1IG
2020-08-30 09:53:39,721: DEBUG - + LC_ALL=C
2020-08-30 09:53:39,721: DEBUG - + equivs-build ./control
2020-08-30 09:53:40,523: DEBUG - + dpkg --force-depends --install ./discourse-ynh-deps_2.3.10~ynh2_all.deb
2020-08-30 09:53:40,623: DEBUG - Selecting previously unselected package discourse-ynh-deps.
2020-08-30 09:53:40,724: DEBUG - (Reading database ... 85900 files and directories currently installed.)
2020-08-30 09:53:40,724: DEBUG - Preparing to unpack .../discourse-ynh-deps_2.3.10~ynh2_all.deb ...
2020-08-30 09:53:40,724: DEBUG - Unpacking discourse-ynh-deps (2.3.10~ynh2) ...
2020-08-30 09:53:41,125: DEBUG - dpkg: discourse-ynh-deps: dependency problems, but configuring anyway as you requested:
2020-08-30 09:53:41,125: DEBUG -  discourse-ynh-deps depends on libjemalloc-dev; however:
2020-08-30 09:53:41,126: DEBUG -   Package libjemalloc-dev is not installed.
2020-08-30 09:53:41,126: DEBUG -  discourse-ynh-deps depends on zlib1g-dev; however:
2020-08-30 09:53:41,126: DEBUG -   Package zlib1g-dev is not installed.
2020-08-30 09:53:41,126: DEBUG -  discourse-ynh-deps depends on libreadline-dev; however:
2020-08-30 09:53:41,126: DEBUG -   Package libreadline-dev is not installed.
2020-08-30 09:53:41,126: DEBUG -  discourse-ynh-deps depends on libpq-dev; however:
2020-08-30 09:53:41,127: DEBUG -   Package libpq-dev is not installed.
2020-08-30 09:53:41,127: DEBUG -  discourse-ynh-deps depends on libssl-dev; however:
2020-08-30 09:53:41,127: DEBUG -   Package libssl-dev is not installed.
2020-08-30 09:53:41,127: DEBUG -  discourse-ynh-deps depends on libyaml-dev; however:
2020-08-30 09:53:41,127: DEBUG -   Package libyaml-dev is not installed.
2020-08-30 09:53:41,127: DEBUG -  discourse-ynh-deps depends on libcurl4-openssl-dev; however:
2020-08-30 09:53:41,127: DEBUG -   Package libcurl4-openssl-dev is not installed.
2020-08-30 09:53:41,128: DEBUG -  discourse-ynh-deps depends on libapr1-dev; however:
2020-08-30 09:53:41,128: DEBUG -   Package libapr1-dev is not installed.
2020-08-30 09:53:41,128: DEBUG -  discourse-ynh-deps depends on libxslt1-dev; however:
2020-08-30 09:53:41,128: DEBUG -   Package libxslt1-dev is not installed.
2020-08-30 09:53:41,128: DEBUG -  discourse-ynh-deps depends on libxml2-dev; however:
2020-08-30 09:53:41,128: DEBUG -   Package libxml2-dev is not installed.
2020-08-30 09:53:41,129: DEBUG -  discourse-ynh-deps depends on vim; however:
2020-08-30 09:53:41,129: DEBUG -   Package vim is not installed.
2020-08-30 09:53:41,129: DEBUG -  discourse-ynh-deps depends on postgresql-server-dev-all; however:
2020-08-30 09:53:41,129: DEBUG -   Package postgresql-server-dev-all is not installed.
2020-08-30 09:53:41,129: DEBUG -  discourse-ynh-deps depends on postgresql-contrib; however:
2020-08-30 09:53:41,129: DEBUG -   Package postgresql-contrib is not installed.
2020-08-30 09:53:41,129: DEBUG -  discourse-ynh-deps depends on optipng; however:
2020-08-30 09:53:41,130: DEBUG -   Package optipng is not installed.
2020-08-30 09:53:41,130: DEBUG -  discourse-ynh-deps depends on jhead; however:
2020-08-30 09:53:41,130: DEBUG -   Package jhead is not installed.
2020-08-30 09:53:41,130: DEBUG -  discourse-ynh-deps depends on jpegoptim; however:
2020-08-30 09:53:41,130: DEBUG -   Package jpegoptim is not installed.
2020-08-30 09:53:41,130: DEBUG -  discourse-ynh-deps depends on gifsicle; however:
2020-08-30 09:53:41,130: DEBUG -   Package gifsicle is not installed.
2020-08-30 09:53:41,131: DEBUG -  discourse-ynh-deps depends on brotli; however:
2020-08-30 09:53:41,131: DEBUG -   Package brotli is not installed.
2020-08-30 09:53:41,131: DEBUG - 
2020-08-30 09:53:41,131: DEBUG - Setting up discourse-ynh-deps (2.3.10~ynh2) ...
2020-08-30 09:53:41,432: DEBUG - + ynh_package_install --fix-broken
2020-08-30 09:53:41,432: DEBUG - + ynh_apt --no-remove --option Dpkg::Options::=--force-confdef --option Dpkg::Options::=--force-confold install --fix-broken
2020-08-30 09:53:41,432: DEBUG - + ynh_wait_dpkg_free
2020-08-30 09:53:41,633: DEBUG - + return 0
2020-08-30 09:53:41,634: DEBUG - + LC_ALL=C
2020-08-30 09:53:41,634: DEBUG - + DEBIAN_FRONTEND=noninteractive
2020-08-30 09:53:41,634: DEBUG - + apt-get --assume-yes --quiet -o=Acquire::Retries=3 -o=Dpkg::Use-Pty=0 --no-remove --option Dpkg::Options::=--force-confdef --option Dpkg::Options::=--force-confold install --fix-broken
2020-08-30 09:53:41,935: DEBUG - Reading package lists...
2020-08-30 09:53:42,035: DEBUG - Building dependency tree...
2020-08-30 09:53:42,036: DEBUG - Reading state information...
2020-08-30 09:53:42,136: DEBUG - Correcting dependencies... Done
2020-08-30 09:53:42,237: DEBUG - The following packages were automatically installed and are no longer required:
2020-08-30 09:53:42,237: DEBUG -   adwaita-icon-theme at-spi2-core dconf-gsettings-backend dconf-service
2020-08-30 09:53:42,237: DEBUG -   erlang-asn1 erlang-base erlang-crypto erlang-eldap erlang-ftp erlang-inets
2020-08-30 09:53:42,237: DEBUG -   erlang-mnesia erlang-os-mon erlang-parsetools erlang-public-key
2020-08-30 09:53:42,238: DEBUG -   erlang-runtime-tools erlang-snmp erlang-ssl erlang-syntax-tools erlang-tftp
2020-08-30 09:53:42,238: DEBUG -   erlang-tools erlang-xmerl gconf-service gconf2-common glib-networking
2020-08-30 09:53:42,238: DEBUG -   glib-networking-common glib-networking-services gsettings-desktop-schemas
2020-08-30 09:53:42,238: DEBUG -   gtk-update-icon-cache libasound2 libasound2-data libatk-bridge2.0-0
2020-08-30 09:53:42,238: DEBUG -   libatk1.0-0 libatk1.0-data libatspi2.0-0 libcairo-gobject2 libcolord2
2020-08-30 09:53:42,238: DEBUG -   libcurl3-nss libdbus-glib-1-2 libdconf1 libdrm-amdgpu1 libdrm-common
2020-08-30 09:53:42,239: DEBUG -   libdrm-intel1 libdrm-nouveau2 libdrm-radeon1 libdrm2 libepoxy0 libfontenc1
2020-08-30 09:53:42,239: DEBUG -   libgconf-2-4 libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-bin libgdk-pixbuf2.0-common
2020-08-30 09:53:42,239: DEBUG -   libgl1 libgl1-mesa-dri libglapi-mesa libglvnd0 libglx-mesa0 libglx0
2020-08-30 09:53:42,239: DEBUG -   libgtk-3-0 libgtk-3-bin libgtk-3-common libice6 libjson-glib-1.0-0
2020-08-30 09:53:42,239: DEBUG -   libjson-glib-1.0-common libnspr4 libnss3 libpciaccess0 libproxy1v5
2020-08-30 09:53:42,239: DEBUG -   librest-0.7-0 librsvg2-2 librsvg2-common libsm6 libsoup-gnome2.4-1
2020-08-30 09:53:42,240: DEBUG -   libsoup2.4-1 libwayland-client0 libwayland-cursor0 libwayland-egl1
2020-08-30 09:53:42,240: DEBUG -   libx11-xcb1 libxaw7 libxcb-dri2-0 libxcb-dri3-0 libxcb-glx0 libxcb-present0
2020-08-30 09:53:42,240: DEBUG -   libxcb-sync1 libxcomposite1 libxcursor1 libxdamage1 libxfixes3 libxfont2
2020-08-30 09:53:42,240: DEBUG -   libxi6 libxinerama1 libxkbcommon0 libxkbfile1 libxmu6 libxrandr2
2020-08-30 09:53:42,240: DEBUG -   libxshmfence1 libxss1 libxt6 libxtst6 libxxf86vm1 mariadb-client
2020-08-30 09:53:42,240: DEBUG -   onlyoffice-documentserver pwgen python-meld3 rabbitmq-server supervisor
2020-08-30 09:53:42,241: DEBUG -   x11-common x11-xkb-utils xfonts-base xfonts-encodings xfonts-utils
2020-08-30 09:53:42,241: DEBUG -   xserver-common xvfb
2020-08-30 09:53:42,241: DEBUG - Use 'apt autoremove' to remove them.
2020-08-30 09:53:42,241: DEBUG - The following additional packages will be installed:
2020-08-30 09:53:42,241: DEBUG -   binfmt-support brotli clang-7 dctrl-tools gifsicle icu-devtools jhead
2020-08-30 09:53:42,241: DEBUG -   jpegoptim lib32gcc1 lib32stdc++6 libapr1 libapr1-dev libc6-i386
2020-08-30 09:53:42,242: DEBUG -   libclang-common-7-dev libclang1-7 libcurl4-openssl-dev libffi-dev libgpm2
2020-08-30 09:53:42,242: DEBUG -   libicu-dev libjemalloc-dev libjpeg-turbo-progs libncurses-dev libobjc-8-dev
2020-08-30 09:53:42,242: DEBUG -   libobjc4 libomp-7-dev libomp5-7 libpq-dev libreadline-dev libsctp-dev
2020-08-30 09:53:42,242: DEBUG -   libssl-dev libturbojpeg0 libxml2-dev libxslt1-dev libyaml-dev llvm-7
2020-08-30 09:53:42,242: DEBUG -   llvm-7-dev llvm-7-runtime optipng postgresql-contrib
2020-08-30 09:53:42,242: DEBUG -   postgresql-server-dev-11 postgresql-server-dev-all uuid-dev vim vim-runtime
2020-08-30 09:53:42,243: DEBUG -   zlib1g-dev
2020-08-30 09:53:42,243: DEBUG - Suggested packages:
2020-08-30 09:53:42,243: DEBUG -   clang-7-doc debtags libcurl4-doc libidn11-dev libkrb5-dev libldap2-dev
2020-08-30 09:53:42,243: DEBUG -   librtmp-dev libssh2-1-dev pkg-config gpm icu-doc ncurses-doc libomp-7-doc
2020-08-30 09:53:42,243: WARNING - E: Packages need to be removed but remove is disabled.
2020-08-30 09:53:42,244: DEBUG -   postgresql-doc-11 readline-doc libssl-doc libyaml-doc llvm-7-doc ctags
2020-08-30 09:53:42,244: DEBUG -   vim-doc vim-scripts
2020-08-30 09:53:42,244: DEBUG - The following packages will be REMOVED:
2020-08-30 09:53:42,244: DEBUG -   libcurl4-nss-dev onlyoffice-ynh-deps
2020-08-30 09:53:42,244: DEBUG - The following NEW packages will be installed:
2020-08-30 09:53:42,244: DEBUG -   binfmt-support brotli clang-7 dctrl-tools gifsicle icu-devtools jhead
2020-08-30 09:53:42,245: DEBUG -   jpegoptim lib32gcc1 lib32stdc++6 libapr1 libapr1-dev libc6-i386
2020-08-30 09:53:42,245: DEBUG -   libclang-common-7-dev libclang1-7 libcurl4-openssl-dev libffi-dev libgpm2
2020-08-30 09:53:42,245: DEBUG -   libicu-dev libjemalloc-dev libjpeg-turbo-progs libncurses-dev libobjc-8-dev
2020-08-30 09:53:42,245: DEBUG -   libobjc4 libomp-7-dev libomp5-7 libpq-dev libreadline-dev libsctp-dev
2020-08-30 09:53:42,245: DEBUG -   libssl-dev libturbojpeg0 libxml2-dev libxslt1-dev libyaml-dev llvm-7
2020-08-30 09:53:42,245: DEBUG -   llvm-7-dev llvm-7-runtime optipng postgresql-contrib
2020-08-30 09:53:42,246: DEBUG -   postgresql-server-dev-11 postgresql-server-dev-all uuid-dev vim vim-runtime
2020-08-30 09:53:42,246: DEBUG -   zlib1g-dev
2020-08-30 09:53:42,246: DEBUG - 0 upgraded, 45 newly installed, 2 to remove and 0 not upgraded.
2020-08-30 09:53:42,246: DEBUG - ++ dpkg --info /tmp/tmp.oBIAjLS1IG/discourse-ynh-deps_2.3.10~ynh2_all.deb
2020-08-30 09:53:42,246: DEBUG - ++ sed 's/^ Depends: //'
2020-08-30 09:53:42,246: DEBUG - ++ sed s/,//g
2020-08-30 09:53:42,347: DEBUG - ++ grep Depends
2020-08-30 09:53:42,347: DEBUG - + local 'dependencies=g++ libjemalloc1 | libjemalloc2 libjemalloc-dev zlib1g-dev libreadline-dev libpq-dev libssl-dev libyaml-dev libcurl4-openssl-dev libapr1-dev libxslt1-dev libxml2-dev vim imagemagick postgresql postgresql-server-dev-all postgresql-contrib optipng jhead jpegoptim gifsicle brotli'
2020-08-30 09:53:42,347: DEBUG - + sed --quiet '/--fix-broken/,$p'
2020-08-30 09:53:42,347: DEBUG - + ynh_package_install g++ libjemalloc1 '|' libjemalloc2 libjemalloc-dev zlib1g-dev libreadline-dev libpq-dev libssl-dev libyaml-dev libcurl4-openssl-dev libapr1-dev libxslt1-dev libxml2-dev vim imagemagick postgresql postgresql-server-dev-all postgresql-contrib optipng jhead jpegoptim gifsicle brotli --dry-run
2020-08-30 09:53:42,348: DEBUG - + ynh_apt --no-remove --option Dpkg::Options::=--force-confdef --option Dpkg::Options::=--force-confold install g++ libjemalloc1 '|' libjemalloc2 libjemalloc-dev zlib1g-dev libreadline-dev libpq-dev libssl-dev libyaml-dev libcurl4-openssl-dev libapr1-dev libxslt1-dev libxml2-dev vim imagemagick postgresql postgresql-server-dev-all postgresql-contrib optipng jhead jpegoptim gifsicle brotli --dry-run
2020-08-30 09:53:42,348: DEBUG - + ynh_wait_dpkg_free
2020-08-30 09:53:42,449: DEBUG - + return 0
2020-08-30 09:53:42,449: DEBUG - + LC_ALL=C
2020-08-30 09:53:42,449: DEBUG - + DEBIAN_FRONTEND=noninteractive
2020-08-30 09:53:42,449: DEBUG - + apt-get --assume-yes --quiet -o=Acquire::Retries=3 -o=Dpkg::Use-Pty=0 --no-remove --option Dpkg::Options::=--force-confdef --option Dpkg::Options::=--force-confold install g++ libjemalloc1 '|' libjemalloc2 libjemalloc-dev zlib1g-dev libreadline-dev libpq-dev libssl-dev libyaml-dev libcurl4-openssl-dev libapr1-dev libxslt1-dev libxml2-dev vim imagemagick postgresql postgresql-server-dev-all postgresql-contrib optipng jhead jpegoptim gifsicle brotli --dry-run
2020-08-30 09:53:42,951: DEBUG - + ynh_die '--message=Unable to install dependencies'
2020-08-30 09:53:42,951: WARNING - E: Package 'libjemalloc1' has no installation candidate
2020-08-30 09:53:42,952: WARNING - Unable to install dependencies
2020-08-30 09:53:42,953: DEBUG - + ret_code=1
2020-08-30 09:53:42,953: DEBUG - + echo 'Unable to install dependencies'
2020-08-30 09:53:42,953: DEBUG - + exit 1
2020-08-30 09:53:42,953: DEBUG - + ynh_exit_properly
2020-08-30 09:53:42,953: DEBUG - + local exit_code=1
2020-08-30 09:53:42,954: DEBUG - + '[' 1 -eq 0 ']'
2020-08-30 09:53:42,954: DEBUG - + trap '' EXIT
2020-08-30 09:53:42,954: DEBUG - + set +o errexit
2020-08-30 09:53:42,954: DEBUG - + set +o nounset
2020-08-30 09:53:42,954: DEBUG - + sleep 0.5
2020-08-30 09:53:43,456: DEBUG - + type -t ynh_clean_setup
2020-08-30 09:53:43,456: DEBUG - + ynh_clean_setup
2020-08-30 09:53:43,456: DEBUG - + ynh_clean_check_starting
2020-08-30 09:53:43,456: DEBUG - + '[' -n '' ']'
2020-08-30 09:53:43,456: DEBUG - + '[' -n '' ']'
2020-08-30 09:53:43,457: DEBUG - + exit 1
2020-08-30 09:53:43,489: ERROR - Impossible d’installer discourse : Une erreur est survenue dans le script d’installation de l’application

Hmpf si je me souviens bien, on avait vu ce soucis il y a quelque mois et c’est du à une incompatibilité entre les dépendances d’une app et d’une autre app (en l’occurence, onlyoffice vs. discourse) à cause de la dépendance libcurl4-nss-dev (dont a besoin onlyoffice) vs. libcurl4-openssl-dev (dont a besoin discourse)

Ah… oui… j’ai bien installé OnlyOffice également…

Je n’ai pas onlyoffice mais Discourse ne s’installe pas non plus chez moi.

J’ai quelqueques doute au sujet de libjemalloc1 ‘|’ libjemalloc2 car mon système a bien libjemalloc2 et j’ai l’erreur

2020-09-09 13:09:33,272: DEBUG - + DEBIAN_FRONTEND=noninteractive
2020-09-09 13:09:33,273: DEBUG - + apt-get --assume-yes --quiet -o=Acquire::Retries=3 -o=Dpkg::Use-Pty=0 --no-remove --option Dpkg::Options::=–force-confdef --option Dpkg::Options::=–force-confold install g++ libjemalloc1 ‘|’ libjemalloc2 libjemalloc-dev zlib1g-dev libreadline-dev libpq-dev libssl-dev libyaml-dev libcurl4-openssl-dev libapr1-dev libxslt1-dev libxml2-dev vim imagemagick postgresql postgresql-server-dev-all postgresql-contrib optipng jhead jpegoptim gifsicle brotli --dry-run
2020-09-09 13:09:34,276: DEBUG - + ynh_die ‘–message=Unable to install dependencies’
2020-09-09 13:09:34,277: WARNING - E: Package ‘libjemalloc1’ has no installation candidate
2020-09-09 13:09:34,278: WARNING - E: Package ‘libssl-dev’ has no installation candidate
2020-09-09 13:09:34,382: DEBUG - + ret_code=1
2020-09-09 13:09:34,382: WARNING - Unable to install dependencies
2020-09-09 13:09:34,384: DEBUG - + echo ‘Unable to install dependencies’
2020-09-09 13:09:34,384: DEBUG - + exit 1
2020-09-09 13:09:34,385: DEBUG - + ynh_exit_properly

apt-cache search libjemalloc
libjemalloc-dev - development files and documentation for jemalloc
libjemalloc2 - general-purpose scalable concurrent malloc(3) implementation

il n’y a pas de libjemalloc1 proposé sur cette debian 10.

Salut,

le truc à propos de libjemalloc1 est un “red herring” … pas le vrai problème (flemme d’expliquer pourquoi ça affiche ce soucis, c’est technique et pas intéressant)

J’ai l’impression que le vrai soucis est lié à libssl-dev, donc est-ce que tu peux faire un

apt policy libssl-dev

apt policy libssl-dev
libssl-dev:
Installé : 1.1.1g-1+0~20200421.17+debian10~1.gbpf6902f
Candidat : (aucun)
Table de version :
*** 1.1.1g-1+0~20200421.17+debian10~1.gbpf6902f -1
600 https://packages.sury.org/php buster/main amd64 Packages
100 /var/lib/dpkg/status
1.1.1d-0+deb10u3 500
500 http://ftp.debian.org/debian buster/main amd64 Packages
500 http://security.debian.org/debian-security buster/updates/main amd64 Packages

il y a des preferences provenant de sury.org pour les paquets debian php, je ne sais pas d’où elles viennent.

/etc/apt/preferences.d$ more extra_php_version
Package: *
Pin: origin “packages.sury.org
Pin-Priority: 600

Package: php
Pin: origin “packages.sury.org
Pin-Priority: -1

Package: php-fpm
Pin: origin “packages.sury.org
Pin-Priority: -1

Package: php-mysql
Pin: origin “packages.sury.org
Pin-Priority: -1

Package: php-xml
Pin: origin “packages.sury.org
Pin-Priority: -1

Package: php-zip
Pin: origin “packages.sury.org
Pin-Priority: -1

Package: php-mbstring
Pin: origin “packages.sury.org
Pin-Priority: -1

Package: php-ldap
Pin: origin “packages.sury.org
Pin-Priority: -1

Package: php-gd
Pin: origin “packages.sury.org
Pin-Priority: -1

Package: php-curl
Pin: origin “packages.sury.org
Pin-Priority: -1

Package: php-bz2
Pin: origin “packages.sury.org
Pin-Priority: -1

Package: php-json
Pin: origin “packages.sury.org
Pin-Priority: -1

Package: php-sqlite3
Pin: origin “packages.sury.org
Pin-Priority: -1

Package: php-intl
Pin: origin “packages.sury.org
Pin-Priority: -1

Package: openssl
Pin: origin “packages.sury.org
Pin-Priority: -1

Package: libssl1.1
Pin: origin “packages.sury.org
Pin-Priority: -1

Package: libssl-dev
Pin: origin “packages.sury.org
Pin-Priority: -1

Elles viennent de Yunohost pour protéger de certains probleme que peut induire sury …

Que raconte

apt install libssl-dev=1.1.1d-0+deb10u3

sudo apt install libssl-dev=1.1.1d-0+deb10u3
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances
Lecture des informations d’état… Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l’impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n’ont pas encore
été créés ou ne sont pas sortis d’Incoming.
L’information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
libssl-dev : Dépend: libssl1.1 (= 1.1.1d-0+deb10u3) mais 1.1.1g-1+0~20200421.17+debian10~1.gbpf6902f devra être installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l’état ».

Okay du coup on va faire un

apt install libssl1.1=1.1.1d-0+deb10u3 --allow-downgrades

puis retenter

apt install libssl-dev

sudo apt install libssl1.1=1.1.1d-0+deb10u3 --allow-downgrades

Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances
Lecture des informations d’état… Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
cpanminus libalgorithm-c3-perl libb-hooks-endofscope-perl libb-hooks-op-check-perl libclass-c3-perl
libclass-c3-xs-perl libclass-method-modifiers-perl libclass-xsaccessor-perl libcpan-changes-perl
libcpan-distnameinfo-perl libcpan-meta-check-perl libdata-optlist-perl libdata-perl-perl libdata-section-perl
libdevel-callchecker-perl libdevel-globaldestruction-perl libdynaloader-functions-perl libexporter-tiny-perl
libfile-pushd-perl libfile-slurp-perl libgetopt-long-descriptive-perl libimport-into-perl liblist-moreutils-perl
liblocal-lib-perl libmodule-build-perl libmodule-implementation-perl libmodule-runtime-perl libmodule-signature-perl
libmoo-perl libmoox-handlesvia-perl libmro-compat-perl libnamespace-autoclean-perl libnamespace-clean-perl
libpackage-stash-perl libpackage-stash-xs-perl libparams-classify-perl libparams-util-perl libparams-validate-perl
libparse-pmfile-perl libpod-markdown-perl libpod-readme-perl libpq-dev libreadonly-perl libref-util-perl
libref-util-xs-perl librole-tiny-perl libsoftware-license-perl libstrictures-perl libstring-shellquote-perl
libsub-exporter-perl libsub-exporter-progressive-perl libsub-identify-perl libsub-install-perl libsub-quote-perl
libtext-template-perl libtype-tiny-perl libtype-tiny-xs-perl libvariable-magic-perl memcached
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
libssl-dev lstu-ynh-deps
Les paquets suivants seront mis à une VERSION INFÉRIEURE :
libssl1.1
0 mis à jour, 0 nouvellement installés, 1 remis à une version inférieure, 2 à enlever et 6 non mis à jour.
Il est nécessaire de prendre 1 538 ko dans les archives.
Après cette opération, 8 109 ko d’espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] n
Annulation.

Je ne suis pas sûr de vouloir faire ça.

J’ai déjà fait face à un problème de mise à jour sur lstu qui n’a pas réussi non plus à revenir en arrivère…

Ah oui du coup anéfé il faut faire plutôt :

apt install libssl1.1=1.1.1d-0+deb10u3 libssl-dev=1.1.1d-0+deb10u3 --allow-downgrades

(par contre en relisant plus haut je pense que c’est pas forcément la source du problème pour discourse, du coup ce serait cool de partager le log complet de l’échec d’installation pour investiguer…)

ce que j’ai gardé comme traces au moment du problème :

2020-09-09 13:09:32,958: DEBUG - libclang1-7 libcurl4-openssl-dev libicu-dev libjemalloc-dev
2020-09-09 13:09:32,959: DEBUG - libjpeg-turbo-progs libncurses-dev libobjc-8-dev libobjc4 libomp-7-dev
2020-09-09 13:09:32,959: DEBUG - libomp5-7 libreadline-dev libsctp-dev libsctp1 libturbojpeg0 libxml2-dev
2020-09-09 13:09:32,960: DEBUG - libxslt1-dev libyaml-dev llvm-7 llvm-7-dev llvm-7-runtime
2020-09-09 13:09:32,961: DEBUG - postgresql-server-dev-11 postgresql-server-dev-all uuid-dev vim vim-runtime
2020-09-09 13:09:33,062: DEBUG - 0 upgraded, 38 newly installed, 2 to remove and 9 not upgraded.
2020-09-09 13:09:33,063: WARNING - E: Packages need to be removed but remove is disabled.
2020-09-09 13:09:33,064: DEBUG - ++ dpkg --info /tmp/tmp.dghXpiFbyp/discourse-ynh-deps_2.3.10~ynh2_all.deb
2020-09-09 13:09:33,065: DEBUG - ++ sed ‘s/^ Depends: //’
2020-09-09 13:09:33,065: DEBUG - ++ grep Depends
2020-09-09 13:09:33,066: DEBUG - ++ sed s/,//g
2020-09-09 13:09:33,066: DEBUG - + local ‘dependencies=g++ libjemalloc1 | libjemalloc2 libjemalloc-dev zlib1g-dev libreadline-dev libpq-dev libssl-dev libyaml-dev libcurl4-openssl-dev libapr1-dev libxslt1-dev libxml2-dev vim imagemagick postgresql postgresql-server-dev-all postgresql-contrib optipng jhead jpegoptim gifsicle brotli’
2020-09-09 13:09:33,067: DEBUG - + ynh_package_install g++ libjemalloc1 ‘|’ libjemalloc2 libjemalloc-dev zlib1g-dev libreadline-dev libpq-dev libssl-dev libyaml-dev libcurl4-openssl-dev libapr1-dev libxslt1-dev libxml2-dev vim imagemagick postgresql postgresql-server-dev-all postgresql-contrib optipng jhead jpegoptim gifsicle brotli --dry-run
2020-09-09 13:09:33,068: DEBUG - + sed --quiet ‘/–fix-broken/,$p’
2020-09-09 13:09:33,069: DEBUG - + ynh_apt --no-remove --option Dpkg::Options::=–force-confdef --option Dpkg::Options::=–force-confold install g++ libjemalloc1 ‘|’ libjemalloc2 libjemalloc-dev zlib1g-dev libreadline-dev libpq-dev libssl-dev libyaml-dev libcurl4-openssl-dev libapr1-dev libxslt1-dev libxml2-dev vim imagemagick postgresql postgresql-server-dev-all postgresql-contrib optipng jhead jpegoptim gifsicle brotli --dry-run
2020-09-09 13:09:33,069: DEBUG - + ynh_wait_dpkg_free
2020-09-09 13:09:33,271: DEBUG - + return 0
2020-09-09 13:09:33,272: DEBUG - + LC_ALL=C
2020-09-09 13:09:33,272: DEBUG - + DEBIAN_FRONTEND=noninteractive
2020-09-09 13:09:33,273: DEBUG - + apt-get --assume-yes --quiet -o=Acquire::Retries=3 -o=Dpkg::Use-Pty=0 --no-remove --option Dpkg::Options::=–force-confdef --option Dpkg::Options::=–force-confold install g++ libjemalloc1 ‘|’ libjemalloc2 libjemalloc-dev zlib1g-dev libreadline-dev libpq-dev libssl-dev libyaml-dev libcurl4-openssl-dev libapr1-dev libxslt1-dev libxml2-dev vim imagemagick postgresql postgresql-server-dev-all postgresql-contrib optipng jhead jpegoptim gifsicle brotli --dry-run
2020-09-09 13:09:34,276: DEBUG - + ynh_die ‘–message=Unable to install dependencies’
2020-09-09 13:09:34,277: WARNING - E: Package ‘libjemalloc1’ has no installation candidate
2020-09-09 13:09:34,278: WARNING - E: Package ‘libssl-dev’ has no installation candidate
2020-09-09 13:09:34,382: DEBUG - + ret_code=1
2020-09-09 13:09:34,382: WARNING - Unable to install dependencies
2020-09-09 13:09:34,384: DEBUG - + echo ‘Unable to install dependencies’
2020-09-09 13:09:34,384: DEBUG - + exit 1
2020-09-09 13:09:34,385: DEBUG - + ynh_exit_properly
2020-09-09 13:09:34,385: DEBUG - + local exit_code=1
2020-09-09 13:09:34,385: DEBUG - + ‘[’ 1 -eq 0 ‘]’
2020-09-09 13:09:34,386: DEBUG - + trap ‘’ EXIT
2020-09-09 13:09:34,386: DEBUG - + set +o errexit
2020-09-09 13:09:34,386: DEBUG - + set +o nounset
2020-09-09 13:09:34,387: DEBUG - + sleep 0.5
2020-09-09 13:09:34,789: DEBUG - + type -t ynh_clean_setup
2020-09-09 13:09:34,790: DEBUG - + ynh_clean_setup
2020-09-09 13:09:34,791: DEBUG - + ynh_clean_check_starting
2020-09-09 13:09:34,791: DEBUG - + ‘[’ -n ‘’ ‘]’
2020-09-09 13:09:34,792: DEBUG - + ‘[’ -n ‘’ ‘]’
2020-09-09 13:09:34,793: DEBUG - + exit 1
2020-09-09 13:09:34,901: ERROR - Impossible d’installer discourse : Une erreur est survenue dans le script d’installation de l’application

Tu peux trouver le log complet dans Outils > Journaux > (l’opération d’install échouée), puis le partager avec le bouton vert

cela contient la même chose que ce que j’avais sauvegardé et recopié au dessus ( voici tout deme le paste : Le journal est désormais disponible via https://paste.yunohost.org/raw/avihecuzaq )

sinon pour apt cela fonctionne

sudo apt install libssl1.1=1.1.1d-0+deb10u3 libssl-dev=1.1.1d-0+deb10u3 --allow-downgrades
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances
Lecture des informations d’état… Fait
Paquets suggérés :
libssl-doc
Les paquets suivants seront mis à une VERSION INFÉRIEURE :
libssl-dev libssl1.1
0 mis à jour, 0 nouvellement installés, 2 remis à une version inférieure, 0 à enlever et 6 non mis à jour.
Il est nécessaire de prendre 3 332 ko dans les archives.
Après cette opération, 27,6 ko d’espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] O
Réception de :1 http://ftp.debian.org/debian buster/main amd64 libssl-dev amd64 1.1.1d-0+deb10u3 [1 793 kB]
Réception de :2 http://ftp.debian.org/debian buster/main amd64 libssl1.1 amd64 1.1.1d-0+deb10u3 [1 538 kB]
3 332 ko réceptionnés en 1s (4 180 ko/s)
Préconfiguration des paquets…
dpkg: avertissement: dégradation (« downgrade ») de libssl-dev:amd64 depuis 1.1.1g-1+0~20200421.17+debian10~1.gbpf6902f vers 1.1.1d-0+deb10u3
(Lecture de la base de données… 92653 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de …/libssl-dev_1.1.1d-0+deb10u3_amd64.deb …
Dépaquetage de libssl-dev:amd64 (1.1.1d-0+deb10u3) sur (1.1.1g-1+0~20200421.17+debian10~1.gbpf6902f) …
dpkg: avertissement: dégradation (« downgrade ») de libssl1.1:amd64 depuis 1.1.1g-1+0~20200421.17+debian10~1.gbpf6902f vers 1.1.1d-0+deb10u3
Préparation du dépaquetage de …/libssl1.1_1.1.1d-0+deb10u3_amd64.deb …
Dépaquetage de libssl1.1:amd64 (1.1.1d-0+deb10u3) sur (1.1.1g-1+0~20200421.17+debian10~1.gbpf6902f) …
Paramétrage de libssl1.1:amd64 (1.1.1d-0+deb10u3) …
Paramétrage de libssl-dev:amd64 (1.1.1d-0+deb10u3) …
Traitement des actions différées (« triggers ») pour libc-bin (2.28-10) .

Est-ce que tu es sur que si tu cliques sur le bouton partager, ce qui est partagé contient réellement seulement les lignes que tu as donné plus haut … (normalement ça montre aussi un bouton “montrer + de lignes” mais il y a un bug que j’ai identifié récemment qui fait qu’il n’est peut-être pas affiché chez toi … par contre la version partagée montre tout)

c’est ce que je découvre, ce qu’il affiche dans la fenetre n’est pas ce qu’il copy/paste.
( lien fourni texte au dessus édité )

suite à mon apt j’ai retenté une installation de discourse.

Cela échoue : Le journal est désormais disponible via https://paste.yunohost.org/raw/ibolukumor

Zblerg je pense que c’est le soucis “classique” de conflit entre les dépendances de discourse et certaines autres apps … dans ton cas à cause de libcurl4-gnutls-dev (nécessaire pour minetest) qui conflicte avec libcurl4-openssl-dev (nécessaire pour discourse)

1 Like