Problème envoi mail sur domaine gmail

D’abord merci de ta réponse. La configuration de l’IPV6 était ce que je suspectais mais je voulais me faire confirmer.

Le ping marche bien il me renvoi 0 paquets perdus:

wikipedia.org ping statistics —
19 packets transmitted, 19 received, 0% packet loss, time 18026ms
rtt min/avg/max/mdev = 38.490/39.666/42.362/0.812 ms

Concernant la commande telnet faut que je trouve un autre réseau où me connecter ^^
Juste une petite précision mon IPV6 est bien un chiffre en héxadécimale?

Edit: je ne sais pas si cela a un lien mais je suis abonné à une Framaliste, est mes messages sont tagué de spam dans l’objet du mail :*spam"

Ca peut avoir un lien.
N’hésites pas à vérifie rta config avec https://www.mail-tester.com/

J’ai une note de 2,5…

Ma signature DKIM n’est pas valide (je ne sais pas ce que c’est)
Mon DNS ne correspond pas à mon nom de domaine:

La recherche ou la résolution de la reverse DNS (rDNS) permet de déterminer si un nom de domaine est associé à l’adresse IP donnée.
Quelques entreprises comme AOL rejetteront tout message envoyé d’un serveur sans rDNS, vous devez vous assurer d’en avoir une.
Vous ne pouvez pas associer plus d’un nom de domaine à une adresse IP unique.

-2.5 NO_FM_NAME_IP_HOSTN NO_FM_NAME_IP_HOSTN
-1.985 PYZOR_CHECK Similar message reported on Pyzor (http://pyzor.org)

https://pyzor.readthedocs.io/en/latest/
Assurez-vous de tester avec un contenu réel, les Newsletters tests seront toujours détectées par Pyzor
Ajustez votre message ou demandez à être whitelisté (http://public.pyzor.org/whitelist/)
|

Voilà ce que j’ai comme résultats et je ne comprends rien, si tu pouvais traduire :slight_smile:

Merci d’avance

Edit1: Quand je regarde mon adresse IPV6 dans ma configuration DNS, ce n’est pas la même que j’ai quand je regarde dans ma Freebox. Est ce que c’est normal?

Edit2: Je crois savoir où j’ai merdé, la 1ere fois que j’ai créer mon serveur j’étais sous un autre nom de domaine. J’ai mal lu la doc et n’ai pas fait le nécéssaire… Suppression nom de domaine dans le fil de discussion et la commande rm des fichiers des fichiers de configurations automatique.

Je crois que j’ai fait un sac de noeud tout seul…

lJf pour répondre à toutes tes questions posées, je peux contacter mon serveur avecla commande telnet sans problème depuis une connexion extérieure.

Je pensais que tu utilisais ton nom de domaine en ynh.fr mais visiblement c’est pas le cas.

Tu dois donc configurer la zone DNS de ton nom de domaine correctement, c’ets à dire comme indiqué dans Web Admin > Domain > Ton domaine qui n’est pas en ynh.fr > Configuration DNS

Re,

Justement j’ai utilisé pour le test mon adresse en nom de domaine en ynh.fr, mais comme je te disais plus haut j’ai constaté que j’avais fait une erreur, en relisant la documentation sur le site:

Mon premier nom de domaine principal sur mon serveur était xxx.ynh.fr.
Lorsque je l’ai supprimé pour mon nouveau de domaine que j’utilise actuellement je n’ai pas suivi ce qui est dit ici:

https://yunohost.org/#/dns_nohost_me_fr

*### Changer un domaine nohost.me, noho.st ou ynh.fr

Si vous voulez utiliser un autre domaine automatique sur votre serveur, vous devez d’abord supprimer celui qui est déjà configuré, selon les instructions suivantes :

  1. Supprimer le domaine de votre instance (par webadmin ou yunohost domain remove ). Attention : cela supprimera toute application installée sur ce domaine, ainsi que ses données .
  2. Demander la suppression de votre souscription dans le fil de discussion dédié du forum.
  3. Enlever les fichiers de configuration automatique sur votre instance (uniquement depuis la ligne de commande pour le moment) : sudo rm /etc/cron.d/yunohost-dyndns && sudo rm -r /etc/yunohost/dyndns*

Effectivement après test elle est toujours valide et j’arrive sur la page d’administration de mon serveur lorsque je la rentre dans mon navigateur…

Est ce que mon problème vient de là, à ton avis?

Peut être.

Les commandes proposées par “yunohost dyndns --help” t’aideront à resynchroniser ton nom de domaine je pense.

Lorsque tu fais

dig +short TXT xxx.ynh.fr @9.9.9.9 

tu dois obtenir ce qui correspond à ta clé dkim (une longue suite de chiffre et de lettre)

Pour le Reverse DNS, il faut le configurer sur ta connexion. Tous les FAI ne le permettent pas, notamment free à tendance à mentir sur sa mise en place chez certains abonnés.

Merci je ne suis pas chez moi, je ne pourrai pas tester cett commande tout de suite.

Est ce que je fais quand même la demande de suppression de mon ancien nom de domaine sur le forum ou vaut il mieux que j’évite?

Pour la configuration du reverse DNS, quelle est la valeur que je dois configurer ? Et pour mon DNS ?
A priori chez Free pour le rDNS il suffit de renseigner le nom de domaine dans son interface client à voir c’est au même endroit que pour l’ouverture du port 25.

J’avoue que je n’y connais pas grand chose et tout ça me semble un peu nébuleux, j’y vais à taton à coup de recherche internet.

Tu devrais le faire

Il faut mettre le domaine principal que tu as configuré sur ton yunohost. C’est le domaine avec la petite étoile dans Web admin > Domaines

Si c’est un domaine en ynh.fr et que tu l’as bien créé à partir de “Je n’ai pas de nom de domaine”, il suffit de faire:

yunohost dyndns update xxx.ynh.fr --force

Pour que les valeurs de la zone DNS soient mise à jour.

Si tu l’a créé à partir de “J’ai déjà un nom de domaine” dans ce cas tu devrais tenter de faire cette commande avant:

yunohost dyndns subscribe -d xxx.ynh.fr

Je connais au moins une personne pour qui cette interface ne fonctionne pas. Apparement free propose l’option mais ça ne marche pas sur tous les abonnements…

Si tu veux vérifier le reverse DNS, tu peux le faire via (ou sur des sites en ligne)

dig +short -x TON_IP_PUBLIQUE

Cette page peut t’aider: https://yunohost.org/#/dns_nohost_me_fr

Justement ce domaine je l’ai crée il y a plus d’un an, je ne sais plus comment je l’ai crée… je vais tenter
yunohost dyndns update xxx.ynh.fr --force

On verra si ça marche. Sinon je peux essayer l’autre commande si cela échoue ça n’engage rien?

Merci pour le lien, c’est cette page qui m’avait alerté sur le fait que je n’avais pas été propre concernant la suppression de mon nom de domaine…

Oui tu peux le faire après.

Hello,

Je progresse, j’ai une note de 4,9/10. J’ai configuré mon rDNS auprès de free et ma note a progressé d’un coup!
Le gros point noir reste ma signature DKIM.
J’attends que la suppression de mon domaine soit effectif pour essayer de forcer la reconfiguration automatique de mon DNS

La commande

dig +short TXT xxx.ynh.fr @9.9.9.9 

Me renvoi "v=spf1 a mx ip4:81.56.70.100 -all"

Est ce normal?

PS:
yunohost dyndns update xxx.ynh.fr --force

Ne fonctionne pas, en regardant le man je suppose qu’il faut écrire:

sudo yunohost dyndns update -d xxx.ynh.fr --force seulement l’argument --force n’est pas reconnu. Fau t’il l’enlever?

OUI ton SPF ext correct (enfin si ton ip est celle indiqué)

Je me suis trompé, pour obtenir la clé dkim:

dig +short TXT mail._domainkey.xxx.ynh.fr @9.9.9.9 

C’est que le --force vient dans une version future pas disponible avec ta version de yunohost.

Essaie juste: yunohost dyndns update -d xxx.ynh.fr

Salut,

Voilà la réponse pour la commande

dig +short TXT mail._domainkey.xxx.ynh.fr @9.9.9.9


"v=DKIM1; h=sha256; k=rsa; p=MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQCsd4YrRgWBUDNHYoAEXKnz9h77pL97C/ou6tmXUuz8yHjKKsX7H4rZv2AmJ90ORSIjWwENHWACVeQ7YNtuVaaC3Cj9dFJXbJPRr3eZb3rA3MZ4q+NbZkf5khfPO7jo1BLFUTTl0Fj0ffMjDrWqsKdNq0EirlT20F5LNXsmfQUBGwIDAQAB"

la réponse à:

yunohost dyndns update -d xxx.ynh.fr

donne:

Error: DNS key not found for the domain

Concernant la commande subscribe:

sudo yunohost dyndns subscribe -d xxx.ynh.fr
Error: You've already subscribed to a DynDNS domain

Mon nom de domaine d’origine est toujours actif cela vient peut être de là?

Il doit te manquer un TON_DOMAINE.private dans /etc/yunohost/dyndns/

Ok je vais vérifier ça.
S’il manque ce fichier in fait comment?

On le recrée manuellement je pense.
C’est un système que tu as restauré d’une sauvegarde ?