# Probleme d'installation applications

**URL:** https://forum.yunohost.org/t/probleme-dinstallation-applications/4058
**Category:** Support apps
**Tags:** french
**Created:** [January 5, 2018, 11:07am UTC](https://forum.yunohost.org/t/probleme-dinstallation-applications/4058 "2018-01-05T11:07:42Z")
**Posts on this page:** 12
**Page:** 1

<div class="post-metadata">

### Author: ![Didier58](https://forum.yunohost.org/letter_avatar_proxy/v4/letter/d/8797f3/32.png) [@Didier58](https://forum.yunohost.org/u/Didier58)
#### Post date: [January 5, 2018, 11:07am UTC](https://forum.yunohost.org/t/probleme-dinstallation-applications/4058/1 "2018-01-05T11:07:43Z")

</div>

@Bonjour à tous,

lors de l’essai d’installation de phpMyAdmin pour l’exemple voir le résultat ci-joint:

La configuration de SSOwat a été générée

- echo ‘The user phpmyadmin was not found’

The user phpmyadmin was not found

- getent passwd phpmyadmin

- ynh\_system\_user\_exists phpmyadmin

- ynh\_system\_user\_delete phpmyadmin

- sudo systemctl reload php5-fpm

/etc/php5/fpm/conf.d/20-phpmyadmin.ini wasn’t deleted because it doesn’t exist.

- echo ‘/etc/php5/fpm/conf.d/20-phpmyadmin.ini wasn’’‘t deleted because it doesn’’‘t exist.’

- ‘[’ -e /etc/php5/fpm/conf.d/20-phpmyadmin.ini ‘]’

- [[i = /]]

- [[/etc/php5/fpm/conf.d/20-phpmyadmin.ini =~ ^/[[:alnum:]]+$ ]]

- [[/var/www /home/yunohost.app =~ /etc/php5/fpm/conf.d/20-phpmyadmin.ini]]

- forbidden\_path=’ /var/www /home/yunohost.app’

- path\_to\_remove=/etc/php5/fpm/conf.d/20-phpmyadmin.ini

- ynh\_secure\_remove /etc/php5/fpm/conf.d/20-phpmyadmin.ini

- echo ‘/etc/php5/fpm/pool.d/phpmyadmin.conf wasn’’‘t deleted because it doesn’’‘t exist.’

- ‘[’ -e /etc/php5/fpm/pool.d/phpmyadmin.conf ‘]’

- [[f = /]]

- [[/etc/php5/fpm/pool.d/phpmyadmin.conf =~ ^/[[:alnum:]]+$ ]]

- [[/var/www /home/yunohost.app =~ /etc/php5/fpm/pool.d/phpmyadmin.conf]]

- forbidden\_path=’ /var/www /home/yunohost.app’

- path\_to\_remove=/etc/php5/fpm/pool.d/phpmyadmin.conf

/etc/php5/fpm/pool.d/phpmyadmin.conf wasn’t deleted because it doesn’t exist.

- ynh\_secure\_remove /etc/php5/fpm/pool.d/phpmyadmin.conf

- ynh\_remove\_fpm\_config

- sudo systemctl reload nginx

- echo ‘/etc/nginx/conf.d/didiercl.me.d/phpmyadmin.conf wasn’’‘t deleted because it doesn’’‘t exist.’

- ‘[’ -e /etc/nginx/conf.d/didiercl.me.d/phpmyadmin.conf ‘]’

- [[f = /]]

- [[/etc/nginx/conf.d/didiercl.me.d/phpmyadmin.conf =~ ^/[[:alnum:]]+$ ]]

- [[/var/www /home/yunohost.app =~ /etc/nginx/conf.d/didiercl.me.d/phpmyadmin.conf]]

- forbidden\_path=’ /var/www /home/yunohost.app’

- path\_to\_remove=/etc/nginx/conf.d/didiercl.me.d/phpmyadmin.conf

- ynh\_secure\_remove /etc/nginx/conf.d/didiercl.me.d/phpmyadmin.conf

- ynh\_remove\_nginx\_config

- echo ‘Avoid deleting .’

- [[/var/www /home/yunohost.app =~ ‘’]]

- forbidden\_path=’ /var/www /home/yunohost.app’

/etc/nginx/conf.d/didiercl.me.d/phpmyadmin.conf wasn’t deleted because it doesn’t exist.

- path\_to\_remove=

- ynh\_secure\_remove ‘’

++ return 1

Avoid deleting .

++ [[-z ‘’]]

ERROR 29 (HY000) at line 1: File ‘./mysql/user.MYD’ not found (Errcode: 13 “Permission denied”)

+++ mysql -u root --password=XXXXXXXXXX -B ‘’

+++ ynh\_mysql\_connect\_as root XXXXXXXXXX ‘’

++++ sudo cat /etc/yunohost/mysql

+++ ynh\_mysql\_execute\_as\_root ‘SELECT User from mysql.user WHERE User = ‘’‘phpmyadmin’’’;’

++ local user=phpmyadmin

++ ynh\_mysql\_user\_exists phpmyadmin

- mysql -u root --password=XXXXXXXXXX -B ‘’

- ynh\_mysql\_connect\_as root XXXXXXXXXX ‘’

++ sudo cat /etc/yunohost/mysql

- ynh\_mysql\_execute\_as\_root ‘DROP DATABASE phpmyadmin;’

Removing database phpmyadmin

- ynh\_mysql\_drop\_db phpmyadmin

- echo ‘Removing database phpmyadmin’

- grep -q ‘^| phpmyadmin’

- mysqlshow -u root -pXXXXXXXXXX

- local mysql\_root\_password=XXXXXXXXXX

++ sudo cat /etc/yunohost/mysql

- local db\_name=phpmyadmin

- local db\_user=phpmyadmin

- ynh\_mysql\_remove\_db phpmyadmin phpmyadmin

- final\_path=

++ sudo yunohost app setting phpmyadmin final\_path --output-as plain --quiet

++ ynh\_app\_setting\_get phpmyadmin final\_path

- db\_name=phpmyadmin

++ sudo yunohost app setting phpmyadmin db\_name --output-as plain --quiet

++ ynh\_app\_setting\_get phpmyadmin db\_name

- [domain=didiercl.me](http://domain=didiercl.me)

++ sudo yunohost app setting phpmyadmin domain --output-as plain --quiet

++ ynh\_app\_setting\_get phpmyadmin domain

- app=phpmyadmin

++ . /usr/share/yunohost/helpers.d/utils

++ ‘[’ -r /usr/share/yunohost/helpers.d/utils ‘]’

++ for helper in ‘$(run-parts --list /usr/share/yunohost/helpers.d 2\>/dev/null)’

++ . /usr/share/yunohost/helpers.d/user

++ ‘[’ -r /usr/share/yunohost/helpers.d/user ‘]’

++ for helper in ‘$(run-parts --list /usr/share/yunohost/helpers.d 2\>/dev/null)’

++ . /usr/share/yunohost/helpers.d/system

++ ‘[’ -r /usr/share/yunohost/helpers.d/system ‘]’

++ for helper in ‘$(run-parts --list /usr/share/yunohost/helpers.d 2\>/dev/null)’

++ . /usr/share/yunohost/helpers.d/string

++ ‘[’ -r /usr/share/yunohost/helpers.d/string ‘]’

++ for helper in ‘$(run-parts --list /usr/share/yunohost/helpers.d 2\>/dev/null)’

++ . /usr/share/yunohost/helpers.d/setting

++ ‘[’ -r /usr/share/yunohost/helpers.d/setting ‘]’

++ for helper in ‘$(run-parts --list /usr/share/yunohost/helpers.d 2\>/dev/null)’

++ . /usr/share/yunohost/helpers.d/print

++ ‘[’ -r /usr/share/yunohost/helpers.d/print ‘]’

++ for helper in ‘$(run-parts --list /usr/share/yunohost/helpers.d 2\>/dev/null)’

++ . /usr/share/yunohost/helpers.d/package

++ ‘[’ -r /usr/share/yunohost/helpers.d/package ‘]’

++ for helper in ‘$(run-parts --list /usr/share/yunohost/helpers.d 2\>/dev/null)’

++ . /usr/share/yunohost/helpers.d/network

++ ‘[’ -r /usr/share/yunohost/helpers.d/network ‘]’

++ for helper in ‘$(run-parts --list /usr/share/yunohost/helpers.d 2\>/dev/null)’

+++ MYSQL\_ROOT\_PWD\_FILE=/etc/yunohost/mysql

++ . /usr/share/yunohost/helpers.d/mysql

++ ‘[’ -r /usr/share/yunohost/helpers.d/mysql ‘]’

++ for helper in ‘$(run-parts --list /usr/share/yunohost/helpers.d 2\>/dev/null)’

++ . /usr/share/yunohost/helpers.d/ip

++ ‘[’ -r /usr/share/yunohost/helpers.d/ip ‘]’

++ for helper in ‘$(run-parts --list /usr/share/yunohost/helpers.d 2\>/dev/null)’

+++ CAN\_BIND=1

++ . /usr/share/yunohost/helpers.d/filesystem

++ ‘[’ -r /usr/share/yunohost/helpers.d/filesystem ‘]’

++ for helper in ‘$(run-parts --list /usr/share/yunohost/helpers.d 2\>/dev/null)’

++ . /usr/share/yunohost/helpers.d/backend

++ ‘[’ -r /usr/share/yunohost/helpers.d/backend ‘]’

++ for helper in ‘$(run-parts --list /usr/share/yunohost/helpers.d 2\>/dev/null)’

+++ run-parts --list /usr/share/yunohost/helpers.d

- source /usr/share/yunohost/helpers

Exécution du script « /var/cache/yunohost/from\_file/phpmyadmin\_ynh-d7bc1f6c1ce4803cac737a862ef378e978a3e9d2/scripts/remove »…

- exit 1

- echo ‘’

- ynh\_die

- type -t ynh\_clean\_setup

- echo -e ‘!!\n phpmyadmin’’‘s script has encountered an error. Its execution was cancelled.\n!!’

- set +eu

- trap ‘’ EXIT

- ‘[’ 1 -eq 0 ‘]’

!!

phpmyadmin’s script has encountered an error. Its execution was cancelled.

!!

- exit\_code=1

- ynh\_exit\_properly

ERROR 1290 (HY000) at line 1: The MariaDB server is running with the --skip-grant-tables option so it cannot execute this statement

- mysql -u root --password=XXXXXXXXXX -B ‘’

- ynh\_mysql\_connect\_as root XXXXXXXXXX ‘’

++ sudo cat /etc/yunohost/mysql

- ynh\_mysql\_execute\_as\_root ‘CREATE DATABASE phpmyadmin; GRANT ALL PRIVILEGES ON phpmyadmin.\* TO ‘’‘phpmyadmin’’’@’’‘localhost’’’ IDENTIFIED BY ‘’‘EthZhhrMpZEXCqMRiFv9nAX0’’’ WITH GRANT OPTION;’

- sql+=’ WITH GRANT OPTION;’

- sql+=’ IDENTIFIED BY ‘’‘EthZhhrMpZEXCqMRiFv9nAX0’’’’

- [[-n EthZhhrMpZEXCqMRiFv9nAX0]]

- sql+=’ GRANT ALL PRIVILEGES ON phpmyadmin.\* TO ‘’‘phpmyadmin’’’@’’‘localhost’’’’

- [[3 -gt 1]]

- sql=‘CREATE DATABASE phpmyadmin;’

- db=phpmyadmin

- ynh\_mysql\_create\_db phpmyadmin phpmyadmin EthZhhrMpZEXCqMRiFv9nAX0

- db\_pwd=EthZhhrMpZEXCqMRiFv9nAX0

- local new\_db\_pwd=EthZhhrMpZEXCqMRiFv9nAX0

++ sed -n ‘s/(.{24}).\*/\1/p’

++ dd if=/dev/urandom bs=1 count=200

++ tr -c -d A-Za-z0-9

++ ynh\_string\_random

- local db\_name=phpmyadmin

- local db\_user=phpmyadmin

- ynh\_mysql\_setup\_db phpmyadmin phpmyadmin

- sudo yunohost app setting phpmyadmin db\_name --value=phpmyadmin --quiet

- ynh\_app\_setting\_set phpmyadmin db\_name phpmyadmin

- db\_name=phpmyadmin

++ echo phpmyadmin

++ dbid=phpmyadmin

++ ynh\_sanitize\_dbid phpmyadmin

- sudo yunohost app setting phpmyadmin admin --value=dclaus --quiet

- ynh\_app\_setting\_set phpmyadmin admin dclaus

- sudo yunohost app setting phpmyadmin path --value=/phpmyadmin --quiet

- ynh\_app\_setting\_set phpmyadmin path /phpmyadmin

- sudo yunohost app setting phpmyadmin domain --value=[didiercl.me](http://didiercl.me) --quiet

- ynh\_app\_setting\_set phpmyadmin domain [didiercl.me](http://didiercl.me)

- sudo yunohost app register-url phpmyadmin [didiercl.me](http://didiercl.me) /phpmyadmin

- local path=/phpmyadmin

- local [domain=didiercl.me](http://domain=didiercl.me)

- local app=phpmyadmin

- ynh\_webpath\_register phpmyadmin [didiercl.me](http://didiercl.me) /phpmyadmin

True

- sudo yunohost domain url-available [didiercl.me](http://didiercl.me) /phpmyadmin

- local path=/phpmyadmin

- local [domain=didiercl.me](http://domain=didiercl.me)

- ynh\_webpath\_available [didiercl.me](http://didiercl.me) /phpmyadmin

- path\_url=/phpmyadmin

++ echo /phpmyadmin

++ ‘[’ n == / ‘]’

++ ‘[’ / ‘!=’ / ‘]’

++ test -n /phpmyadmin

++ path\_url=/phpmyadmin

++ ynh\_normalize\_url\_path /phpmyadmin

- test ‘!’ -e /var/www/phpmyadmin

- final\_path=/var/www/phpmyadmin

- app=phpmyadmin

- admin=dclaus

- path\_url=/phpmyadmin

- [domain=didiercl.me](http://domain=didiercl.me)

- trap ynh\_exit\_properly EXIT

- set -eu

- ynh\_abort\_if\_errors

++ . /usr/share/yunohost/helpers.d/utils

++ ‘[’ -r /usr/share/yunohost/helpers.d/utils ‘]’

++ for helper in ‘$(run-parts --list /usr/share/yunohost/helpers.d 2\>/dev/null)’

++ . /usr/share/yunohost/helpers.d/user

++ ‘[’ -r /usr/share/yunohost/helpers.d/user ‘]’

++ for helper in ‘$(run-parts --list /usr/share/yunohost/helpers.d 2\>/dev/null)’

++ . /usr/share/yunohost/helpers.d/system

++ ‘[’ -r /usr/share/yunohost/helpers.d/system ‘]’

++ for helper in ‘$(run-parts --list /usr/share/yunohost/helpers.d 2\>/dev/null)’

++ . /usr/share/yunohost/helpers.d/string

++ ‘[’ -r /usr/share/yunohost/helpers.d/string ‘]’

++ for helper in ‘$(run-parts --list /usr/share/yunohost/helpers.d 2\>/dev/null)’

++ . /usr/share/yunohost/helpers.d/setting

++ ‘[’ -r /usr/share/yunohost/helpers.d/setting ‘]’

++ for helper in ‘$(run-parts --list /usr/share/yunohost/helpers.d 2\>/dev/null)’

++ . /usr/share/yunohost/helpers.d/print

++ ‘[’ -r /usr/share/yunohost/helpers.d/print ‘]’

++ for helper in ‘$(run-parts --list /usr/share/yunohost/helpers.d 2\>/dev/null)’

++ . /usr/share/yunohost/helpers.d/package

++ ‘[’ -r /usr/share/yunohost/helpers.d/package ‘]’

++ for helper in ‘$(run-parts --list /usr/share/yunohost/helpers.d 2\>/dev/null)’

++ . /usr/share/yunohost/helpers.d/network

++ ‘[’ -r /usr/share/yunohost/helpers.d/network ‘]’

++ for helper in ‘$(run-parts --list /usr/share/yunohost/helpers.d 2\>/dev/null)’

+++ MYSQL\_ROOT\_PWD\_FILE=/etc/yunohost/mysql

++ . /usr/share/yunohost/helpers.d/mysql

++ ‘[’ -r /usr/share/yunohost/helpers.d/mysql ‘]’

++ for helper in ‘$(run-parts --list /usr/share/yunohost/helpers.d 2\>/dev/null)’

++ . /usr/share/yunohost/helpers.d/ip

++ ‘[’ -r /usr/share/yunohost/helpers.d/ip ‘]’

++ for helper in ‘$(run-parts --list /usr/share/yunohost/helpers.d 2\>/dev/null)’

+++ CAN\_BIND=1

++ . /usr/share/yunohost/helpers.d/filesystem

++ ‘[’ -r /usr/share/yunohost/helpers.d/filesystem ‘]’

++ for helper in ‘$(run-parts --list /usr/share/yunohost/helpers.d 2\>/dev/null)’

++ . /usr/share/yunohost/helpers.d/backend

++ ‘[’ -r /usr/share/yunohost/helpers.d/backend ‘]’

++ for helper in ‘$(run-parts --list /usr/share/yunohost/helpers.d 2\>/dev/null)’

+++ run-parts --list /usr/share/yunohost/helpers.d

- source /usr/share/yunohost/helpers

- source \_common.sh

Exécution du script « /var/cache/yunohost/from\_file/phpmyadmin\_ynh-d7bc1f6c1ce4803cac737a862ef378e978a3e9d2/scripts/install »…

Vérification des paquets requis…

Terminé

Extraction…

Téléchargement…

Connecté

une idée pour essayer de résoudre le soucis?

je pense que le soucis viens de mysql car j’ai encore des soucis avec lors de redémarrage de la brique.

didier58

---

<div class="post-metadata">

### Author: ![Maniack\_Crudelis](https://forum.yunohost.org/user_avatar/forum.yunohost.org/maniack_crudelis/32/13_2.png) [@Maniack\_Crudelis](https://forum.yunohost.org/u/Maniack_Crudelis)
#### Post date: [January 5, 2018, 12:01pm UTC](https://forum.yunohost.org/t/probleme-dinstallation-applications/4058/2 "2018-01-05T12:01:43Z")

</div>

> [@Didier58](#):
>
> ERROR 1290 (HY000) at line 1: The MariaDB server is running with the --skip-grant-tables option so it cannot execute this statement

Ton erreur est ici. C’est donc effectivement lié à mysql.

---

<div class="post-metadata">

### Author: ![Didier58](https://forum.yunohost.org/letter_avatar_proxy/v4/letter/d/8797f3/32.png) [@Didier58](https://forum.yunohost.org/u/Didier58)
#### Post date: [January 5, 2018, 9:09pm UTC](https://forum.yunohost.org/t/probleme-dinstallation-applications/4058/3 "2018-01-05T21:09:00Z")

</div>

Merci pour ta réponse

y a t’il un moyen de réparer cela?

et comment?

si je n’utilise pas su - mysql -s /bin/bash -c "/usr/sbin/mysqld --skip-grant-tables"  
je n’arrive à ne rien faire marché a part le mail toutes les autres applications qui ont besoin de mysql ne fonctionnent as sans cela je ne voie pas comment m’en sortir!

didier58

---

<div class="post-metadata">

### Author: ![Didier58](https://forum.yunohost.org/letter_avatar_proxy/v4/letter/d/8797f3/32.png) [@Didier58](https://forum.yunohost.org/u/Didier58)
#### Post date: [January 5, 2018, 10:40pm UTC](https://forum.yunohost.org/t/probleme-dinstallation-applications/4058/4 "2018-01-05T22:40:52Z")

</div>

re-bonjour à tous,

en assaillant de démarrer le service avec le terminal voici le résultat

root@didiercl:/etc/yunohost# sudo yunohost service start mysql  
Job for mysql.service failed. See ‘systemctl status mysql.service’ and ‘journalctl -xn’ for details.  
Succès ! Le service « mysql » a été démarré

mais le service n’est pas démarrer.

en consultant systemctl status mysql.service

root@didiercl:/etc/yunohost# systemctl status mysql.service  
● mysql.service - LSB: Start and stop the mysql database server daemon  
Loaded: loaded (/etc/init.d/mysql)  
Active: failed (Result: exit-code) since ven. 2018-01-05 23:32:51 CET; 3min 38s ago  
Process: 3800 ExecStart=/etc/init.d/mysql start (code=exited, status=1/FAILURE)

janv. 05 23:32:51 [didiercl.me](http://didiercl.me) /etc/init.d/mysql[4247]: 0 processes alive and ‘/usr/bin/mysqladmin --defaults-file=/etc/mysql/debian.cnf ping’ resulted in  
janv. 05 23:32:51 [didiercl.me](http://didiercl.me) /etc/init.d/mysql[4247]: [61B blob data]  
janv. 05 23:32:51 [didiercl.me](http://didiercl.me) /etc/init.d/mysql[4247]: error: 'Can’t connect to local MySQL server through socket ‘/var/run/mysqld/mysqld.sock’ (2 “No such fi…ectory”)'  
janv. 05 23:32:51 [didiercl.me](http://didiercl.me) mysql[3800]: Starting MariaDB database server: mysqld . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . failed!  
janv. 05 23:32:51 [didiercl.me](http://didiercl.me) systemd[1]: mysql.service: control process exited, code=exited status=1  
janv. 05 23:32:51 [didiercl.me](http://didiercl.me) systemd[1]: Failed to start LSB: Start and stop the mysql database server daemon.  
janv. 05 23:32:51 [didiercl.me](http://didiercl.me) systemd[1]: Unit mysql.service entered failed state.  
Hint: Some lines were ellipsized, use -l to show in full.

en consultant journalctl -xn

root@didiercl:/etc/yunohost# journalctl -xn  
– Logs begin at ven. 2018-01-05 22:42:23 CET, end at ven. 2018-01-05 23:39:13 CET. –  
janv. 05 23:39:01 [didiercl.me](http://didiercl.me) CRON[4376]: pam\_unix(cron:session): session opened for user root by (uid=0)  
janv. 05 23:39:01 [didiercl.me](http://didiercl.me) CRON[4377]: (root) CMD ( [-x /usr/lib/php5/sessionclean] && /usr/lib/php5/sessionclean)  
janv. 05 23:39:01 [didiercl.me](http://didiercl.me) CRON[4376]: pam\_unix(cron:session): session closed for user root  
janv. 05 23:39:03 [didiercl.me](http://didiercl.me) slapd[804]: \<= mdb\_equality\_candidates: (memberUid) not indexed  
janv. 05 23:39:03 [didiercl.me](http://didiercl.me) slapd[804]: \<= mdb\_equality\_candidates: (member) not indexed  
janv. 05 23:39:03 [didiercl.me](http://didiercl.me) slapd[804]: slap\_global\_control: unrecognized control: 1.3.6.1.4.1.4203.666.5.16  
janv. 05 23:39:03 [didiercl.me](http://didiercl.me) slapd[804]: \<= mdb\_equality\_candidates: (gidNumber) not indexed  
janv. 05 23:39:03 [didiercl.me](http://didiercl.me) slapd[804]: slap\_global\_control: unrecognized control: 1.3.6.1.4.1.4203.666.5.16  
janv. 05 23:39:03 [didiercl.me](http://didiercl.me) slapd[804]: \<= mdb\_equality\_candidates: (gidNumber) not indexed  
janv. 05 23:39:13 [didiercl.me](http://didiercl.me) sshd[4450]: pam\_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=61.177.172.66 user=root

mais je ne sais pas quoi faire pour continuer.

didier58

---

<div class="post-metadata">

### Author: ![Maniack\_Crudelis](https://forum.yunohost.org/user_avatar/forum.yunohost.org/maniack_crudelis/32/13_2.png) [@Maniack\_Crudelis](https://forum.yunohost.org/u/Maniack_Crudelis)
#### Post date: [January 5, 2018, 11:04pm UTC](https://forum.yunohost.org/t/probleme-dinstallation-applications/4058/5 "2018-01-05T23:04:59Z")

</div>

Plutôt que `journalctl -xn`, essaye `journalctl -u mysql`

---

<div class="post-metadata">

### Author: ![Didier58](https://forum.yunohost.org/letter_avatar_proxy/v4/letter/d/8797f3/32.png) [@Didier58](https://forum.yunohost.org/u/Didier58)
#### Post date: [January 5, 2018, 11:50pm UTC](https://forum.yunohost.org/t/probleme-dinstallation-applications/4058/6 "2018-01-05T23:50:08Z")

</div>

voici le résultat:

root@didiercl:~# journalctl -u mysql  
– Logs begin at ven. 2018-01-05 22:42:23 CET, end at sam. 2018-01-06 00:46:50 CET. –  
janv. 05 22:42:36 [didiercl.me](http://didiercl.me) systemd[1]: Starting LSB: Start and stop the mysql database server daemon…  
janv. 05 22:43:20 [didiercl.me](http://didiercl.me) /etc/init.d/mysql[2028]: 0 processes alive and ‘/usr/bin/mysqladmin --defaults-file=/etc/mysql/debian.cnf ping’ resulted in  
janv. 05 22:43:20 [didiercl.me](http://didiercl.me) /etc/init.d/mysql[2028]: [61B blob data]  
janv. 05 22:43:20 [didiercl.me](http://didiercl.me) /etc/init.d/mysql[2028]: error: 'Can’t connect to local MySQL server through socket ‘/var/run/mysqld/mysqld.sock’ (2 “No such file or directory”)'  
janv. 05 22:43:20 [didiercl.me](http://didiercl.me) mysql[952]: Starting MariaDB database server: mysqld . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . failed!  
janv. 05 22:43:20 [didiercl.me](http://didiercl.me) systemd[1]: mysql.service: control process exited, code=exited status=1  
janv. 05 22:43:20 [didiercl.me](http://didiercl.me) systemd[1]: Failed to start LSB: Start and stop the mysql database server daemon.  
janv. 05 22:43:20 [didiercl.me](http://didiercl.me) systemd[1]: Unit mysql.service entered failed state.  
janv. 05 22:56:20 [didiercl.me](http://didiercl.me) systemd[1]: Starting LSB: Start and stop the mysql database server daemon…  
janv. 05 22:56:52 [didiercl.me](http://didiercl.me) /etc/init.d/mysql[3234]: 0 processes alive and ‘/usr/bin/mysqladmin --defaults-file=/etc/mysql/debian.cnf ping’ resulted in  
janv. 05 22:56:52 [didiercl.me](http://didiercl.me) /etc/init.d/mysql[3234]: [61B blob data]  
janv. 05 22:56:52 [didiercl.me](http://didiercl.me) /etc/init.d/mysql[3234]: error: 'Can’t connect to local MySQL server through socket ‘/var/run/mysqld/mysqld.sock’ (2 “No such file or directory”)'  
janv. 05 22:56:52 [didiercl.me](http://didiercl.me) mysql[2787]: Starting MariaDB database server: mysqld . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . failed!  
janv. 05 22:56:52 [didiercl.me](http://didiercl.me) systemd[1]: mysql.service: control process exited, code=exited status=1  
janv. 05 22:56:52 [didiercl.me](http://didiercl.me) systemd[1]: Failed to start LSB: Start and stop the mysql database server daemon.  
janv. 05 22:56:52 [didiercl.me](http://didiercl.me) systemd[1]: Unit mysql.service entered failed state.  
janv. 05 23:32:18 [didiercl.me](http://didiercl.me) systemd[1]: Starting LSB: Start and stop the mysql database server daemon…  
janv. 05 23:32:51 [didiercl.me](http://didiercl.me) /etc/init.d/mysql[4247]: 0 processes alive and ‘/usr/bin/mysqladmin --defaults-file=/etc/mysql/debian.cnf ping’ resulted in  
janv. 05 23:32:51 [didiercl.me](http://didiercl.me) /etc/init.d/mysql[4247]: [61B blob data]  
janv. 05 23:32:51 [didiercl.me](http://didiercl.me) /etc/init.d/mysql[4247]: error: 'Can’t connect to local MySQL server through socket ‘/var/run/mysqld/mysqld.sock’ (2 “No such file or directory”)'  
janv. 05 23:32:51 [didiercl.me](http://didiercl.me) mysql[3800]: Starting MariaDB database server: mysqld . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . failed!  
janv. 05 23:32:51 [didiercl.me](http://didiercl.me) systemd[1]: mysql.service: control process exited, code=exited status=1  
janv. 05 23:32:51 [didiercl.me](http://didiercl.me) systemd[1]: Failed to start LSB: Start and stop the mysql database server daemon.  
janv. 05 23:32:51 [didiercl.me](http://didiercl.me) systemd[1]: Unit mysql.service entered failed state.

pour moi c’est pas très parlant!

didier58

---

<div class="post-metadata">

### Author: ![Maniack\_Crudelis](https://forum.yunohost.org/user_avatar/forum.yunohost.org/maniack_crudelis/32/13_2.png) [@Maniack\_Crudelis](https://forum.yunohost.org/u/Maniack_Crudelis)
#### Post date: [January 5, 2018, 11:55pm UTC](https://forum.yunohost.org/t/probleme-dinstallation-applications/4058/7 "2018-01-05T23:55:57Z")

</div>

Ton mysql est cassé  
`0 processes alive`  
`error: 'Can’t connect to local MySQL server through socket ‘/var/run/mysqld/mysqld.sock’ (2 “No such file or directory”)'`

Tu peux faire un `sudo df -h` ?

---

<div class="post-metadata">

### Author: ![Didier58](https://forum.yunohost.org/letter_avatar_proxy/v4/letter/d/8797f3/32.png) [@Didier58](https://forum.yunohost.org/u/Didier58)
#### Post date: [January 6, 2018, 10:41am UTC](https://forum.yunohost.org/t/probleme-dinstallation-applications/4058/8 "2018-01-06T10:41:57Z")

</div>

pas de problème voilà le résultat:

root@didiercl:~# sudo df -h  
Filesystem Size Used Avail Use% Mounted on  
/dev/mmcblk0p1 30G 4.6G 24G 17% /  
udev 10M 0 10M 0% /dev  
tmpfs 100M 13M 88M 13% /run  
tmpfs 249M 4.0K 249M 1% /dev/shm  
tmpfs 5.0M 0 5.0M 0% /run/lock  
tmpfs 249M 0 249M 0% /sys/fs/cgroup  
tmpfs 50M 0 50M 0% /run/user/0

didier58

---

<div class="post-metadata">

### Author: ![Maniack\_Crudelis](https://forum.yunohost.org/user_avatar/forum.yunohost.org/maniack_crudelis/32/13_2.png) [@Maniack\_Crudelis](https://forum.yunohost.org/u/Maniack_Crudelis)
#### Post date: [January 8, 2018, 7:30pm UTC](https://forum.yunohost.org/t/probleme-dinstallation-applications/4058/9 "2018-01-08T19:30:04Z")

</div>

Je n’ai plus beaucoup d’autres idées…

Regarde du côté de `/var/log/mysql`, `/var/log/mysql.err` et `/var/log/mysql.log`  
Chez moi ils sont tous vide…

Tu peux également vérifier que ton fichier `/etc/hosts` contient bien une résolution de localhost sur 127.0.0.1

---

<div class="post-metadata">

### Author: ![Didier58](https://forum.yunohost.org/letter_avatar_proxy/v4/letter/d/8797f3/32.png) [@Didier58](https://forum.yunohost.org/u/Didier58)
#### Post date: [January 8, 2018, 8:11pm UTC](https://forum.yunohost.org/t/probleme-dinstallation-applications/4058/10 "2018-01-08T20:11:41Z")

</div>

Salut @Maniack_Crudelis,

chez moi ils sont vides également.

et le fichier hosts à bien une résolution de localhost sur 127.0.0.1

je te remercie pour ton aide et je vais voir ce que je vais faire peut être une réinstallation complète.

bonne soirée.

didier58

---

<div class="post-metadata">

### Author: ![gauthier67](https://forum.yunohost.org/letter_avatar_proxy/v4/letter/g/9fc29f/32.png) [@gauthier67](https://forum.yunohost.org/u/gauthier67)
#### Post date: [January 15, 2018, 11:38am UTC](https://forum.yunohost.org/t/probleme-dinstallation-applications/4058/11 "2018-01-15T11:38:46Z")

</div>

Bonjour,  
J’avais des problèmes pour l’installation de différentes applications avec des erreurs difficiles à comprendre. Il s’est avéré que c’était la RAM qui saturait pendant l’install. Il est possible de vérifier cela en se connectant en ssh pendant l’installation et en tapant la commande

> free -m

qui renvoie la mémoire totale, utilisée et libre.

J’ai réglé le problème en ajoutant un fichier de swap de 1Go sur ma SD. Il suffit de suivre ce tutoriel (lire le tuto jusqu’à la fin et voir directement la section “the faster way” si vous êtes convaincus du problème)

> **[How To Add Swap on Ubuntu 14.04 | DigitalOcean](https://www.digitalocean.com/community/tutorials/how-to-add-swap-on-ubuntu-14-04)**
>
> Swap space can be used as an “overflow” area for your system when you run out of RAM. The operating system can store data that would normally be kept in RAM…

que j’ai trouvé grâce à ce post

> [@\[Résolu\] Swap: manque sérieux de ram](https://forum.yunohost.org/t/resolu-swap-manque-serieux-de-ram/2694):
>
> Bonjour, J’aimerais me servir de mon raspberry ayant 512 MB de ram (ce qui est vraiment peu j’en conviens) en installant yunohost dessus. Je l’ai donc installé, mais toutes les applications que j’ai installé n’ont jamais fonctionné (wordpress et une autre appli officielle). Il restait presque rien niveau ram, j’ai regardé et il n’y avait pas de partition swap sur la carte sd du raspberry. J’ai donc effacé le contenu de la carte sd pour refaire l’installation. J’aimerais donc savoir comment je d…

J’espère que ça aidera et je me demande pourquoi l’image de yunohost n’inclut pas de zone de swap par défaut?

Gaut

---

<div class="post-metadata">

### Author: ![Aleks](https://forum.yunohost.org/user_avatar/forum.yunohost.org/aleks/32/1704_2.png) [@Aleks](https://forum.yunohost.org/u/Aleks)
#### Post date: [January 18, 2023, 8:16pm UTC](https://forum.yunohost.org/t/probleme-dinstallation-applications/4058/12 "2023-01-18T20:16:31Z")

</div>


