Problème de réception courriels

Bonjour,
Je ne peux plus recevoird’ email
Je peux en envoyer.
J’utilise rainloop en webmail.
benne sais pas si le problème vient de postfix… ou autre.

voici mon diagnostic
https://paste.yunohost.org/nuxetuwuha.json
https://paste.yunohost.org/bubomequfi.tex

var log mail

https://paste.yunohost.org/surucenemo

var log mail err

https://paste.yunohost.org/mumatiquja

Je ne sais pas trop ou il faut regarder (logs) pour savoir d’où ça vient…

J’ai eu un souci il n’y pas longtemps avec Ldap. J’avais réinitialisé le mdp admin via la ligne de commande, ça n’avait pas fonctionné…je n’avais plus accès a l’interface user et webadmin (les mdp étaient refusés) . Le problème a été réglé en refaisant la ligne de commande:

yunohost-reset-ldap-password

Je ne sais pas si il peut y avoir une relation
Merci pour votre aide

Hello,
Quand tu envoies un mail depuis l’extérieur vers ton serveur est ce que tu as une notification delivery qui pourrait donner des explications ?

Je vois des erreurs relay access denied également. Il doit sûrement y avoir un truc à creuser dans cette direction. As tu modifié ton fichier de conf postfix ? Pourrais tu nous montrer ta conf postfix et dovecot (en anonymisant les données sensibles bien sur)

.

je n’ai pas touché aux configs dovecot et postfix.
Par contre comme je l’ indicais, j’ai eu un plantage ldap après changement mdp admin…c’est ésolu mais le problème dovecot doit y être lié.
dovecot ne doit pas pouvoir se connecter au ldap correctement…
j’ai ça dans var log mail.rr
https://paste.yunohost.org/eyeripovab.scala

les emails ne sont pas délivrés. j’ai en retour sur l’email extérieur:

The mail system

xxxxxx@xxxxxxx.nohost.me: host xxxx.nohost.me[82.255.51.103] said:
454 4.7.1 xxxxxx@xxxxxx.nohost.me: Relay access denied (in reply
to RCPT TO command)

ma conf:
voici dovecot.config
https://paste.yunohost.org/rinitabufo.js

pour postfix main
https://paste.yunohost.org/uyeyiwuqoy.makefile

Ah effectivement ya clairement un souci avec ldap. Du coup est ce que ça veut dire que dovecot n’a pas pris en compte le changement de mot de passe suite à ton souci ? Bizarre je sais pas trop comment vérifier ça. Je vais regarder si je trouve quelque chose dans la doc

c’est sympa merci.
Je viens de faire un yunohost service status:

postfix:
  active: active
  active_at: 2019-07-21 12:04:56
  description: used to send and receive emails
  loaded: enabled
  service_file_path: /lib/systemd/system/postfix.service
  status: exited

donc effectivement il doit y avoir un problème postfix ou dovecot a cause du soucis ldap que j’ai eu.
peut être en réinstallant ces deux services…
merci du coup de main :smiley:

Mmmm peut être pas forcément réinstaller les services mais tu peux mettre une copie de ta conf quelque part et régénérer la conf pour dovecot et postfix (il me semble qu’il y a une commande yunohost spéciale pour régénérer la conf d’un service)

D’ailleurs en regardant ta conf, je sais pas si c’est le copier coller qui fait ça mais à la ligne 77 de ton main. Cf de postfix une ligne est erronée

virtual_alias_maps = ldap:/etc/postfix/ldap-aliases.cfvirtual_alias_domains =

Tout ça c’est une seule ligne alors que tu devrais avoir

virtual_alias_maps = ldap:/etc/postfix/ldap-aliases.cf
virtual_alias_domains =

Et ça concerne ldap. Coïncidence peut être mais à vérifier :slight_smile:

Effectivement c’est un problème de copier coller c’est bien séparé dans le fichier.
pour ce qui est de régénérer la conf … j’ai essayé mais rien ne change.

N.B. : c’est normal que postfix soit en status: exited

Comment est-ce que tu as procédé ?

j’ai fais:

yunohost tools regen-conf postfix

un dernier extrait de /var/log/mail.log
https://paste.yunohost.org/rudizofoku

Mais du coup quid de /etc/postfix/main.cf ? Tu as toujours cette ligne étrange dont parlais @Kuun-Lann ?

D’après son poste ç’etait une erreur de copier coller. Donc normalement sa conf est normale. Et d’ après son diagnostic tous les services (dont ldap) sont bien actifs

voici mon postconf -n si ça peut aider…
Je ne comprends pas pourquoi les mails sont shootes par postfix… Surement un problème d’authentification du user via Ldap …
Les lignes Relay access denied reject RCPT dans les logs m’ont fait penser a ca…

postconf -n  

https://paste.yunohost.org/unelaronow.makefile

en faisant /etc/fail2ban/filter.d# cat postfix-rbl.conf
j’ai remarqué que ca pouvait peut être être la source de mon problème avec postfix.

Fail2Ban filter for Postfix’s RBL based Blocked hosts

[INCLUDES]

Read common prefixes. If any customizations available – read them from

common.local

before = common.conf

[Definition]

_daemon = postfix(-\w+)?/smtpd

failregex = ^%(__prefix_line)sNOQUEUE: reject: RCPT from \S+[]: 454 4.7.1 Service unavailable; Client host [\S+] blocked using .* from=<\S*> to=<\S+> proto=ESMTP helo=<\S*>$

ignoreregex =

Author: Lee Clemens

l’erreur 454 4…7.1 est celle que j’ai dans les logs postfix…

mais voila je ne sais pas comment y remédier…

Tu peux faire un test rapide : tu désactives fail2ban, tu fais un test de mail et tu vois si t’as toujours le même message d’erreur, puis tu réactives ton fail2ban bien entendu :slight_smile:

je viens de le faire avec:
service fail2ban stop puis start et même reload… ça ne change rien. Postfix en rade . pas de réception des emails.
J’ai d’autres erreurs dans les logs:
/var/log/mail.err
https://paste.yunohost.org/ucojexuqoz
/var/log/mail.log
https://paste.yunohost.org/coceyojuli

C’est un peu trop pointu pour moi la…
Entre un problème Ldap , dovecot ou postfix, voir fail2ban je ne sais plus…
Je pense a tout remettre à plat…

bon ben je vois pas.
y a t il un script de re install pour postfix dovecot? ou un moyen de remettre le tout comme au début?
Je ne trouverais pas le problème je pense.
Et j’ai besoin d’acceder un certains comptes mails :disappointed_relieved:
merci pour votre aide

Bonsoir,

Attention : Je ne suis pas un expert postfix/dovecot, ce n’est qu’une suggestion.

Avant tout, réaliser une sauvegarde et l’enregistrer sur un autre support que le serveur : https://yunohost.org/#/backup_fr.
Ensuite, peut-être tenter de forcer la régénération des configurations mail avec quelque chose du genre :

yunohost tools regen-conf postfix --force
yunohost tools regen-conf dovecot --force

ppr

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.