Problème de postinstallation sur un Raspberry pi

,

J’étais passé à côté de ce détail, merci.

Bonjour,

j’ai le même problème (nginxErreur : impossible de modifier le domaine principal).
Installation sur Raspbian toute fraiche. Pas de problème concenant eth0.
Connexion impossible.

Merci d’avance pour votre aide

Bonjour,
Content de voir que je ne suis pas le seul :smile:

j’ai aussi le même problème à savoir que mon interface est bien eth0 donc théoriquement pas besoin de le modifier, et elle est configurée en static. Voici un petit aperçu de mon fichier interfaces pour la partie eth0.

auto eth0

iface eth0 inet static
address 192.168.0.6
netmask 255.255.255.0
gateway 192.168.0.254

La commande iplink me retourne bien comme nom eth0. Donc je ne pense pas que ça vienne de là.

Bonjour !

Il y a effectivement un problème avec la configuration nginx par défaut quand l’IPv6 n’est pas supporté, ça doit sûrement être votre cas… Je viens de mettre à jour le paquet yunohost-config-nginx qui devrait résoudre ce problème. Essayez de le mettre à jour et de relancer le service nginx : sudo service nginx restart !
Si ça ne fonctionne toujours pas, il va falloir inspecter les journaux et la configuration… N’hésitez pas à passer sur le salon pour ça, s’il y a qqun pour vous aider ! :slight_smile:

Enfin, je remets ici la démarche à suivre pour terminer manuellement la post-installation quand celle-ci a échoué (vu qu’il est actuellement impossible de la relancer…), à faire une fois que nginx démarre :

  1. Tell that YunoHost is installed in order to be able to execute commands with the moulinette: sudo touch /etc/yunohost/installed
  2. If you’re using DynDNS - i.e. a subdomain offered by YunoHost - subscribe to it: sudo yunohost dyndns subscribe -d yourdomain.nohost.me (replace yourdomain.nohost.me with the domain that you entered just before)
  3. Generate SSOwat configuration: sudo yunohost app ssowatconf
  4. Set the administration password: sudo yunohost tools adminpw (the current one is yunohost)
  5. If you’re using uPnP - see https://doc.yunohost.org/#/isp_box_config - enable it: sudo yunohost firewall upnp enable
  6. Reload the firewall: sudo yunohost firewall reload
  7. Done!

Désolé pour ce désagrément, et en espérant que ça fonctionne pour vous !

Super ! merci beaucoup Yunohost a bien démarré.

Merci pour votre réponse. ça fonctionne !
j’ai encore un souci sur mon navigateur (firefox) Echec de connexion sécurisé.
Avec un autre navigateur (qupzilla) erreur ssl mais j’arrive à continuer.

Encore merci.

Ah je vous en prie, content que ça ait fonctionné !

Je te propose de venir en parler sur le salon ou d’ouvrir un nouveau sujet, merci !

Bonjour à tous !

Je suis en train de mettre en place YunoHost sur mon Pi, et je rencontre (je pense) exactement le même problème. Malheureusement pour moi, le paquet yunohost-config-nginx est déjà la plus récente version disponible. J’ai donc ouvert les journaux nginx comme conseillé, et j’y ai trouvé que :

2014/11/11 20:05:02 [info] 27694#0: [lua] init.lua:32: SSOwat ready
2014/11/11 20:05:02 [emerg] 27694#0: socket() [::]:80 failed (97: Address family not supported by protocol)

Alors je ne m’y connais pas trop, mais ça ressemble au problème IPv6 relevé par Jerome. Je suppose que je dois aller faire la modification à la mano, mais je ne sais pas du tout quoi faire, ni où. Je suis ouvert à toute proposition pour finir l’installation les mains dans le cambouis !

Merci d’avance ! :smile:

Cyrille,
Essaie déjà d’enlever l’IPv6 dans ton réseau local si tu ne l’utilises pas.

Open /etc/sysctl.conf and add following lines.
net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1

Then run sudo sysctl -p

(désolé pour le franglais: https://rtcamp.com/tutorials/linux/disable-ipv6/)

Ensuite, tu peux essayer de redémarrer manuellement le service nginx pour voir. Qui ca ne marche toujours pas, t’y peux vérifier qu’il n’existe pas d’adresse ipv6 dans /etc/hosts ( notamment le ::1)

Hello MoutonJR, merci pour ton aide !

Alors ta manip’ ne fonctionne pas, lorsque que j’exécute la dernière commande, il me renvoi une erreur :

$ sudo sysctl -p
kernel.printk = 3 4 1 3
sysctl: cannot stat /proc/sys/net/ipv6/conf/all/disable_ipv6: Aucun fichier ou dossier de ce type
sysctl: cannot stat /proc/sys/net/ipv6/conf/default/disable_ipv6: Aucun fichier ou dossier de ce type
sysctl: cannot stat /proc/sys/net/ipv6/conf/lo/disable_ipv6: Aucun fichier ou dossier de ce type
vm.swappiness = 1
vm.min_free_kbytes = 8192

En fait, le dossier /proc/sys/net/ipv6/ n’existe pas sur ma machine…

J’ai regardé un peu partout à la recherche de traces d’IPv6, et j’en a trouvé dans /etc/hosts, je les ai retirées. Je n’ai rien dans la configuration de nginx, et quand je tente de le redémarrer, il ne revoit rien, mais écrit toujours la même chose dans son journal, à savoir :

[info] 31983#0: [lua] init.lua:32: SSOwat ready
[emerg] 31983#0: socket() [::]:80 failed (97: Address family not supported by protocol)

Comme je ne sais pas d’où ça peut venir, je fait un très sale grep un peu partout à la recherche de “[::]:80”. En attendant que la commande se termine xD, je reste ouvert à toute proposition, même les indécentes !

Merci d’avance :blush:

@Cyrille Il semble que l’IPv6 n’est pas activée sur ta version de Raspbian.

Merci d’utiliser l’image officielle ou une version avec IPv6 activée pour pouvoir utiliser correctement YunoHost (et Internet en général :slight_smile: )

Modifier le fichier /etc/modules pour ajouter une ligne contenant
ipv6
redemarrer ou charger le module si vous savez faire
et relancer nginx
Par default sur raspbian ce modules n’est pas par défault.

Bonsoir à tous, et merci pour votre aide !

Alors bilan de l’aventure :

  • @kload, c’est exact : pas d’ipv6, bien que j’utilisai la version officielle de Raspbian :confused: J’ai tout de même tenté d’utiliser celle de linuxsystems.it, mais ça a capoté au moment où je n’avais plus de place sur ma partition -_-’ . J’ai un peu essayé de l’étendre, mais je n’ai pas encore compris comme ça fonctionne tout ça… Bref.
  • J’ai fini par essayer la méthode de @Jean31 qui a fonctionné sans problèmes, et j’ai pu terminer l’installation à la main ! :smile:

Tout semble fonctionner maintenant, encore merci pour votre aide, et pour ce beau travail réalisé sur YunoHost !

Salut,
J’ai le même problème que Cyrille, mais la solution de Jean31 n’a rien donné :confused:
J’ai rajouté la ligne “ipv6” dans etc/modules et j’ai redémarré mon olimex (A13).
Je relance la post-install avec yunohost tools postinstall et ça pète à la config d’nginx:

[....] Restarting nginx: nginxError: Unable to change main domain

Note que j’ai renseigné le nom de domaine en truc.nohost.me.
Les logs d’erreur d’nginx disent 2 choses:

[error] 17939#0: failed to run init_by_lua*: cannot open /usr/s

hare/ssowat/init.lua: No such file or directory

alors qu’il existe, puis on voit que ssowat est ready, puis

2015/04/29 17:02:07 [emerg] 6630#0: socket() [::]:80 failed (97: Address family not supported by protocol)

D’après un formu nginx, il faut le configurer pour qu’il support l’ipv6, ce qu’ils montrent avec une recompilation (flag --with-ipv6). Sinon dans /etc/nginx/site-available/default la ligne

listen ::[:80] ipv6only=on default_server

est là.

Je n’ai pas d’autre idée. Qui m’aide ?!

ps: un copain me dit qu’avec un adaptateur internet usb il a déjà eu des pb… y a-t-il un lien ?

J’ai trouvé cette discussion: Raspberrypi - postinstall - unable to change main domain pour résoudre l’erreur “unable to change domain name”.

Donc je tente:

root@yunohost:~> yunohost dyndns subscribe matutine.nohost.me
usage: yunohost [-h] [-v]
                
                {domain,monitor,service,firewall,tools,app,hook,dyndns,backup,user}
                ...
yunohost: error: unrecognized arguments: matutine.nohost.me

I re-installed yunohost and it worked better. It failed first because my password was too short (the screen just said “postinstall failed, retry ?”). But after yunohost tools postinstall I have unavailable dyndns subdomain, which is a known pb if you use a subdomain of nohost.me: Nohost domain recovery - Suppression de domaine en nohost.me et noho.st We then must ask the administrators to delete the subdomain.

Hello, dear community manager. Could you wipe my first try “echange66.noho.st”, which seems not to work. Thanks for your time and your work.
Cheers,
Raphael

Salut,
J’ai le même problème que Cyrille, mais la solution de Jean31 n’a rien donné :confused:
J’ai rajouté la ligne “ipv6” dans etc/modules et j’ai redémarré mon Graperain (4418).
Je relance la post-install avec yunohost tools postinstall et ça pète à la config d’nginx:

[…] Restarting nginx: nginxError: Unable to change main domain
Note que j’ai renseigné le nom de domaine en truc.nohost.me.

Salut!

J’ai eu le meme probleme avec une migration qui s’est mal passé.

Probleme d’IPv6?

Probablement

Solution (pour moi au moins):

Upgrader le kernel.

Telecharges la nouvelle image yunohost et mount la
sudo mount -o loop,offset=4194304 2021-02-21-yunohost-lite-qemu.img /mnt

l’offset correxpond a la partition boot.

Maintenant sur la carte sd :
Copies kernel.img quelquepart sur ton ordi au cas ou.

remplace le kernel.img de ta carteSD par celui de l’image yunohost4***.
???
Profit!

Ma theorie:

La migration fait un upgrade du firmware Rpi. Vu que toutes les platformes sont supportées par la meme image, les fichiers pour le pi4 prennent trop de place pour la parition boot tel qu’elle a été allouée pour les image ynh3***. Et donc il y a des fails.

Quelqu’un peut confirmer?