Problème avec Metronome (XMPP)... peut-être ^^

Configuration de mon YunoHost
Matériel: Raspberry Pi 3
Accès Internet: ethernet à la maison
YunoHost version:
yunohost 3.3.4 (stable)
yunohost-admin 3.3.1 (stable)
moulinette 3.3.1 (stable)
ssowat 3.3.2 (stable)

En mettant a jour Yunohost j’ai eu ces messages:

J’ai choisi “Y” comme choix mais depuis lors mon compte XMPP ne fonctionne plus avec l’app conversation sur mon smartphone. J’ai le message suivant: “Le serveur n’est pas responsable du domaine”.

Je ne sais pas si c’est lié a mon choix lors de la mise a jour ou si ca n’a rien a voir.
Et je ne sais pas vraiment comment régler le problème.
Je viens donc vous demander un peu d’aide ^^

Diagnostic:
{
“host”: “Debian 9.6”,
“kernel”: “4.14.79-v7+”,
“packages”: {
“yunohost”: {
“repo”: “stable”,
“version”: “3.3.4”
},
“yunohost-admin”: {
“repo”: “stable”,
“version”: “3.3.1”
},
“moulinette”: {
“repo”: “stable”,
“version”: “3.3.1”
},
“ssowat”: {
“repo”: “stable”,
“version”: “3.3.2”
}
},
“backports”: [],
“system”: {
“disks”: {
“sda2”: “Mounted on /, 1.8TiB (1.7TiB free)”,
“mmcblk0p1”: “Mounted on /boot, 42.5MiB (20.5MiB free)”
},
“memory”: {
“ram”: “927.2MiB (376.3MiB free)”,
“swap”: “4.0GiB (3.4GiB free)”
}
},
“nginx”: [
“nginx: the configuration file /etc/nginx/nginx.conf syntax is ok”,
“nginx: configuration file /etc/nginx/nginx.conf test is successful”
],
“services”: {
“glances”: “running (enabled)”,
“nslcd”: “running (enabled)”,
“pihole-FTL”: “exited (enabled)”,
“metronome”: “running (enabled)”,
“ttrss”: “running (enabled)”,
“postfix”: “exited (enabled)”,
“rspamd”: “running (enabled)”,
“transmission-daemon”: “running (enabled)”,
“yunohost-firewall”: “exited (enabled)”,
“nginx”: “running (enabled)”,
“php7.0-fpm”: “running (enabled)”,
“dnsmasq”: “running (enabled)”,
“fail2ban”: “running (enabled)”,
“yunohost-api”: “running (enabled)”,
“mysql”: “running (enabled)”,
“avahi-daemon”: “running (enabled)”,
“dovecot”: “running (enabled)”,
“redis-server”: “running (enabled)”,
“slapd”: “running (enabled)”,
“ssh”: “running (enabled)”
},
“applications”: {
“wallabag2”: “Wallabag”,
“transmission”: “Transmission”,
“funkwhale”: “Funkwhale”,
“ttrss”: “Tiny Tiny RSS”,
“rainloop”: “Rainloop”,
“pihole”: “Pi-hole”,
“nextcloud”: “Nextcloud”
},
“security”: {
“CVE-2017-5754”: {
“name”: “meltdown”,
“vulnerable”: false
}
}
}

Cette commande résoudra le probleme :

yunohost service regen-conf metronome --force
1 Like

Je viens de faire cette commande ; la configuration a été effectuée avec force, mais il y a un souci qui s’est affiché et on m’a demandé de vérifier avec cette commande :

systemctl status metronome.service

Voici ce qu’elle me renvoie :

● metronome.service - LSB: Metronome XMPP Server
Loaded: loaded (/etc/init.d/metronome; generated; vendor preset: enabled)
Active: failed (Result: exit-code) since Sat 2019-01-19 20:10:22 CET; 1min 7s ago
Docs: man:systemd-sysv-generator(8)
Process: 13280 ExecStop=/etc/init.d/metronome stop (code=exited, status=0/SUCCESS)
Process: 23396 ExecReload=/etc/init.d/metronome reload (code=exited, status=0/SUCCESS)
Process: 13286 ExecStart=/etc/init.d/metronome start (code=exited, status=1/FAILURE)

Arf ok

Est-ce que tu peux faire :

systemctl restart metronome
tail /var/log/metronome/metronome.{err,log}

Job for metronome.service failed because the control process exited with error code.
See “systemctl status metronome.service” and “journalctl -xe” for details.

tail /var/log/metronome/metronome.{err,log}

==> /var/log/metronome/metronome.err <==

Jan 19 06:25:02 certmanager error SSL/TLS: Failed to load ‘/etc/metronome/certs/localhost.key’: Check that the path is correct, and the file exists. (for conference.example.com)

Jan 19 06:25:02 certmanager error SSL/TLS: Failed to load ‘/etc/metronome/certs/localhost.key’: Check that the path is correct, and the file exists. (for conference.example.com)

Jan 19 06:25:02 certmanager error SSL/TLS: Failed to load ‘/etc/metronome/certs/localhost.key’: Check that the path is correct, and the file exists. (for localhost)

Jan 19 06:25:02 certmanager error SSL/TLS: Failed to load ‘/etc/metronome/certs/localhost.key’: Check that the path is correct, and the file exists. (for localhost)

==> /var/log/metronome/metronome.log <==

Jan 19 18:25:55 s2sin564481432fe0 info incoming s2s stream news.movim.eu->***.eu closed: This host does not serve ***.eu

Jan 19 18:33:18 s2sin564481246b60 info incoming s2s stream news.movim.eu->***.eu closed: This host does not serve ***.eu

Jan 19 18:40:46 s2sin564481284100 info incoming s2s stream news.movim.eu->***.eu closed: This host does not serve ***.eu

Jan 19 20:10:22 mod_posix warn Received SIGTERM

Jan 19 20:10:22 general info Shutting down: Received SIGTERM

Jan 19 20:10:22 general info Shutting down…

Jan 19 20:10:22 general info Shutdown status: Cleaning up

Jan 19 20:10:22 general info Shutdown status: Closing all active sessions

Jan 19 20:10:22 general info Shutdown status: Closing all server connections

Jan 19 20:10:22 general info Shutdown complete

Marf … et si tu fais

metronomectl start

ça ne raconte pas plus de choses j’imagine ?


Metronome was unable to find the configuration file.
We looked for: /etc/metronome/metronome.cfg.lua
A sample config file is included in the Metronome download called metronome.cfg.lua.dist
Copy or rename it to metronome.cfg.lua and edit as necessary.


Uh mais du coup ce fichier n’existe vraiment pas ?

yunohost service regen-conf metronome --force ne le génère pas ? o.O

Il y a toujours eu un souci avec Metronome depuis que j’ai fait l’installation de Yunohost… MOVIM, par exemple, ne parvient pas à faire de connexion persistente bien que tout soit configuré correctement.

Concernant la commande que tu viens de me demander d’exécuter, elle n’affiche rien. Quand j’essaie de démarrer, cela affiche :


Metronome was unable to find the configuration file.
We looked for: /etc/metronome/metronome.cfg.lua
A sample config file is included in the Metronome download called metronome.cfg.lua.dist
Copy or rename it to metronome.cfg.lua and edit as necessary.


Beh c’est chelou, si y’a bien un truc que c’est censé faire, c’est de générer ce fichier :confused:

Si tu rajoutes --debug à la fin, ça raconte quoi ?

Lorsque je mets sudo devant

metronomectl start


A problem occured while reading the config file /etc/metronome/metronome.cfg.lua
Error: Host “upload.***.eu” clashes with previously defined http_upload Component “upload.***.eu”, for services use a sub-domain like conference.upload.***.eu


Apparemment, il renvoie à un nom de domaine où Girafeau est installé… Bizarre !

Donc maintenant il y a un fichier /etc/metronome/metronome.cfg.lua … ?

Oui, j’ai vérifié avec NANO. Mais Movim ne veut même plus que je me logge.

Bon mais attends en fait là … pourquoi c’est @beer2beer qui a posté le message initialement et c’est toi qui réponds en fait … -_-

1 Like

Voilà ce que Movim affiche constamment : il ne se connecte pas.

grafik

Laissons Movim de côté pour le moment … Si metronome ne démarre pas il y a peu de chance que Movim fonctionne …

Merci beaucoup @Aleks ça à parfaitement fonctionné chez moi, ça a réglé mon problème.

1 Like

Je dois ouvrir un autre post ?

Je dois ouvrir un autre post ?