Problem with PHP applications after upgrade to Yunohost 2.2


Tonight, I run an upgrade of my distribution as I run usualy.
See only during the process, that Yunohost was upgrading to 2.2, that was a good thing for me, thinking maybe Jessie support is near, so I will have to upgrade to Jessie soon.

But as soon I have finish, I get issues with nginx starting. New file and modification make 2 differents files have a default parameter in my main domain.file.conf and the yunohost_admin.conf
Ok, I remove one and it’s starting. But weird thing is, all reverse proxied applications are working fines (transmission, sickrage, strut, gateone) but none of the php applications.
So it’s not from missing parameter of domain.d directory to include.

I check, no modification to php conf files, the sockets are here for each pool.

When I check my logs, in access.log for my domain, I see all my attempt (for exemple with owncloud)
And it seems for each line, I get a line in error.log complaining about missing directory /usr/share/nginx/html/blog
/blog is my default application yes, but of course it’s in /var/www. But no reason it’s going to look in usr share.
I try to create a symlink in case, but no still the error.

Have you an idea of what have been introduce in the conf in 2.2 ? I cannot find and .dpkg-distrib file, there was no question about overwriting, but it definitly done some.

To add details : if I’m not logged under SSO, when I request the gateone url for exemple, I have the redirection to SSO and then my app. But for owncloud for exemple, I don’t get the SSO authentication page. The page receive is just blank and code empty. Authenticated or not.

I have the same problem , half of the application are not working.
I can not login through ssh

any solution ?

I still not find the solution.

But it’s not PHP : I have another domain configured in Nginx (but not in Yunohost, as it’s a simple website) and it’s working fine. So nginx is well going to this vhost and serve it in PHP.

But when it’s Yunohost configured domains (so SSOWAT also) it’s working fine with any reverse proxied application (gateone, transmission …)

But for PHP applications, white page, auth or not. Nothing in logs.
I look for the postinst script in .deb, it’s purely overwriting files, no backup. So impossible to reverte the configuration …
Deb 2.0 are not on the depot anymore, that’s so impossible to find the old template and I’m not able to read what can be missing …

@kload any help ?

Hi all,

For blank page, you are probably looking for that fix in nginx conf file:

Thanks a lot, that did it !!!

I can not login to ssh

Thanks @tostaki
I applied the same fix to my packages:

You have to upgrade PHP applications one by one.

E.g.: sudo yunohost app upgrade roundcube

Hi all !

It seems that I have the same problem since I upgraded my yunohost server. Some of my applications are not running anymore. For example, I have a blank page with Dokuwiki, Roundcube, Tiny Tiny RSS, … But as it was said above, applications like Transmission or CouchPotato are still running fine.

As said by @kload, I tried to upgrade PHP applications one by one, but I get this error :

root@pomme:/# yunohost app upgrade dokuwiki
Traceback (most recent call last):
  File "/usr/bin/yunohost", line 160, in <module>
    print_json=PRINT_JSON, use_cache=USE_CACHE)
  File "/usr/lib/python2.7/dist-packages/moulinette/", line 117, in cli, print_json)
  File "/usr/lib/python2.7/dist-packages/moulinette/interfaces/", line 197, in run
    ret = self.actionsmap.process(args, timeout=5)
  File "/usr/lib/python2.7/dist-packages/moulinette/", line 458, in process
    return func(**arguments)
  File "/usr/lib/moulinette/yunohost/", line 280, in app_upgrade
  File "/usr/lib/moulinette/yunohost/", line 155, in app_list
    with open( apps_setting_path + app +'/manifest.json') as json_manifest:
IOError: [Errno 2] No such file or directory: '/etc/yunohost/apps/couchpotato/manifest.json'

I saw another problem, I don’t know if it is linked. In the administration interface, I can’t go to the Applcations menu anymore. I have this error :

Error: 500 Internal Server Error
Sorry, the requested URL '' caused an error:
            Internal Server Error

If someone has any idea… Thanks !

You may have installed CouchPotato, which obviously has some issues.

If you don’t need it anymore, just remove the application by running rm -r /etc/yunohost/couchpotato