Problem using clients for xmpp and mail

metronome
raspberrypi
postfix

#1

My YunoHost configuration

Hardware: Raspberry Pi
Internet access: ethernet at home
YunoHost version:
yunohost : 3.1.0
yunohost-admin : 3.1.0
moulinette : 3.1.0
ssowat : 3.1.0

Description of my problem

I’m trying to use a client for my mail (tried both evolution and thunderbird), but cannot connect my account. But I installed RoundCube on my server and it works perfectly.

Tried the same with XMPP (tried both Conversation on my phone and Gajim on my PC) and I cannot connect either. I installed Jappix on my server, but it does not work either (Error : Service unavailable)

I have checked my port forwarding on my router and have my two tcp redirection on both port 5222 and 5269 for XMPP, and 25 and 587 for mail.

Only strange thing I found myself is that both metronome and postfix say “exited” instead of “running” like most other services on the diagnosis of my server. But their status on the services page still says “active”.

Any idea ?
Thanks a lot for your help !


#2

Hi @PP44

If you are comfortable with the command line, can you check on the system if the ports are listening (here is an example on my server) :

root@yunohost:~# netstat -apn  | grep 5222
tcp        0      0 0.0.0.0:5222            0.0.0.0:*               LISTEN      21788/lua5.1        
tcp        0      0 192.168.122.62:5222     37.173.156.254:8504     ESTABLISHED 21788/lua5.1        
tcp6       0      0 :::5222                 :::*                    LISTEN      21788/lua5.1        
root@yunohost:~# netstat -apn  | grep 587
tcp        0      0 0.0.0.0:587             0.0.0.0:*               LISTEN      21749/master        
tcp6       0      0 :::587                  :::*                    LISTEN      21749/master   

Otherwise do you have logs for the two services ? Maybe systemctl status metronome ? or take a look at /var/log/metronome/metronome.log


#3

Thanks for the answer !

I checked and both port are listenning :

tcp        0      0 0.0.0.0:5222            0.0.0.0:*               LISTEN      1074/lua5.1         
tcp6       0      0 :::5222                 :::*                    LISTEN      1074/lua5.1         
tcp        0      0 0.0.0.0:587             0.0.0.0:*               LISTEN      1229/master
tcp6       0      0 :::587                  :::*                    LISTEN      1229/master 

Here the part of the diagnosis I was talking about before :

"services": {
    "glances": "running (enabled)",
    "nslcd": "running (enabled)",
    "metronome": "exited (enabled)",
    "slapd": "running (enabled)",
    "ttrss": "running (enabled)",
    "postfix": "exited (enabled)",
    "rspamd": "running (enabled)",
    "transmission-daemon": "running (enabled)",
    "yunohost-firewall": "exited (enabled)",
    "nginx": "running (enabled)",
    "php7.0-fpm": "running (enabled)",
    "dnsmasq": "running (enabled)",
    "ssh": "running (enabled)",
    "yunohost-api": "running (enabled)",
    "mysql": "running (enabled)",
    "avahi-daemon": "running (enabled)",
    "dovecot": "running (enabled)",
    "redis-server": "running (enabled)",
    "uwsgi": "running (enabled)",
    "fail2ban": "running (enabled)"

Here are the logs :
metronome.log : https://paste.yunohost.org/ujevozexug
postfix.log : https://paste.yunohost.org/wunevabeve

Thank you again for your help !