Problem accessing GateOne and Etherpad Lite: 502 Bad Gateway


I installed Yunohost on a Raspberry Pi recently and I have an issue accessing the GateOne application.
When I connect to, I got a page: 502 Bad Gateway - ngx_openresty/

Any idea where to look at to solve that issue? I don’t know which logs I should look at and where they are located.

I have the same issue with Etherpad Lite, don’t know if it’s the same root cause…

Hello Snorky,
Go to the admin interface and start the service for GateOne.
I have the same problem: it does not start on reboot.

Edit: I’ve seen your post below. Sorry, I can’t help you on this error. I let the answer to better experts.

Hello @xof,

Indeed it was not started. I started it, but it stopped immediately.
In the logs I see:

[W 150222 23:28:53 app_terminal:2711] dtach command not found. dtach support has been disabled.
[I 150222 23:28:54 server:4026] Imported applications: Terminal
[I 150222 23:28:54 server:4168] Version: 1.2.0 (20140516085214)
[I 150222 23:28:54 server:4169] Tornado version 4.1
[I 150222 23:28:54 server:4189] Connections to this server will be allowed from the following origins: ‘localhost’
[I 150222 23:28:54 server:3707] No authentication method configured. All users will be ANONYMOUS
[I 150222 23:28:54 server:3834] Loaded global plugins: help.js
[I 150222 23:28:54 server:4301] Listening on https://*:443/
[E 150222 23:28:54 server:4330] Could not listen on (address:port is already in use by another application).
[E 150222 23:28:54 server:4344] Exception was: (98, ‘Address already in use’)
[I 150222 23:28:54 server:4351] Clearing cache_dir: /tmp/gateone_cache
[I 150222 23:28:54 server:4354] pid file removed.

Any idea what could use port 443?

Each time I update GateOne, this problem appears.
The solution I’ve found is to remove this app and reinstall it.

Hi @tilux,

Uninstalling/reinstalling did the trick. It works now for GateOne.
On the other hand Etherpad Lite still doesn’t work. So I’m half way here.

Thank you!