PostInstall script hangs at Success! YunoHost has been configured

I’ve installed 3 different times now testing out YunoHost to see if I can use it to replace my OS X Server, and it always seems to hang on the YunoHost has been configured step in the post install script. Anyone have an idea why that might be, or where I should look to see what is supposed to be happening next?

I’ve been installing on Proxmox both as a VM and a container and it doesn’t seem to matter which way I install it.

Can you elaborate on how which instructions you followed to install ?

What happens exactly after it “hangs” ? Have you tried hitting Enter a few times ? Have you tried to Ctrl+C to cancel ? Or accessing the webadmin ?

I installed both from the iso and manually after installing plain debian from iso.

After it hangs I am not able to do anything with the script. Hitting enter did nothing, cntrl-c did nothing, I can log in to the web interface and everything seems to be fine. Rebooting the vm brings everything back up and there are no signs of an issue so far.

I just don’t know what the issue was, and it makes me think there is something that didn’t get done that may come back to bite later.

I am running the system behind my router and no ports are forwarded yet. I still have my other server running and handling mail and such, so maybe there is something the install expects from the network it’s not getting?

Also, I am not sure about the domain to put in during install. It seems like the install script wants the root domain. When I log in via SSH the prompt shows "". I’m not used to seeing that. Usually my servers claim to be either the server name or the fully qualified server name. It seems odd to me. Did I enter the wrong thing? Should I have put something like “”?


Well it’s a bit unexpected that the terminal gets completely blocked at the end of the postinstall … but that might be just some silly / not-important technical reason behind that :confused: (or maybe there’s a bigger problem, idk). Looking into the code, we just have nothing after telling yunohost got configured. If you really want to dig into it, you could re-run the postinstall with --debug and see if the debugs tells something more at the end.

Hmmmm I dunno, it should be fine to run the postinstall with no port forwarded yet, that’s okay. And that seems unrelated to the issue. I’m thinking more about stuff like “some service got restarted which messed up the console you were in somehow” (which isnt supposed to happen but maybe on some particular setup it does…) Or maybe that could be our bootprompt system ?

From what I know, the prompt (PS1) should show “root@domain” if your domain is domain.tld. (For instance, with domain yolo.test you end up with root@yolo). So, not sure what you mean by “the server name”. Anyway, this is managed via hostnamectl to which we feed the fully-qualified domain name and we have little control of what it does with it I think (or never really digged).

In any case, the domain you should enter at the postinstall is the domain you intend to use in everyday’s life to access your server … i.e. if you want yours users to use, put

1 Like

So after resetting and running the postinstall --debug, everything completed fine. The only thing that the debug really logs after the last SUCCESS line is “lock has been released”. Maybe there is something that prevents the lock from being released and it never finishes when I run it immediately after the installation. Not sure, but it doesn’t appear to be any problem with the config, so I am going to ignore that issue for now.

From what I can tell everything seems to be working as intended. It’s just odd to me that hostname and hostname -f both return just the main domain.

On my proxmox server for example, the server name is tycho so hostname returns tycho and hostname -f returns I guess it’s not a problem the way it works now, it just doesn’t fit with the convention I’ve always used. I would never have a server called the domain name. Maybe that’s because I frequently have more than one server handling services for the domain so it doesn’t fit to have a single server claim to be the domain.

Will it cause any issues if I change the server name after install. I presume I have to use the main domain during install for the email config to be set up properly?