Plus d'acces sur mon serveur en http

Matériel: ordinateur
Version de YunoHost: 11
J’ai accès à mon serveur : En SSH

Description du problème

Je viens de redemarrer mon serveur apres 13 jours sans probleme suite a mon changement de processeur.
J’ai un acces en SSH, mais je n’ai plus acces depuis http.
Ni via l’adresse IP direct en local.
Apres verification

ip a annonce la meme ip local que d’habitude.

Une idée?

Merci! :slight_smile:

[edit : j’ai redemarrer NGINX manuellement c’etait tout]
MAIS ! d’apres vous pourquoi nginx + les services PHP + docovt + postoffice n’on pas démarré normalement?
Comment verifier et resoudre ces petits incidents?

ps : maintenant 8Go de RAM physique + 4 de swap
et un intel 4 coeurs :slight_smile:

Il n’y a pas de détails précis tel que le message d’erreur exact que tu vois quand tu essayes de te connecter en HTTP, ni le résultat du diagnostique (ni la version exacte de YunoHost d’ailleurs, des versions “11” il doit y’en avoir eu une 50aine maintenant)

Donc on ne peut pas t’aider

En effet il s’agit de la version 11.1.17.

Message d’erreur stipulant que l’adresse web est inaccessible.

J’avais d’abord tester

ping orange.fr avec succes depuis le serveur.

Puis j’ai redemarrer nginx manuellement et j’ai eu acces a l’interface web.

Je me suis apercu ensuite que tout les services :slight_smile:

Php + postfix etait inactif.

J’ai redémarrer un a un les services manuellement pour avoir un serveur de nouveau opérationnel.

j’ai rebooter une seconde fois quelques temps plus tard et j’ai eu de nouveau le meme probleme.

voici les dernieres lignes de Nginx du journal d’aujourd’hui si cela peut aider:

mai 13 15:34:48 systemd[1]: Starting A high performance web server and a reverse proxy server...
mai 13 15:36:18 systemd[1]: nginx.service: start-pre operation timed out. Terminating.
mai 13 15:36:18 systemd[1]: nginx.service: Control process exited, code=killed, status=15/TERM
mai 13 15:36:18 systemd[1]: nginx.service: Failed with result 'timeout'.
mai 13 15:36:18 systemd[1]: Failed to start A high performance web server and a reverse proxy server.
mai 13 15:50:45 systemd[1]: Starting A high performance web server and a reverse proxy server...
mai 13 15:50:47 systemd[1]: Started A high performance web server and a reverse proxy server.
mai 13 17:54:10 systemd[1]: Stopping A high performance web server and a reverse proxy server...
mai 13 17:54:15 systemd[1]: nginx.service: Stopping timed out. Terminating.
mai 13 17:54:20 systemd[1]: nginx.service: State 'stop-sigterm' timed out. Killing.
mai 13 17:54:20 systemd[1]: nginx.service: Killing process 8241 (nginx) with signal SIGKILL.
mai 13 17:54:20 systemd[1]: nginx.service: Killing process 8242 (nginx) with signal SIGKILL.
mai 13 17:54:20 systemd[1]: nginx.service: Main process exited, code=killed, status=9/KILL
mai 13 17:54:20 systemd[1]: nginx.service: Killing process 8242 (nginx) with signal SIGKILL.
mai 13 17:54:20 systemd[1]: nginx.service: Failed with result 'timeout'.
mai 13 17:54:20 systemd[1]: nginx.service: Unit process 8242 (nginx) remains running after unit stopped.
mai 13 17:54:20 systemd[1]: Stopped A high performance web server and a reverse proxy server.
mai 13 17:54:20 systemd[1]: nginx.service: Consumed 16.654s CPU time.
-- Boot 44f4737d9f0f43b8ad78bf7958f0c4dd --
mai 13 18:00:08 systemd[1]: Starting A high performance web server and a reverse proxy server...
mai 13 18:01:38 systemd[1]: nginx.service: start-pre operation timed out. Terminating.
mai 13 18:01:40 systemd[1]: nginx.service: Control process exited, code=killed, status=15/TERM
mai 13 18:01:40 systemd[1]: nginx.service: Failed with result 'timeout'.
mai 13 18:01:40 systemd[1]: Failed to start A high performance web server and a reverse proxy server.
mai 13 18:02:51 systemd[1]: Starting A high performance web server and a reverse proxy server...
mai 13 18:03:32 systemd[1]: Started A high performance web server and a reverse proxy server.

Merci par avance de votre aide.

Désolé de te l’annoncer, tu as (encore) très probablement des problèmes de mémoire sur ton serveur.

Ca serais pas de bol… j’ai changer toutes les barettes de memoire (elles sont neuves)
mise a part la carte mere du coup…
J’ai deux questions :slight_smile:

  • 1 est ce possible de m’aider a faire un script pour mettre en demarrage auto les services nginx et php ? (j’ai deja créer le script mais je n’arrive pas a le faire lancer automatiquement) mais fonctionne en manuel.

  • 2 Si je change de pc est ce que je peux brancher le disque dur qui a yunhost sur un autre pc directement? ou cela ne marchera pas? (je me doute sur les autres disques durs, il faudra changer les parametres par rapport au UUID)

merci pour tes réponses :slight_smile:

Jonathan

Dans ce cas est-ce que tu peux nous copier-coller la ligne du diagnostique de YunoHost qui raconte quel pourcentage de RAM est utilisé / libre

Ils sont déjà en démarrage automatique, le problème est qu’ils se font tuer au démarrage, sans doute à cause d’un problème de ressource

et voici!

Le système dispose encore de 4.5 GiB (58%) de RAM sur 7.8 GiB.

Le système dispose de 4.0 GiB de swap !

Oui tu a raison… je n’avais pas pensé ainsi… pour le démarrage

Je me suis dit que j’allais enlever certaine application qui ne me servent pas… et maintenant quand je vais dans application " Il n’y a aucune application installée."…

Incroyable… lollll je redemarre le serveur… a suivre.

serveur redemarrer et aucune application installé d’apres l’interface de ynh… alors que j’ai acces a toutes les applications…et tout les services sont au vert.

Y t’il un exorciste sur le forum?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.