# Planka - Cannot connect right after installation

**URL:** https://forum.yunohost.org/t/planka-cannot-connect-right-after-installation/42728
**Category:** Support apps
**Tags:** planka, english
**Created:** [July 29, 2026, 2:13pm UTC](https://forum.yunohost.org/t/planka-cannot-connect-right-after-installation/42728 "2026-07-29T14:13:55Z")
**Posts on this page:** 11
**Page:** 1

<div class="post-metadata">

### Author: ![punky](https://forum.yunohost.org/letter_avatar_proxy/v4/letter/p/ed8c4c/32.png) [@punky](https://forum.yunohost.org/u/punky)
#### Post date: [July 29, 2026, 2:13pm UTC](https://forum.yunohost.org/t/planka-cannot-connect-right-after-installation/42728/1 "2026-07-29T14:13:55Z")

</div>

**What app is this about, and its version** : Planka 2.1.0~ynh1  
**What YunoHost version are you running** : 13.0.4 (testing)  
**What type of hardware are you using** : VPS bought online

### Describe your issue

Hi,

I’m trying to use Planka on my VPS which is up and running other applications already.

The issue that I’m facing is that right after the installation, I cannot login into the application with an admin account or any other account.

At installation time, I made sure that the admin of yunohost is selected as admin of the application, and copy/pasted the login of the admin so that it is synchronised with the admin information, and that does not allow me to login as admin.

I found a thread on the forums that seems to be the same issue as mine since it is related to the same application version :

> [@Planka - initial login after app installation fails](https://forum.yunohost.org/t/planka-initial-login-after-app-installation-fails/42373):
>
> What app is this about, and its version: Planka (2.1.0~ynh1) What YunoHost version are you running: 12.1.40.1 What type of hardware are you using: Other(?) Describe your issue Hello, The initial login after installation fails with “invalid credentials”. I tried these workaround without improvements : Launch the script : sudo yunohost app install [https://github.com/YunoHost-Apps/planka\_ynh/tree/fix-admin-creation](https://github.com/YunoHost-Apps/planka_ynh/tree/fix-admin-creation), specified in [Wanderer & Planka - initial login after app installation fails](https://forum.yunohost.org/t/wanderer-planka-initial-login-after-app-installation-fails/40599) …

So I tried to follow indicated steps, but now, I’m facing a different issue 🙂

Executing `yunohost app shell planka`gives me a strange error, and does not bring me to a shell running under the user of the application. I get the following instead :

```auto
/usr/share/yunohost/helpers.v2.1.d/0-utils: line 459: sed: command not found
/usr/share/yunohost/helpers.v2.1.d/0-utils: line 483: systemctl: command not found
/usr/share/yunohost/helpers.v2.1.d/0-utils: line 487: su: command not found
/usr/share/yunohost/helpers.v2.1.d/0-utils: line 44: sleep: command not found

```

Checking the file /etc/passwd shows that the planka user does exist, so I don’t know why I cannot bring the shell correctly.

Trying the same yunohost command but with an other application does work, so it does not seem to be related to the yunohost installation itself.

The only difference I can see between my scenario and the thread I found is that I am running yunohost 13, whereas the thread was open for a version 12 stable. Could there be a link ?

Is there any alternate way to execute the advised command to trigger admin user creation ?  
Is there an issue with the application itself ?

Any help appreciated 🙂

Thanks,

### Share relevant logs or error messages

Here is what I get in the logs of the service :

```auto
ul 29 13:41:34 systemd[1]: Started planka.service - Planka: realtime kanban board.
Jul 29 13:41:36 node[278519]: 2026-07-29 13:41:36 [W] Custom terms not found, falling back to template
Jul 29 13:41:52 node[278519]: 2026-07-29 13:41:52 [W] Invalid email or username: "administrateur"!

```

I also tried with the email of the user and the full name of the user, the results are the same.

---

<div class="post-metadata">

### Author: ![Tho](https://forum.yunohost.org/user_avatar/forum.yunohost.org/tho/32/3667_2.png) [@Tho](https://forum.yunohost.org/u/Tho)
#### Post date: [July 31, 2026, 8:20pm UTC](https://forum.yunohost.org/t/planka-cannot-connect-right-after-installation/42728/2 "2026-07-31T20:20:02Z")

</div>

> [@punky](#):
>
> Executing `yunohost app shell planka`gives me a strange error, and does not bring me to a shell running under the user of the application. I get the following instead :
> 
> ```auto
> /usr/share/yunohost/helpers.v2.1.d/0-utils: line 459: sed: command not found
> /usr/share/yunohost/helpers.v2.1.d/0-utils: line 483: systemctl: command not found
> /usr/share/yunohost/helpers.v2.1.d/0-utils: line 487: su: command not found
> /usr/share/yunohost/helpers.v2.1.d/0-utils: li
> 
> ```

I’ve just installed a new version of Planka to test but could not reproduce, at least on Bookworm.

Could you try again with latest version?

---

<div class="post-metadata">

### Author: ![punky](https://forum.yunohost.org/letter_avatar_proxy/v4/letter/p/ed8c4c/32.png) [@punky](https://forum.yunohost.org/u/punky)
#### Post date: [August 3, 2026, 5:26am UTC](https://forum.yunohost.org/t/planka-cannot-connect-right-after-installation/42728/3 "2026-08-03T05:26:05Z")

</div>

Hi,

thanks for having a look at the issue I’m facing.

I did an uninstall / re-installation of the application, now in version 2.1.1; I’m doing similar steps as the previous ones, and once installed, I checked the login page but still cannot connect with the account created at installation time.

Moving on to ssh on the machine, I’m still unable to execute the shell command on this application :

```bash
administrateur@xxx:~$ sudo yunohost app shell planka
/usr/share/yunohost/helpers.v2.1.d/0-utils: line 459: systemctl: command not found
/usr/share/yunohost/helpers.v2.1.d/0-utils: line 459: sed: command not found
/usr/share/yunohost/helpers.v2.1.d/0-utils: line 483: systemctl: command not found
/usr/share/yunohost/helpers.v2.1.d/0-utils: line 487: su: command not found
/usr/share/yunohost/helpers.v2.1.d/0-utils: line 44: sleep: command not found

```

Think this could be linked to yunohost being a testing version ? I did install the “unattended-upgrades” application which looks like to do its job, it seems I’m up-to-date regarding system packages.

---

<div class="post-metadata">

### Author: ![jarod5001](https://forum.yunohost.org/user_avatar/forum.yunohost.org/jarod5001/32/5323_2.png) [@jarod5001](https://forum.yunohost.org/u/jarod5001)
#### Post date: [August 3, 2026, 11:25pm UTC](https://forum.yunohost.org/t/planka-cannot-connect-right-after-installation/42728/4 "2026-08-03T23:25:06Z")

</div>

Do you have these errors with other apps shells?  
Try `sudo -u planka /bin/bash`and/or `su -s /bin/bash planka`, any errors?  
Can you also check the path as root and when switching to planka user `echo $PATH`

---

<div class="post-metadata">

### Author: ![punky](https://forum.yunohost.org/letter_avatar_proxy/v4/letter/p/ed8c4c/32.png) [@punky](https://forum.yunohost.org/u/punky)
#### Post date: [August 4, 2026, 7:16am UTC](https://forum.yunohost.org/t/planka-cannot-connect-right-after-installation/42728/5 "2026-08-04T07:16:06Z")

</div>

Hi,

other applications are working fine, here for example with bookstack which is also installed on the machine :

```auto
administrateur@xxx:~$ sudo yunohost app shell bookstack
bookstack@xxx:~$ 

```

As for errors when doing sudo, it appears there is an issue yes; executing `sudo -u planka /bin/bash` leads to this :

```auto
administrateur@xxx:~$ sudo -u planka /bin/bash
Sorry, user administrateur is not allowed to execute '/bin/bash' as planka on xxx.yyy.

```

The command `su -s /bin/bash planka`asks for a password, I have no idea what to enter in terms of password 🙂

Here is the path value for the administrator user :

```auto
administrateur@xxx:~$ echo $PATH
/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games

```

Thanks for the help,

Edit:  
I did additional tests and none of the sudo commands are working, even with a user related to an application that works (I tested with bookstack) :

```auto
administrateur@xxx:~$ sudo -u bookstack /bin/bash
[sudo] password for administrateur: 
Sorry, user administrateur is not allowed to execute '/bin/bash' as bookstack on xxx.yy.

```

I tried to do comparison of the users in /etc/passwd, the configuration seems similar for planka and bookstack :

```auto
bookstack:x:992:984::/var/www/bookstack:/bin/sh
planka:x:987:982::/var/www/planka:/bin/sh

```

And the application is correctly linked to its own group in /etc/group :

```auto
bookstack:x:984:bookstack
planka:x:982:planka

```

---

<div class="post-metadata">

### Author: ![otm33](https://forum.yunohost.org/user_avatar/forum.yunohost.org/otm33/32/11941_2.png) [@otm33](https://forum.yunohost.org/u/otm33)
#### Post date: [August 5, 2026, 9:09am UTC](https://forum.yunohost.org/t/planka-cannot-connect-right-after-installation/42728/6 "2026-08-05T09:09:41Z")

</div>

So there is an issue with the environment variables when starting a shell as the planka user.

Try running this to create your admin user :

```auto
sudo -u planka env PATH=/opt/node_n/n/versions/node/22.23.2/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin COREPACK_ENABLE_DOWNLOAD_PROMPT=0 NPM_CONFIG_UPDATE_NOTIFIER=false npm run db:create-admin-user

```

Yout nodejs version (here 22.23.2) may be different : you can check it with `grep nodejs_version /etc/yunohost/apps/planka/settings.yml`

This should work. Let us know.

---

<div class="post-metadata">

### Author: ![punky](https://forum.yunohost.org/letter_avatar_proxy/v4/letter/p/ed8c4c/32.png) [@punky](https://forum.yunohost.org/u/punky)
#### Post date: [August 5, 2026, 10:23am UTC](https://forum.yunohost.org/t/planka-cannot-connect-right-after-installation/42728/7 "2026-08-05T10:23:01Z")

</div>

Hi,

thanks for the instructions; the node version I have is the same as the one you pointed out :

```auto
administrateur@xxx:~$ sudo grep nodejs_version /etc/yunohost/apps/planka/settings.yml
nodejs_version: 22.23.2

```

Now onto the command line to create the admin user; unfortunately, this one seems to fail at the sudo step because of execution rights :

```auto
administrateur@xxx:~$ sudo -u planka env PATH=/opt/node_n/n/versions/node/22.23.2/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin COREPACK_ENABLE_DOWNLOAD_PROMPT=0 NPM_CONFIG_UPDATE_NOTIFIER=false npm run db:create-admin-user
Sorry, user administrateur is not allowed to execute '/usr/bin/env PATH=/opt/node_n/n/versions/node/22.23.2/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin COREPACK_ENABLE_DOWNLOAD_PROMPT=0 NPM_CONFIG_UPDATE_NOTIFIER=false npm run db:create-admin-user' as planka on xxx.yy.

```

But that led me to something; i’m connecting through ssh as the ‘administrateur’ user, which is one created by yunohost; on the machine, there is also the ‘debian’ user which is the original account that exists since installation, and this one seems to have the required sudo rights :

```auto
debian@xxx:~$ sudo -u planka env
LANG=C.UTF-8
LS_COLORS
...

```

So I think I should use this account instead; unfortunately, it’s still unable to run the yunohost shell command :

```auto
debian@xxx:~$ sudo yunohost app shell planka
/usr/share/yunohost/helpers.v2.1.d/0-utils: line 459: sed: command not found
/usr/share/yunohost/helpers.v2.1.d/0-utils: line 459: systemctl: command not found
/usr/share/yunohost/helpers.v2.1.d/0-utils: line 483: systemctl: command not found
/usr/share/yunohost/helpers.v2.1.d/0-utils: line 487: su: command not found
/usr/share/yunohost/helpers.v2.1.d/0-utils: line 44: sleep: command not found

```

Anyway, back to the manual command to create the db admin user for planka; now I’m able to execute it, but there is a file access issue :

```auto
debian@xxx:~$ sudo -u planka env PATH=/opt/node_n/n/versions/node/22.23.2/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin COREPACK_ENABLE_DOWNLOAD_PROMPT=0 NPM_CONFIG_UPDATE_NOTIFIER=false npm run db:create-admin-user
npm error code EACCES
npm error syscall open
npm error path /home/debian/package.json
npm error errno -13
npm error Error: Could not read package.json: Error: EACCES: permission denied, open '/home/debian/package.json'

```

This is probably due to the command being executed in the home folder of the user, and since it’s executed as the planka user, it does not have access to read and write in it.

So I switched to sudo in interactive mode to be able to change directory before executing the command :

```auto
debian@xxx:~$ sudo -i -u planka
$ cd /var/www/planka
$ env PATH=/opt/node_n/n/versions/node/22.23.2/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin COREPACK_ENABLE_DOWNLOAD_PROMPT=0 NPM_CONFIG_UPDATE_NOTIFIER=false npm run db:create-admin-user

> db:create-admin-user
> node db/create-admin-user.js
...

```

And that worked 😃

In the end, I don’t exactly know what the difference is between my 2 users, and also why I cannot run the standard yunohost shell command, but at least I’m able to connect to planka now with the admin user.

Thanks for the help !

---

<div class="post-metadata">

### Author: ![otm33](https://forum.yunohost.org/user_avatar/forum.yunohost.org/otm33/32/11941_2.png) [@otm33](https://forum.yunohost.org/u/otm33)
#### Post date: [August 5, 2026, 11:27am UTC](https://forum.yunohost.org/t/planka-cannot-connect-right-after-installation/42728/8 "2026-08-05T11:27:27Z")

</div>

You need to run the command as root user, and, yes, in planka install directory.

```auto
cd /var/www/planka
su
# root password 
sudo -u planka env PATH=/opt/node_n/n/versions/node/22.23.2/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin COREPACK_ENABLE_DOWNLOAD_PROMPT=0 NPM_CONFIG_UPDATE_NOTIFIER=false npm run db:create-admin-user

```

---

<div class="post-metadata">

### Author: ![jarod5001](https://forum.yunohost.org/user_avatar/forum.yunohost.org/jarod5001/32/5323_2.png) [@jarod5001](https://forum.yunohost.org/u/jarod5001)
#### Post date: [August 5, 2026, 11:44am UTC](https://forum.yunohost.org/t/planka-cannot-connect-right-after-installation/42728/9 "2026-08-05T11:44:12Z")

</div>

There is a bug in app shell command for apps with nodejs path in systemd env.  
I installed wekan and got the same behavior

---

<div class="post-metadata">

### Author: ![otm33](https://forum.yunohost.org/user_avatar/forum.yunohost.org/otm33/32/11941_2.png) [@otm33](https://forum.yunohost.org/u/otm33)
#### Post date: [August 5, 2026, 12:53pm UTC](https://forum.yunohost.org/t/planka-cannot-connect-right-after-installation/42728/10 "2026-08-05T12:53:56Z")

</div>

Maybe this is a silent bug in many apps using nodejs.

For planka on Trixie, I noticed two things:

- there is no apparent issue if “`NODE_ENV=production`” is set before `path=path_with_nodejs` in the service file. You can open planka shell as expected.
- the `path_with_nodejs` is slightly different than in bookworm, so `"NODE_ENV=production''`breaks the path on Trixie but does not on bookwork (or without aborting)

So I assume the issue is related to how the env vars are passed for the app user shell. I’m sorry but it’s still a pain to reach GitHub for me…🙄

---

<div class="post-metadata">

### Author: ![system](https://forum.yunohost.org/uploads/default/original/2X/f/f59fe8e3ee6b100b4f574d30d6e30479c68b89f0.png) [@system](https://forum.yunohost.org/u/system)
#### Post date: [August 20, 2026, 12:54pm UTC](https://forum.yunohost.org/t/planka-cannot-connect-right-after-installation/42728/11 "2026-08-20T12:54:02Z")

</div>

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.
