Php version 7.4?

Matériel: Raspberry Pi à la maison
Version de YunoHost: (stable).
J’ai accès à mon serveur : En SSH | Par la webadmin
Êtes-vous dans un contexte particulier ou avez-vous effectué des modificiations particulières sur votre instance ? : non

apres un ticket ouvert du coté de l’application 2fauth concernant plusieurs petit problemes, il semble que depuis la version 3 de 2fauth, PHP 7.3 n’est plus supporté, et qu’il faut utiliser la 7.4 .
quand je fais PHP --version, il me retourne 7.33 …est il prevu un update ? ou cela depend t’il des depots propres au raspberry ?

Each app as its own version of PHP set with Sury. 2fauth uses PHP8.0. PHP7.3 is the default version installed with Buster and PHP7.4 for Bullseye

1 Like

is there a way to check this ?

/etc/php/8.0/fpm/pool.d to find out what app is configured to use a specific version.
I’m sure a bash command can also be used to check which version of PHP applications are using…

will try to confirm with 2fauth author, but it seems like it need the 7.4 version …
in yuno it’s confgured with 8.0
maybe my problems come from here

Try to install 2fauth with PHP7.4 from this branch to see if your problem disappear

sudo yunohost app install --force
1 Like

And also it is always usefull to open an issue on 2fauth_ynh repo (that can be share with upstream eventualy).

can i do this with 2faut already installed or may i uninstall first ?

Better to remove and reinstalle.

ok … i’ll wait for the author if he need for testing purposes, and i’ll try that. i’ve opened a ticket on the github.

i kept this thread open for the moment,TY

tried with the 7.4 php version … still the same problem…
look like the problem is not with php version

maybe with the arm arch ?

hi ericg .
the authos was able to reproduce the bug i have : , it’s a regression introduced by the v3.1.0 on the create form.

He’ll push a fix soon … hope you’ll make a testing version .
send me a message when it’s done for testing it !

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.