[PeerTube] Partager iframe site externe

en
fr
#21

Hey sorry,

la commande n’a rien renvoyé que ce soit au niveau du dossier Nginx ou conf.d

grep -r -i 'peertube__2\.conf' *

J’ai refais une installation de mon instance peertube et cela fonctionne de nouveau https://tube.metadocs.cc re-fonctionne de nouveaux. Je suis ready pour de nouveaux tests =)

#22

Si tu n’as rien au retour de commande, cela voudrait certainement dire que peertube__2.conf n’est référencé nulle part. Et que les modifs ne font rien.

Quelle distribution Linux utilises-tu ? Debian, Ubuntu, Fedora, autre ?

Quels fichiers as-tu sous /etc/nginx/conf.d/ et sous /etc/nginx/conf.d/tube.metadoc.cc/ ?

#23

Excuse moi de mon absence @PaliPalo, me revoilà connecté sur la toile.
Du coup c’est yunohost, qui est basé sur une debian stretch.

Sous  /etc/nginx/conf.d/

J’ai la liste de mes services sous cette forme :

nom.nomdedomaine.eu.conf
nom.nomdedomaine.eu.d (dossier dans lequel il y a 2 fichier : 

000-acmechallenge.conf
appli.conf

En espérant que ça puisse aider ?

#24

Pas de soucis, Plumf. Nous sommes sur le web, le temps n’a plus d’importance :slight_smile:

Tu as donc reconfiguré tube.metadoc.cc, je me trompe ?

Tu devrais donc avoir un fichier tube.metadoc.cc.conf sous /etc/nginx/conf.d/ et un nommé peertube__2.conf dans le sous-dossier tube.metadoc.cc.d

Donc, je suppose que tu as une directive server { dans le fichier tube.metadoc.cc.conf. Correct ?

Dans ce même fichier tu devrais avoir une directive include applic.conf (dans ton cas ce devrait être include peertube__2.conf). Mais là je pense qu’elle n’y est pas.

#25

J’ai triché dans la reconfiguration j’ai supprimé l’application et je l’ai reinstallé, dans le fichier :

etc/nginx/conf.d/tube.metadoc.cc.conf

J’ai trois ligne ligne avec un include :

include /etc/nginx/conf.d/tube.metadocs.cc.d/*.conf;
include /etc/nginx/conf.d/yunohost_admin.conf.inc;
include /etc/nginx/conf.d/yunohost_api.conf.inc;

Cela peut il etre une piste ? (je me ne me suis pas encore aventuré dans le dossier

/etc/nginx/conf.d/tube.metadocs.cc.d
#26

OK.

La ligne

include /etc/nginx/conf.d/tube.metadocs.cc.d/*.conf;

spécifie qu’elle va lire et appliquer les options inscrites dans tous les fichiers dont le nom se termine par .conf et qui se trouvent dans le dossier nommé /etc/nginx/conf.d/tube.metadocs.cc.d/ D’ailleurs, c’est la raison pour laquelle la commande grep que je t’avais fait exécuter précédemment n’avait rien affiché vu que ce fichier ne contenait pas peertube__2.conf.

Donc, si ton fichier peertube__2.conf était dans le dossier /etc/nginx/conf.d/tube.metadocs.cc.d/ (avant la réinstallation), il aurait dû être inclus et les options qu’il contenait auraient dû être appliquées également.

Qu’as-tu actuellement dans /etc/nginx/conf.d/tube.metadocs.cc.d/ ?

#27

J’ai deux fichiers de configurations :

000-acmechallenge.conf
peertube__2.conf

Mais ce sont les seuls présents, ce que je ne comprend pas c’est que le fichier de configuration “mere” fait pourtant bien appel à peertube__2.conf …

#28

Le fichier 000-acmechallenge.conf m’a l’air d’être en rapport avec Let’s Encrypt. Donc nous devrions le mettre de côté.

Dans ton fichier /etc/nginx/conf.d/tube.metadoc.cc.conf, as-tu quelque chose qui ressemble à peu près à ceci :

server {
  listen 443 ssl http2;
  listen [::]:443 ssl http2;
  server_name peertube.example.com;

Si c’est le cas, essaye de rajouter la ligne d’option add_header 'X-Frame-Options' 'ALLOWALL'; après la ligne server_name...

Par ailleurs, si tu sais mettre une vidéo pour que je teste un peu les headers sur un client web.

#29

Plus bas dans le fichier de configuration il y a cette option dois je plutot la modifier que rajouter une ligne ?

`add_header 'X-Frame-Options' 'SAMEORIGIN';`
#30

Essai de video :

<iframe width="560" height="315" sandbox="allow-same-origin allow-scripts" src="https://tube.metadocs.cc/videos/embed/a7a0361c-2149-4166-a3e6-929f81495d78" frameborder="0" allowfullscreen></iframe>

Il y a une video ici :

Le changement que tu me proposais est actuellement en place sur le serveur ?

#31

On se rapproche du but, dans les entêtes HTTP retournées de ton serveur, j’ai les deux :

x-frame-options	SAMEORIGIN
x-frame-options	ALLOWALL

Oui, essaye de modifier celle qui existe déjà.

#32

+1 essai

Ligne avec

x-frame-options	SAMEORIGIN 

commenté (donc supprimer du fichier de conf) en laissant la première ligne au même emplacement, il y a une iframe ici :

A propos, ou vois tu les entetes HTTP ? Et a quoi servent elles ?

#33

Youhou! C’est bon! Je vois la vidéo sur mon site web de test!

#34

Alors pour les visualiser les entêtes, je procède comme suit avec Firefox:

  1. J’ouvre la page de mon site web où j’ai inclu l’iframe
  2. J’appuye sur le touche [F12]
  3. Je choisi “Réseau” dans les “onglets” (entre “mémoire” et “stockage”
  4. Je raffraichis la page en appuyant sur [F5]
  5. Dans le cadre en bas avec une liste de requêtes HTTP, je choisis une ligne avec le domaine pourlequel je veux visualiser les entêtes (en l’occurence, je choisis une ligne avec `tube.metadocs.cc)
  6. Une nouvelle portion de fenêtre apparaît à droite, dans laquelle je choisis l’onglet “En-têtes” en haut à côté de “cookies”
  7. Dans la partie “En-têtes de la réponse”, je constate quelles sont celles présentes ainsi que leur valeur.

J’espère que c’est assez clair :slight_smile:

1 Like
#35

Elles servent justement à paramétriser certains comportements autorisés ou interdits (comme pour ton cas, où il fallait justement autoriser -ALLOW- que les frames soient exploitables par d’autres sites que celui qui héberge la ressource) De plus elle permettent de définir les compatibilités entre le serveur et le client web. On pourrait par exemple parler de l’encodage du texte sur le serveur qui pourrait ne pas être supporté par le client web. Mais bon, je ne suis pas expert dans le domaine. Je te conseille de regarder ici :

#36

C’est clair comme de l’eau de roche. Je vais m’atteler à la lecture de la page wikipedia en anglais (elle n’existe pas en français)

Un grand merci pour ton aide :sparkler::fireworks::sparkler: et ta perseverance dans le guidage et les détails.

#37

Sache que c’est tout à mon plaisir.

Bonne continuation.

Et si t’as besoin d’aide, n’hésite pas.