PANIC: Failed to register the runner. You may be having network problems

Hi! I installed a new yunohost server in VM and after a few DNS and SSL cert issues I finally got most everything working.
So far it is working very good except for one issue…

My YunoHost server

Hardware: Local VM behind a firewall.

  • libvirt/kvm
  • 4 virtual CPUs
  • 26624 MiB ram

YunoHost version: (stable).
I have access to my server : all three:

  1. Through SSH
  2. through the webadmin
  3. direct access via keyboard / screen
    I can ssh in an tail -f install logs as the installs are taking place.

Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

I can’t register a gitlab-runner. I can access the gitlab server via ssh and https. I can do git push/pulls against it. I can access to the https gitlab and projects.

The gitlab-server is running on my fresh yunohost server.

Here is the paste of the install logs.

Also tried installing the runner from ArchLinux and FreeBSD and got the
following, which is the same error message that is in the logs:

PANIC: Failed to register the runner. You may be having network problems. 
ERROR: Registering runner... failed                 runner=JWfiVxDd status=200 OK

How can there be a network problem when it is on the same machine or subnet?

  • in the case of trying to install via the yunohost server that has the gitlab instance
  • or in the case of the ArchLinux and FreeBSD attempts (same subnet)

I can curl the https main login URL and the gitlab server URL and I don’t get SSL certificate errors.

So, I removed gitlab, am starting over. also did a userdel -r -f git*

(where git* is very user with git in the name in /etc/passwd)

Reinstalled gitlab, I’ll see if I can install gitlab-runner now…

ok… now running into runner can’t install dependencies problem…

and, on other machines still can’t install git runner, still running into:

ERROR: Registering runner... failed                 runner=zyzCxF3d status=200 OK
PANIC: Failed to register the runner. You may be having network problems. 

Well, I reduced the memory footprint of that VM down to 4GiG and removed gitlab… Going to try gitlab on it it’s own VM (new yunhost install).

EDIT: That did not work either. So I created a CentOS 8 VM and installed gitlab in that… (And I can register runners with it). I’m closing this post, because that this point I have at gitlab server and don’t need to get one working in yunohost.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.