Owncloud 8.1 released!

,

Owncloud 8.1 has been released.
Any idea on how long it will take before it finds its way into Yunohost?

+1 … Many changes look great (including the app store for easy app installation).

Pourquoi ne peut-on pas tout simplement faire la maj vers 8.1 depuis owncloud directement ?

Why cannot we do the upgrade to 8.1 directly from owncloud app ?

Bonjour,
J’ai essayé la maj vers la 8.0.4 depuis owncloud, ça n’a pas fonctionné.

Ce week-end j’ai fait une maj de la 8.0.3 vers la 8.1 en suivant les instructions de maj majeur de la doc Owncloud.
Pour le moment ça fonctionne.

I am currently in holidays, I have sprainned my ankle so I could work on this update tuesday.
I think there is not a lot of think to do, you can try to fork the repo owncloud_ynh and replace the sources directory by the sources of 8.1 …

It should be good to understand why the owncloud are not updatable directly, may be some rights are missing ?

Hi,

I have updated the package to owncloud_8_1

WARNING: this package has been tested only on a wheezy stable. So if you use Jessy or a testing/unstable instance, take care.
For the moment, it is an unofficial update, because not enough test has been made. If you test it thanks to report it.

Changelog:
[enh] update to owncloud 8.1
[enh] add contact and calendar app by default in the app directory
[enh] optimize owncloud with a memcache system like it is ask on the admin panel
[fix] hidden files are now copied during the process install

Known issues:

About Jessie the package doesn’t work.
There is a problem with php-apc and nosnif option.

chez moi j’ai la maj de owncloud 8.0.5 vers la 8.1.1 et ça c’est pas trop mal passer hormis une erreur 504 après la maj.
j’ai fais un : sudo su -c “php occ maintenance:repair” owncloud

et tout à refonctionner comme par magie.
je précise, je suis sur un debian jessie 64bit

I had updated to 8.1.1.
I fix a minor bug concerning permission with old instance of owncloud.

OwnCloud 8.1.1 is now validated among the official app list.

yunohost app fetchlist
yunohost app upgrade owncloud

est-ce que je peux faire cette mise à jour après avoir installer la version test de lfj https://github.com/zamentur/owncloud_ynh ?

Bon, j’ai essayé de la faire et ça semble fonctionner …

I have updated the package to 8.1.3.
You can test here:

I already have post the pull request to kload.

Bonjour,

J’ai upgradé vers la 8.1.1 mais maintenant j’ai une erreur avec owncloud-client il me dit “Erreur : paramètres de connexion invalides”

Avez-vous eu le même problème ?

yunohost 32bits V2 sur un ordi standard à l’aide de l’iso sous debian 7


Hi,

I have upgrade to 8.1.1 and i can not connect with owncloud-client “Erreur : paramètres de connexion invalides”

someone have the same problem ?

yunohost 32bits V2 in standard computer (debian 7)

J’ai trouvé lol / I have resolv de problem

Il suffisait de mettre à jour le client :; procédure à suivre : / Upgrade owncloud-client like describe in the link :

https://software.opensuse.org/download/package?project=isv:ownCloud:desktop&package=owncloud-client

Pour ma part, le message owncloud-client “Erreur : paramètres de connexion invalides” est apparu lors de 2 situations précises :

  1. Un décalage de version entre owncloud client et le server owncloud. Dans ce cas, il faut aligner les 2.

  2. Une réinstallation ou une mise à jour de owncloud-client dont des fichiers de configuration de la version précédente sont restés et impactent la dernière version installée.

Dans ce cas :

  • désinstaller complètement owncloud-client, via synaptic : owncloud-client, owncloud-client-l10n et libowncloudsync0
  • effacer les répertoires et fichiers temporaires dont les noms commencent par sni-qt*, dans le répertoire /tmp
  • effacer le répertoire $/.local/share/data/ownCloud (il contient les données de connexion et de configuration de la version précédente)
  • réinstaller owncloud-client

8.2 is out!

when can we expect an update?

Why don’t you use the updater within owncloud? Works, as far as i can see, fine!

I seem to run in to problems then… Would prefer to wait for Yunohost to provide a tried and tested update

Symfony\Component\Routing\Exception\RouteNotFoundException:
Unable to generate a URL for the named route "contacts_index" as such 
route does not exist.
The update was unsuccessful. Please report this issue to the ownCloud community.

on seconds attempt this actually worked. I do not know why I didn’t think of this myself. Thanks!