Outline app install - JavaScript heap out of memory

My YunoHost server

Hardware: RackNerd VPS - 2 vCPU, 2.5GB RAM, 60GB SSD
YunoHost version: 11.2.4
I have access to my server : Through SSH
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If yes, please explain: N/A
If your request is related to an app, specify its name and version: Outline 0.69.2.2~ynh1

Description of my issue

Hi everyone :wave:! I’m a new YunoHost user here trying to install the Outline app. I seem to be running into a memory issue which I have been unable to workaround without going to buy a higher tier VPS with more RAM and I’d appreciate if anyone could take a look and offer any pointers on what I could try next :smiley:.

Full logs here: https://paste.yunohost.org/raw/ihilafehej

2023-09-19 12:13:24,514: DEBUG - FATAL ERROR: Reached heap limit Allocation failed - JavaScript heap out of memory

Workaround attempts

From lots of searching on this forum and Google these are my attempts to fix the issue without just upgrading the tier on my VPS to get more RAM.

So far I’ve tried increasing my swap space:

root@cloud:~# cat /proc/swaps
Filename				Type		Size		Used		Priority
/swapfile                               file		10485756	452712		-2
/dev/vda2                               partition	3144700		0		-3

From top:

MiB Mem :   2471.8 total,   1486.3 free,    321.6 used,    663.9 buff/cache
MiB Swap:  13311.0 total,  12870.1 free,    440.9 used.   1978.2 avail Mem

Changing the swappiness from 60 to 1 to 200 (last attempt in the logs was 200):

root@cloud:~# cat /proc/sys/vm/swappiness
200

I’ve also tried changing --max-old-space-size incase node needed more memory:

root@cloud:~# echo $NODE_OPTIONS
--max-old-space-size=32768

and finally I jumped up a tier on my VPS from the original 1.5GB of RAM to 2.5GB of RAM which is what I am now using in the attempt above in the logs.

During the install process, when I watch the memory usage via top the install seems to always fail at the build step with around 70MiB free Mem and I only ever see less than 500MiB used in swap.

If anyone has any ideas on what I could try next I would really appreciate it - I could bump up to the next tier on the VPS but would rather try and find a way around with what I have now.

Thanks!

Managed to install the app by forking the app on Github and adding the following to the install script:

NODE_OPTIONS="--max-old-space-size=8192"

to become

ynh_exec_warn_less sudo -u $app env $ynh_node_load_PATH NODE_OPTIONS="--max-old-space-size=8192" yarn build 2>&1

Hope that helps someone! :slightly_smiling_face:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.