OnlyOffice fails to open files since update to 7.3.4

My YunoHost server

Hardware: VM hosted by our university
YunoHost version: 4.2.8.3
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : I don’t know
If yes, please explain:

Description of my issue

Hi everyone, and thanks to all the devs and people contributong to Yunohost !

I tried updating Nextcloud apps today, and I updated OnlyOffice connector to v7.3.4. I then tried to edit a file and it doesn’t work anymore, I get a unsupported version error message and a blank page.

I thought I might have to update Nextcloud (actual version : 22.1.1), I tried but it fails because I am still using ynh 4.2.

Any idea what I should do ? Is it safe to update ynh to 4.3 yet ? Is it unrelated ?

I can respond in English or in French

Thank you :pray:

Logs logs logs :smiley: Without them, we cannot help you more…

As for the Yunohost update, you can update yes, it’s a stable version.

1 Like

Beware also that OnlyOffice disabled support to old microsoft formats (.doc, .ppt), probably to focus on compatibility with recent ones (docx). This seems to be the case since at least 7.0.1 (but I can’t find any info on that…)

1 Like

Hi and thanks for your reply, I have tried searching for nextcloud or onlyoffice related logs, but I cannot find anything, and my logs are spammed with backup logs because our borg instance is malfunctionning :frowning:

Any idea how I can find more info ?

Thanks for the suggestion, but the problem happens with a recent format (xlsx)

Hi,

same issue here!

The browser’s devtools show a request failing with NS_BINDING_ABORTED when requesting https://mydomain.tld/apps/richdocuments/index?fileId=12345&requesttoken=TOKEN.

Also I get these errors in the nginx logs:

2022/05/19 09:14:31 [error] 32623#32623: *2955211 upstream timed out (110: Connection timed out) while reading response header from upstream, client: MY_BROWSER_IP, server: mydomain.tld, request: "GET /apps/richdocumentscode/proxy.php?status HTTP/2.0", upstream: "fastcgi://unix:/var/run/php/php7.3-fpm-nextcloud.sock", host: "mydomain.tld"
2022/05/19 09:19:44 [error] 32623#32623: *2955211 FastCGI sent in stderr: "PHP message: richdocumentscode (proxy.php) error exit, PID: 15337, Message: No content in reply from coolwsd. Is SSL enabled in error ?" while reading upstream, client: MY_BROWSER_IP, server: mydomain.tld, request: "POST /apps/richdocumentscode/proxy.php?req=/cool/https%3A%2F%2Fmydomain.tld%2Findex.php%2Fapps%2Frichdocuments%2Fwopi%2Ffiles%2F30632_ocigfuk7vssz%3Faccess_token%3DQIxNOB2Kmq4bAvIicc38VEZb1HbLjqje%26access_token_ttl%3D0/ws?WOPISrc=https%3A%2F%2Fmydomain.tld%2Findex.php%2Fapps%2Frichdocuments%2Fwopi%2Ffiles%2F30632_ocigfuk7vssz&compat=/ws/44ba1f8c71145d201d4c93e546977fb3/close/2 HTTP/2.0", upstream: "fastcgi://unix:/var/run/php/php7.3-fpm-nextcloud.sock:", host: "mydomain.tld"
1 Like

J’ai désactivé l’application, l’ai réactivée, et ça a fonctionné (entre temps j’ai eu un message d’erreur comme quoi il n’y avait plus d’espace disque, ça m’arrive de temps en temps malgré qu’il reste de la place, mais c’est un autre souci).

1 Like

I tried deactivating / reactivating, didn’t work for me :frowning:

I just tried searching for logs with the incident date, there is no log that seems related (only backup and new user logs)…

sudo yunohost log list --limit 200 | grep 20220511 -C3

Yes it’s safe

However, i think your onlyoffice package is not up to date.
I suggest you to backup all the files in: /var/lib/onlyoffice/documentserver/App_Data/cache/ , remove onlyoffice and reinstall it.