[OnlyOffice] Errors when installing OnlyOffice


My YunoHost server

Hardware: Raspberry Pi at home
YunoHost version:
I have access to my server : Through SSH, through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : Kind of : The yunohost is connected to a personnal VPN located in France (like labriqueinternet)

Impossible to install OnlyOffice

Hi all,

I tried to install OnlyOffice but it failed.

Nextcloud is already installed on my yunohost and works nicely but

  • I’m not sure if it has been installed with the “public” or “private” option (and I checked there /etc/yunohost/apps/nextcloud/settings.yml but did not find the is_public parameter )
  • I didn’t install the OnlyOffice App in Nextcloud (as the YNH_OnlyOffice readme does not mention it)

Here are the complete logs : https://box.sucha.fr/zerobin/?824c90d49563aa11#mTVISyeLs17OR42N47t4mqbdBBQJkLEz7TzSeQrfCWk=

And here is the part that, I would say, goes wrong :

2019-11-14 10:18:01,874: DEBUG - The following packages were automatically installed and are no longer required:
2019-11-14 10:18:01,875: DEBUG -   erlang-asn1 erlang-base erlang-corba erlang-crypto erlang-diameter
2019-11-14 10:18:01,876: DEBUG -   erlang-edoc erlang-eldap erlang-erl-docgen erlang-eunit erlang-ic
2019-11-14 10:18:01,877: DEBUG -   erlang-inets erlang-mnesia erlang-nox erlang-odbc erlang-os-mon
2019-11-14 10:18:01,878: DEBUG -   erlang-parsetools erlang-percept erlang-public-key erlang-runtime-tools
2019-11-14 10:18:01,880: DEBUG -   erlang-snmp erlang-ssh erlang-ssl erlang-syntax-tools erlang-tools
2019-11-14 10:18:01,881: DEBUG -   erlang-xmerl libcurl3-nss libcurl4-nss-dev libsctp1 libtidy5 rabbitmq-server
2019-11-14 10:18:01,882: DEBUG -   sgml-base xml-core
2019-11-14 10:18:01,883: DEBUG - Use 'apt autoremove' to remove them.
2019-11-14 10:18:09,812: DEBUG - The following packages will be REMOVED:
2019-11-14 10:18:09,813: DEBUG -   onlyoffice-ynh-deps
2019-11-14 10:18:09,914: DEBUG - 0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
2019-11-14 10:18:09,915: WARNING - E: Packages need to be removed but remove is disabled.
2019-11-14 10:18:09,917: DEBUG - + ynh_die '--message=Unable to install dependencies'
2019-11-14 10:18:09,917: WARNING - Unable to install dependencies
2019-11-14 10:18:09,923: DEBUG - + local legacy_args=mc
2019-11-14 10:18:09,924: DEBUG - + args_array=([m]=message= [c]=ret_code=)
2019-11-14 10:18:09,924: DEBUG - + declare -Ar args_array
2019-11-14 10:18:09,925: DEBUG - + local message
2019-11-14 10:18:09,926: DEBUG - + local ret_code
2019-11-14 10:18:09,926: DEBUG - + ynh_handle_getopts_args '--message=Unable to install dependencies'
2019-11-14 10:18:09,927: DEBUG - + set +x
2019-11-14 10:18:09,927: DEBUG - + echo 'Unable to install dependencies'
2019-11-14 10:18:09,928: DEBUG - + exit 1
2019-11-14 10:18:09,929: DEBUG - + ynh_exit_properly
2019-11-14 10:18:09,930: DEBUG - + local exit_code=1
2019-11-14 10:18:09,930: DEBUG - + '[' 1 -eq 0 ']'
2019-11-14 10:18:09,931: DEBUG - + trap '' EXIT

Thanks very much for you kind help,
Have a nice day

Hey charly, just some wild guesses…

You did the usual sudo apt-get update &sudo apt-get upgrade ?
Did you run sudo apt-get autoremove and tried the installation again?



Thanks for you help.
Apt remove didn’t remove any package but somehow the output is now different, here are the logs :


Can you install “dirmngr” via apt-get install dirmngr. It seems to be needed but not in place. And try again?

dirmngr is already the newest version (2.1.18-8~deb9u4).

Weird, isn’t it ?

I can’t install onlyoffice also :

On dirait bien que ça provient de là :

Add OnlyOffice repository…’
2019-11-16 21:33:10,743: DEBUG - + apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys CB2DE8E5
2019-11-16 21:33:11,045: WARNING - Warning: apt-key output should not be parsed (stdout is not a terminal)

Du coup, je ne sais pas si c’est une bonne idée de rajouter en ligne de commande le repository ou non, comme expliqué un peu partout sur le Ouaibe, par exemple ici

merci, si quelqu’un a un retour en ajoutant à la mains le dépôt …

I don’t speak french but i think he is suggesting to run the step manually before the installation.

apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys CB2DE8E5

echo "deb http://download.onlyoffice.com/repo/debian squeeze main" | sudo tee /etc/apt/source

And try the installation again.

it doesn’t work …


Si ca provient de Rabbit-mq.server, tu trouveras quelques infos ci-dessous :

AleksDev group
9 sept.
L’erreur viens de : astrowalker2013:

2019-09-08 21:52:18,905: DEBUG - Errors were encountered while processing:
2019-09-08 21:52:18,906: DEBUG - rabbitmq-server
qui est lié à onlyoffice (c.f. un autre sujet qui en parle : Rabbitmq-server probleme et Problème d’installation OfficeOnly )
Bump @ljf qui en sait peut-etre plus sur le sujet

Bin attendons de voir ce que ça donne.
Merci en tout cas pour les réponses


Similar issue here. I tried to add the onlyoffice repo by hand as suggested above. It seems that repo does not support the ARM architecture needed for a Raspbery Pi.

root@le-led:~# apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys CB2DE8E5
Executing: /tmp/apt-key-gpghome.OC0gdAi0J8/gpg.1.sh --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys CB2DE8E5
gpg: key 8320CA65CB2DE8E5: public key "Ascensio System Limited (ONLYOFFICE) <support@onlyoffice.com>" imported
gpg: Total number processed: 1
gpg:               imported: 1
root@le-led:~# echo "deb http://download.onlyoffice.com/repo/debian squeeze main" | sudo tee /etc/apt/sources.list.d/onlyoffice.list
deb http://download.onlyoffice.com/repo/debian squeeze main
root@le-led:~# apt-get update
Hit:1 http://forge.yunohost.org/debian stretch InRelease
Hit:2 http://raspbian.raspberrypi.org/raspbian stretch InRelease    
Get:3 http://download.onlyoffice.com/repo/debian squeeze InRelease [14.3 kB]
Hit:4 http://archive.raspberrypi.org/debian stretch InRelease       
Fetched 14.3 kB in 1s (8,216 B/s)                                   
Reading package lists... Done
N: Skipping acquire of configured file 'main/binary-armhf/Packages' as repository 'http://download.onlyoffice.com/repo/debian squeeze InRelease' doesn't support architecture 'armhf'

Well, as my ex-boss would say : “We should urgently wait”


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.