[Official topic] Nextcloud

Hi,

Maybe these topics could helps you :


ppr

1 Like

Bonjour, j’ai eu un soucis lors de la derniùre update.
J’ai suivi la procĂ©dure pour dĂ©placer le fichiers du dossier data dans un autre dossier, j’ai donc supprimer le contenu de l’ancien dossier et lors de l’update il y a eu une erreur , donc en fouillant dans les logs , il s’avĂšre que la cause de l’erreur est du au fichier nextcloud log ( je sais plus comment il s’appel exactement) j’ai donc rĂ©tabli l’ancien fichier et l’update s’est bien faite.
Je sais pas si sa peut ĂȘtre intĂ©grĂ© dans le script d’update et savoir si le fichier est prĂ©sent ou pas et le crĂ©er au besoin.

New stable release :tada:

  • 25 January 2019 - #249
    • Upgrade to Nextcloud 15.0.14
    • Use ynh_get_scalable_phpfpm to adapt php to the actual device (avoid crashing on low-end devices)

Bonjour,
Un nouveau message d’avertissement que je n’avais pas avec la 15.0.13

PHP ne semble pas ĂȘtre configurĂ© de maniĂšre Ă  rĂ©cupĂ©rer les valeurs des variables d’environnement. Le test de la commande getenv(“PATH”) retourne seulement une rĂ©ponse vide. Veuillez consulter la documentation d’installation :arrow_upper_right:pour savoir comment configurer PHP sur votre serveur, en particulier en cas d’utilisation de php-fpm.

Affichage en double de certaines valeurs dans le fichier de configuration php:

pm.max_children = 9
pm.max_children = 9

pm.start_servers = 2
pm.start_servers = 2

; Note: Used only when pm is set to ‘dynamic’
; Note: Mandatory when pm is set to ‘dynamic’
pm.min_spare_servers = 1
pm.min_spare_servers = 1

; Note: Used only when pm is set to ‘dynamic’
; Note: Mandatory when pm is set to ‘dynamic’
pm.max_spare_servers = 4
pm.max_spare_servers = 4

Sinon toujours les messages concernant la version de php et le non support des caractÚres codés sur 4 octets pour MySQL.
Malgré ces quelques erreurs, tout fonctionne normalement.

J’ai le mĂȘme message d’erreur mais j’ai pu rĂ©glĂ© le problĂšme en appliquant ceci et en redĂ©marrant PHP.

Il me semble que le fix n’a pas Ă©tĂ© reportĂ© dans la nouvelle configuration de PHP dĂ©ployĂ©e avec la derniĂšre version
 Je vais essayer de proposer une PR sur GitHub

3 Likes

Je venais de comparer il y a une petite heure avec l’ancien fichier et j’avais trouvĂ© la mĂȘme chose, ajout de env[PATH] = $PATH Ă  la ligne 395 puis:

yunohost service restart php7.0-fpm

J’en ai profitĂ© pour supprimer les lignes en doublon, bien que celles-ci n’ont pas l’air d’avoir de consĂ©quences.

2 Likes

Idem chez moi: apparition du mĂȘme message d’avertissement de php-fpm suite Ă  la mise Ă  jour vers nextcloud 15.0.14

Ces derniùres erreurs me pose la question de faire la maj 


New testing release :tada:

This release really need to be tested, please give us feedback

sudo yunohost app install https://github.com/YunoHost-Apps/nextcloud_ynh/tree/testing --debug
or
sudo yunohost app upgrade nextcloud -u https://github.com/YunoHost-Apps/nextcloud_ynh/tree/testing --debug
5 Likes

Upgraded smoothly, everything is working on my side.

Upgrade fine for me :slight_smile:

I have just a new warning in the admin interface

La limite de mémoire PHP est inférieure à la valeur recommandée de 512 Mo.

Any idea for this ?

Will be fixed with upcoming 18.0.2 update :wink:

2 Likes

Hi !

Thanks for the update ! The update went fine for me too. But in the Nextcloud Administration > Overview page, I see some error messages :

There are some errors regarding your setup.

    It was not possible to execute the cron job via CLI. The following technical errors have appeared:
        PHP module zip not installed. Please ask your server administrator to install the module.

The thing is, the package of the module is installed as indicated with this command :

$ apt list --installed | grep -i php | grep -i zip

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

php-zip/oldstable,now 1:7.0+49 all [installed,auto-removable]
php7.0-zip/unknown,now 7.0.33-25+0~20200225.32+debian9~1.gbpa11893 amd64 [installed,auto-removable]
php7.3-zip/unknown,now 7.3.15-4+0~20200224.55+debian9~1.gbpbea824 amd64 [installed,automatic]

On a side note, I don’t know if it matters, but you can see that the php7.0-zip package is marked as auto-removable. An apt autoremove command would remove these packages : libtidy5 php-zip php7.0-zip.

Would someone have an idea about this ?

Edit :
The error message disappeared. In that case, you can ignore this message.

Bonjour,

Sur la version Testing 3.7.4 de YunoHost je viens de faire l’installation de Nextcloud dans la version stable actuelle soit la 15.0.14.

[edit] sur mon Raspberry Pi 3 B (environ une grosse-grosse 1/2 heure avec 2 Go de swap)

J’ai ensuite appliquĂ© la mise Ă  niveau vers la version 18.0.1 Testing.
Effectivement, les 2 seuls avertissements dans Nextcloud sont :

  • la limite PHP infĂ©rieure Ă  512 Mo (qui sera corrigĂ© dans la version suivante) ;
  • le codage des caractĂšres sur 4 octets non supportĂ©.

[edit 2] mise à niveau réussi sur une VM à partir de YunoHost Stable 3.6 et Nextcloud 15.0.14.

[edit 3] mise Ă  niveau rĂ©ussi sur mon VPS Ă  partir de YunoHost Stable aprĂšs une frayeur : passage en mode maintenance de l’instance Nextcloud. J’ai tentĂ© le reboot, rien de mieux. Finalement, j’ai Ă©ditĂ© le fichier config.php et j’ai passĂ© la maintenance => true Ă  maintenance => false. En dehors de ça j’ai dĂ» mettre Ă  jour des Applications propres Ă  Nextcloud, ainsi qu’en rĂ©activer certaines comme par exemple Agenda/Calendar.

nano /var/www/nextcloud/config/config.php

Source : https://forums.ouvaton.coop/t/resolu-instance-bloquee-lors-de-mise-a-jour-de-nextcloud/1218/2

Bravo @JimboJoe @Maniack_Crudelis @Kayou ainsi qu’à l’équipe !

Merci !

ppr

2 Likes

Hello,

Update done to the testing branch. Everything went smoothly :slight_smile:

Many thanks for this work !

Upgrade went ~okay on my side. Encountered a few issues unrelated to the app itself :

  • I’m on a RPi2, upgrading from 15.x. The upgrade process made my RPi2 explode (it stopped answering requests except pings, logs shows that oom_reaper went full rampage all night long). I strongly suspect this is due to the lack of swap.
  • Reran the upgrade later, ran into a bug related to the permission system, fix submitted here
  • Now I’m on 18.x, have the same warnings that @ppr but apart from this, sounds good :+1:

As a side note, here’s an extract from the upgrade log :

Info : [############........] > Upgrading nextcloud...
Info : Upgrade to nextcloud 16.0.0
Info : '/tmp/tmp.o7DtytDUX6' wasn't deleted because it doesn't exist.
Attention :  Starting ...
Attention :     0/0 [>---------------------------]   0% Starting ...
Info : Upgrade to nextcloud 17.0.0
Info : '/tmp/tmp.rdknRmctgR' wasn't deleted because it doesn't exist.
Attention :     0/0 [>---------------------------]   0% Starting ...
Info : Upgrade to nextcloud 18.0.0
Info : '/tmp/tmp.29CrBZwrH3' wasn't deleted because it doesn't exist.
Attention :     0/0 [>---------------------------]   0% Starting ...
Attention :     0/0 [>---------------------------]   0% Starting ...
Attention :     0/0 [>---------------------------]   0%warning: commands will be executed using /bin/sh
Info : Upgrade to nextcloud 18.0.1
Attention : job 6 at Sun Mar 15 22:16:00 2020
Info : '/tmp/tmp.Gfa5pU5a3E' wasn't deleted because it doesn't exist.
Info : [############+++.....] > Reconfiguring nextcloud...

I don’t know if that’s easy to remove, but several of those messages are confusing ("Starting ..." wut ? and it just sit at 0% o.O 
 then at the end “Attention : [current date]”, wtf ?)

Anyway, cheers for the huge work :+1:

1 Like

Sur mon VPS, la mise Ă  jour (depuis la derniĂšre version stable) s’est trĂšs bien passĂ©e, Ă  part un petit blocage, cf dĂ©tails ci-dessous :

  1. Mise à jour effectuée, pas de mode maintenance, tout est parfait
  2. Je vais dans le menu applications pour mettre à jour et réactiver certaines apps
  3. Une des activations fait planter nextcloud, je rafraĂźchis et me retrouve en mode maintenance
  4. Je désactive le mode maintenance dans le fichier var/www/nextcloud/config/config.php
  5. ProblÚme réglé, Nextcloud à jour et fonctionnel

S’il n’y avait pas eu ce blocage en mode maintenance la sĂ©quence Ă©tait parfaite.
L’interface d’administration me remonte quatre avertissements en tout :

  • La limite de mĂ©moire PHP est infĂ©rieure Ă  la valeur recommandĂ©e de 512 Mo.

  • MySQL est utilisĂ©e comme base de donnĂ©es mais ne supporte pas les caractĂšres codĂ©s sur 4 octets. Pour pouvoir manipuler les caractĂšres sur 4 octets (comme les Ă©moticĂŽnes) sans problĂšme dans les noms de fichiers ou les commentaires par exemple, il est recommandĂ© d’activer le support 4 octets dans MySQL. Pour plus de dĂ©tails, lisez la page de documentation Ă  ce sujet

  • La configuration du serveur web ne permet pas d’atteindre “/.well-known/caldav”. Vous trouverez plus d’informations dans la documentation.

  • La configuration du serveur web ne permet pas d’atteindre “/.well-known/carddav”. Vous trouverez plus d’informations dans la documentation.

Les deux premiers ont l’air normaux d’aprĂšs les messages ci-dessus, et les deux derniers sont toujours les mĂȘmes que je me traĂźne depuis trois ou quatre mises Ă  jour, sans avoir jamais rĂ©ussi Ă  les faire disparaĂźtre.

Quoi qu’il en soit merci pour ce travail impressionnant, c’est gĂ©nial d’ĂȘtre de nouveau Ă  jour ! J’ai un sentiment d’interface Nextcloud lĂ©gĂšrement plus rapide mais il y a peut-ĂȘtre un petit effet placebo.

Petite mise Ă  jour, je ne parviens pas Ă  installer l’application “Community Document Server”, nĂ©cessaire pour faire tourner OnlyOffice. Apparemment c’est liĂ© Ă  la mĂ©moire allouĂ©e Ă  PHP. Vu dans les journaux :

Allowed memory size of 134217728 bytes exhausted (tried to allocate 315857416 bytes) at /var/www/nextcloud/lib/private/Installer.php#278

Cette fonctionnalitĂ© n’est pas disponible sur les architectures arm. De plus cette application est assez lourde, j’ai eu du mal Ă  la tĂ©lĂ©charger Ă©galement Ă  cause d’un timeout de l’interface

Édit: C’est visiblement pas ça :slight_smile:

1 Like

Pour passer ce message d’erreur, il faut mettre une valeur supĂ©rieure Ă  301 Mo (c’est plus ou moins ce que ton message d’erreur indique) pour la variable memory_limit (genre 512 Mo) dans le fichier /etc/php/7.3/fpm/php.ini.

Edit : ce soucis sera rĂ©solu avec le prochain upgrade de l’app.

1 Like