[Official topic] CryptPad

CryptPad for YunoHost

Overview

CryptPad is a privacy-friendly alternative to popular office tools and cloud services. All content stored in CryptPad is encrypted before being sent, which means that no one can access your data unless you give them the keys.

Shipped version: 3.18.1

Screenshots

Demo

Links


New testing release for CryptPad :tada:

  • Shipped version: 3.18.1
sudo yunohost app install https://github.com/YunoHost-Apps/cryptpad_ynh/tree/testing --debug
ou
sudo yunohost app upgrade cryptpad -u https://github.com/YunoHost-Apps/cryptpad_ynh/tree/testing --debug
3 Likes

There was an already official topic I made here : Paquet Cryptpad/Cryptpad Package It’s a bit old… but if we do a new one, it’s better to add again the introduction to the app.

New testing release for CryptPad :tada:

  • Shipped version: 3.19.0
sudo yunohost app install https://github.com/YunoHost-Apps/cryptpad_ynh/tree/testing --debug
ou
sudo yunohost app upgrade cryptpad -u https://github.com/YunoHost-Apps/cryptpad_ynh/tree/testing --debug
1 Like

New stable release :1st_place_medal:

  • 18 july 2020 - #44
    • Upgrade to upstream version 3.19.1
    • Fix installation
    • Upgrade package scripts

New testing release :2nd_place_medal:

It doesn’t work out of the box for now, it doesn’t recognize correctly something about path in the url
Do we need to create a dedicated subdomain for it ?

CryptPad cannot run in a subfolder, you need a dedicated domain or sub-domain.

Mmmmh okey that’s why. Thanks for the clarification

New stable release :tada:

1 Like

can someone help me what I should put in config.js to become admin? I can’t seem to figure it out…

/*
 *  CryptPad contains an administration panel. Its access is restricted to specific
 *  users using the following list.
 *  To give access to the admin panel to a user account, just add their user id,
 *  which can be found on the settings page for registered users.
 *  Entries should be strings separated by a comma.
 */
/*
adminKeys: [
        //"https://my.awesome.website/user/#/1/cryptpad-user1/YZgXQxKR0Rcb6r6CmxHPdAGLVludrAF2lEnkbx1vVOo=",
    ],
  • Should I keep the two leading forward-dashes?
  • do I replace cryptpad-user1 with the my username?
  • or do I only replace the crypto-code?
  • is a cryptpad-service restart in YNH enough to load the updated config.js?
  • are extra admin added áfter the comma, but before the ]?

So many variables… Thnx for help!

Hello @dosch
here are some answers:

Should I keep the two leading forward-dashes?

No

do I replace cryptpad-user1 with the my username?
or do I only replace the crypto-code?

The crypto-code is the full address between the quotes

is a cryptpad-service restart in YNH enough to load the updated config.js?

Yes

are extra admin added áfter the comma, but before the ]?

Yes

1 Like

thnx @ericg.

I ditched the dashes, restarted the service and obeyed the commas.

But the crypto-code/full address I get from the settings in cryptpad is formatted as:

[emailadres@emailadres/r4nD0ms7rY|\|g=]

while the cryptocode in config.json is formatted as

"https://my.awesome.website/user/#/1/cryptpad-user1/r4nD0ms7rY|\|g=",

So I am still somewhat at a loss which part I have to replace with the code from my personal settings page. What is the magic combination of the full address that should go between the quotes?

[emailadres@emailadres/r4nD0ms7rY||g=]

mmh … that doesn’t look like the expected key …
To find your public key:
Go to your account (top right) > Profil > VIEW MY PROFIL > COPY PUBLIC KEY

1 Like

I have no idea anymore what I am doing wrong.

  1. I took the key from the place you told me (indeed, a different format)
  2. pasted it in between the brackets.
/*
    adminKeys: [
"https://docs.domain.tld/admin/user/#/1/dosch/FtgvqJaUafewirkhqhRKCNPHsO3KgHICzcVqCQc4=",
]
*/
  1. restarted the Cryptpad service in YNH
  2. open https://docs.domain.tld/admin/ and get an error: Only administrators can access this page

Just to be sure. Have you removed /* and */ which surrounds the adminKeys variable

/*
    adminKeys: [
"https://docs.domain.tld/admin/user/#/1/dosch/FtgvqJaUafewirkhqhRKCNPHsO3KgHICzcVqCQc4=",
]
*/



adminKeys: [
"https://docs.domain.tld/admin/user/#/1/dosch/FtgvqJaUafewirkhqhRKCNPHsO3KgHICzcVqCQc4=",
],

and leave the comma at the end after ]…

1 Like

I had not… :pensive:

thank you for your patience. It now works.

ps. if the @moderators can move (or delete) my issues here, I think it would be a good idea. It clutters the topic and it painfully shows my ignorance :blush: