[Official app] Synapse

fr
en

#41

Hi !
Does Synapse work on a RPi 3B+ ? Because it’s an ARMv7 board
Thx !


#42

Hello, normally it should work on all architecture. There are just for ARMv7 a prebuilt package to make the installation quicker. But it’s not necessary.

I you have an issue could report your issue here https://github.com/YunoHost-Apps/synapse_ynh/issues


#43

New Update available for Synapse

  • 19 Nov #86
    • Update to synapse 0.33.8

#44

New Testing available for Synapse

  • 23 Nov #89
    • Update to synapse 0.33.9

#45

New Update available for Synapse

  • 11 Dec #89
    • Update to synapse 0.33.9

#46

New Testing available for Synapse

  • 04 Jan 2019 #94
    • Update to synapse 0.34.0
    • Migrate to python 3

Problem during the synapse update
#47

New Testing available for Synapse

  • 11 Jan 2019 #97
    • Update to synapse 0.34.0.1
    • Fix an important security issue described here.

Please upgrade your server as quickly as possible from the testing branch to fix the security issue. You can use this command to do that:
For install

sudo yunohost app install https://github.com/YunoHost-Apps/synapse_ynh/tree/testing

For upgrade

sudo yunohost app upgrade synapse -u https://github.com/YunoHost-Apps/synapse_ynh/tree/testing

#48

New update available for Synapse

  • 19 Jan 2019 #97
    • Update to synapse 0.34.0.1
    • Fix an important security issue described here.
  • 19 Jan 2019 #99
    • Fix venv setup

Please upgrade your server as quickly as possible if it’s not already done.


#49

hello @Josue

I just updated my Synapse server with a green SUCCESS synapse has been upgraded

But I noticed several error during the process that I wanted to report to you.
You’ll find these at https://paste.yunohost.org/ejofimeziw.lua

Hope this can help !

Thanks again for your great work !


#50

Thanks,

Can you try this branch https://github.com/YunoHost-Apps/synapse_ynh/tree/fix_wheel_dependances ?


#51

New Testing available for Synapse

  • 24 Jan 2019 #101
    • Fix wheel dependance

#52

New Update available for Synapse

  • 11 Feb #102
    • Fix python wheel dependance

#53

New Testing available for Synapse

  • 12 Feb 2019 #104
    • Update to synapse 0.99

Note that with this new version need a valid TLS certificate for the domain used by synapse. To do that you can refer to the documentation here : https://yunohost.org/#/certificate_en


#54

Awesome app! Thanks for packaging and maintaining! :+1: :smile:

In the description it says:

We do not recommend running Riot from the same domain name as your Matrix
homeserver (synapse).

Does that mean it needs to be a completely different domain like domainA.com and B-domian.com or is it secure enough to have different subdomains like synapse.domain.com and riot.domain.com?


#55

Hello,

I think synapse.domain.com and riot.domain.com should be enought.


#56

I very much appreciate the quick answer! Thank you! :grinning: :+1:


#57

New Testing available for Synapse

  • 08 Mars 2019 #110
    • Update to synapse 0.99.2
  • 08 Mars 2019 #106
    • Setup Fail2ban
  • 08 Mars 2019 #103
    • Update doc for federation

#58

New Testing available for Synapse

  • 10 Mars 2019 #69
    • Add config pannel

#59

Hello,

New version available for synapse:

  • 18 Mars 2019 #104
    • Update to synapse 0.99
  • 18 Mars 2019 #110
    • Update to synapse 0.99.2
  • 18 Mars 2019 #106
    • Setup Fail2ban
  • 18 Mars 2019 #103
    • Update doc for federation
  • 18 Mars #69
    • Add config pannel

It’s really important to update your instance if it’s not already done, because only this new release will compatible with for the federation with the next synapse version (1.0).

Note that with this new version need a valid TLS certificate for the domain used by synapse. To do that you can refer to the documentation here : https://yunohost.org/#/certificate_en

You can check that your instance is compatible with for the federation here : https://www.arewereadyyet.com/


MAJ synapse 0.99 en échec
#60

Update done… so ready for Matrix 1.0 !
:wink:

Thanks @Josue