[Official app] Roundcube


That’s the restoration log Gofannon, could you please send the complete log?


Are you sure? I believe I took the right log by looking in the admin panel

If not, which log or information do you need ?


The complete upgrade log.
The end of the log is only about removing then restoring the app.


Roundcube has been upgraded. It should have been a temporary connection issue. My bad


New testing release :tada:

1 Like

I’m wondering if someone had a try at that testing release…? :thinking:



Je reproduis le même problème qu’expliqué ici Roundcube doesn't send email, but Mail works :

  • ok en réception ;
  • échec en envoi : le clic sur le bouton envoyé ne fait rien et on reste avec le mail ouvert qui ne part pas. Ça ne bascule pas sur un autre écran de l’application et le message non envoyé ne va même pas dans brouillon.

J’ai fait le test avec la version 1.3.9 testing sur un Raspberry Pi 3B avec YunoHost
J’ai aussi vérifié que les ports étaient bien ouverts : RAS.

Sinon, entre l’application K-9 Mail sous Android et l’application Rouncube, il semble qu’il n’y ai pas de synchronisation entre les dossiers des éléments envoyés, corbeille, … de K-9 Mail et Roundcube.
Comme s’il y avait un problème de droit et/ou d’accès avec Roundcube, et Rainloop semble bloquer aussi.


1 Like

En ce qui concerne K-9 Mail il suffit d’associer les bons dossiers en allant dans les paramètres du compte, sinon l’application stocke ces dossiers en local.


@ppr Did you try with the testing release?

We didn’t get any feedback so far on the testing release… Is anyone interested in a new release? :thinking:


Hello JimboJoe,

Quickly I’ve apply this command on my Raspberry Pi : sudo yunohost app upgrade roundcube -u https://github.com/YunoHost-Apps/roundcube_ynh/tree/testing --debug
The problem is always there :frowning:The send button is inactive and the save button seems to be a little active because the circle turning at the bottom of the web page but don’t do anything else.


1 Like

Hi @JimboJoe ,

So, i’ve remove roundcube from my Raspberry Pi and i’ve launch this command and it works now :slight_smile:

sudo yunohost app install https://github.com/YunoHost-Apps/roundcube_ynh/tree/testing --debug

I’ll try to remove roundcube in order to reinstall it from the stable version to upgrade the testing … keep in touch.

Edit :
Upgrade the latest testing from the latest stable version don’t work.

sudo yunohost app upgrade roundcube -u https://github.com/YunoHost-Apps/roundcube_ynh/tree/testing --debug

Had to uninstall roundcube (stable or testing) then reinstall the latest testing.
I have not test the CardDAV or Enigma options.


1 Like

Hello, i’ve noticed that on roundcube 1.3.8: when i double click on a msg nothing happens (msg should open in the same window by default), noticed had two yunohost panels at practicaly the same place too so tried to empty the cache and so on … but still the same.
Today i’ve modified /etc/nginx/conf.d/thebullet.ovh.d/roundcube.conf by commenting include conf.d/yunohost_panel.conf.inc; and now it works but of course i have no panel anymore.
The panel works with my others apps…
It’s the same with roundcube 1.3.9

1 Like

thanks @mrmars!
@ppr could you please try @mrmars’s workaround to see if that fixes it on your instance as well…?



I’ve applying on the last stable, restart nginx but nothing. Then reboot my Raspberry Pi but nothing too.

So i’ve upgrade to the last testing and apply the trick but nothing better and i’ve lost the floating YunoHost’s Square and had to go into the address bar in order to return on the user web panel. The upgrade restore the conf file and uncommented the line.

Finally, i’ve unistall Rouncube and reinstall from the lastest testing branch, the conf file was restore and the line from the trick still uncommented and it works (send, receive and floating YunoHost’s square on).




The upgrade failed on my Raspberry Pi 3 B where the CI Package Check run on.
Maybe it’s because my Roundcube’s version was in testing branch when i’ve upgraded it.
The return of the web admin’s panel here :



As the log says “OSError: [Errno 11] Resource temporarily unavailable”, did you retry ?

1 Like

I’ve just retry and it’s alright now.
Upgrade succeded !
Thanks :slight_smile:



New stable release:


New testing available

  • 26 May 2019 - #66
    • Add php-curl as a dependency
    • Upgrade composer before using it
    • Add a change_url script
    • Global upgrade of the package
sudo yunohost app install https://github.com/YunoHost-Apps/roundcube_ynh/tree/testing --debug
sudo yunohost app upgrade roundcube -u https://github.com/YunoHost-Apps/roundcube_ynh/tree/testing --debug


Some quick returns from stable YunoHost on my Raspberry Pi 3 :

  • I’ve upgrade Roundcube : it works.
  • I’ve test to send a mail : it works.
  • I’ve test to receive a mail : it works.
  • I’ve test to draft a mail : it works.
  • I’ve test to delete the received, send and drafted mails : it works.

Thanks Yuno’s Team !


1 Like