[Official app] Nextcloud

fr
en

#122

New testing release :tada:


#123

Cool ! J’en dĂ©duis qu’on passera directement de la 13.0.6 Ă  la 15, c’est bien cela ?
Encore merci pour tout ce travail :slight_smile:


#124

Oui, surtout parce que j’ai oubliĂ© de releaser la 14.0.4 en stable avant de faire la testing :blush:


#125

Non, j’utilise massivement ces mots de passe, le SSO ne pose pas de soucis.


#126

Upgrade réalisé depuis la testing release 14.04 sans encombres.
Le lifting de l’interface est lĂ©ger mais sympa, ça fait plus moderne !

Pour info, j’ai quelques erreurs remontĂ©es dans l’interface admin.


#127

Hello !

  • Pour le contrĂŽle d’intĂ©gritĂ©, il te faudrait le dĂ©sactiver (je ne saurais te dire pourquoi ce paramĂštre a changĂ© chez toi): dans /var/www/nextcloud/config/config.php, "integrity.check.disabled": true.
  • Pour les accĂšs .well-known, es-tu sĂ»r de ne pas avoir une application sur le mĂȘme domaine qui sert dĂ©jĂ  ces URL (il y a un contrĂŽle lĂ -dessus Ă  l’installation/mise Ă  jour de Nextcloud) ?
  • Pour les index manquants dans la base de donnĂ©es, une opĂ©ration de maintenance est planifiĂ©e en fin d’upgrade pour lancer ce qui est indiquĂ©. Je ne sais pas si tu avais affichĂ© ces informations peu aprĂšs la mise Ă  jour
 et donc si le message est toujours prĂ©sent dĂ©sormais
 ?

#128

Hello @JimboJoe, merci pour ta réponse et pour ton aide.

  • Pour le contrĂŽle d’intĂ©gritĂ©, c’est assez bizarre, je suis allĂ© vĂ©rifier dans le fichier en question et le paramĂštre Ă©tait dĂ©jĂ  sur true. AprĂšs avoir cliquĂ© sur le lien “Rescanner” l’alerte a disparu.
  • Pour les accĂšs .well-known, je ne suis pas sĂ»r de comprendre ta question ? Je n’ai que nextcloud installĂ© sur cette url qui est du type nuage.monserveur.fr
  • Pour les index manquants, presque 24h aprĂšs l’upgrade, j’ai toujours les mĂȘmes messages d’alerte. Faudrait-il que je fasse des opĂ©rations Ă  la main Ă  l’aide de phpMyAdmin ou d’une commande “php occ” ?

#129

bonjour,
je suis toujours avec le mĂȘme problĂšme Ă  l’installation 
 :confused:
Quelqu’un peu m’aider svp ?
merci d’avance : https://paste.yunohost.org/raw/ukixoyuqam
Install on : raspberry 3

H-py New Year


#130

Tu sembles avoir déjà un dossier /home/yunohost.app/nextcloud qui ne dispose pas des bons droits.
Si tu n’avais pas de donnĂ©es Ă  conserver, tu peux dĂ©placer ce dossier et retenter l’installation.


#131
  • Pour l’accĂšs .well-known, il peut y avoir un conflit avec une autre application sur le mĂȘme domaine et dĂ©clarant la mĂȘme URL (par exemple l’application baikal), d’oĂč le contrĂŽle Ă  l’installation. Cela ne semble pas avoir bien fonctionnĂ© dans ton cas

  • Pour les index manquant, c’est curieux
 as-tu une seule ou plusieurs instance de Nextcloud sur ton serveur ?

#132

Oui, mais malgrĂ© les suppresions de ces documents j’ai toujours une erreur 
 je commence a dĂ©sesperer d’installer nextcloud.
https://paste.yunohost.org/raw/xecovakoro

merci d’avances


#133

Tu veux bien dire que tu as supprimé le dossier /home/yunohost.app/nextcloud ?


#134

Oui, et du coup la nouvelle tentative a donné les nouveaux log présent dans mon dernier message.

last log : https://paste.yunohost.org/raw/xecovakoro


#135

La partie intéressante me semble là :

2019-01-08 16:02:53,798: DEBUG - + sudo -u nextcloud php occ --no-interaction --no-ansi maintenance:install --database mysql --database-name nextcloud --database-user nextcloud --database-pass ijLLUm9o0H2W7alEk9mfRLrr --admin-user admin --admin-pass hhMN8h --data-dir /home/yunohost.app/nextcloud/data
2019-01-08 16:02:54,703: DEBUG - Nextcloud is not installed - only a limited number of commands are available
2019-01-08 16:05:15,095: DEBUG - Nextcloud was successfully installed
2019-01-08 16:05:15,199: DEBUG - Création du répertoire « /home/nextcloud ».
2019-01-08 16:05:15,201: DEBUG - + exec_occ app:disable updatenotification
2019-01-08 16:05:15,202: DEBUG - + cd /var/www/nextcloud
2019-01-08 16:05:15,203: DEBUG - + exec_as nextcloud php occ --no-interaction --no-ansi app:disable updatenotification
2019-01-08 16:05:15,204: DEBUG - + local USER=nextcloud
2019-01-08 16:05:15,205: DEBUG - + shift 1
2019-01-08 16:05:15,206: DEBUG - ++ whoami
2019-01-08 16:05:15,207: DEBUG - + [[ nextcloud = root ]]
2019-01-08 16:05:15,208: DEBUG - + sudo -u nextcloud php occ --no-interaction --no-ansi app:disable updatenotification
2019-01-08 16:05:16,212: DEBUG - Your data directory is readable by other users
2019-01-08 16:05:16,213: WARNING - !!
2019-01-08 16:05:16,214: DEBUG - Please change the permissions to 0770 so that the directory cannot be listed by other users.

Dans la premiĂšre ligne, on demande de lancer l’installation de Nextcloud dans /home/yunohost.app/nextcloud, mais ce dernier rĂ©pond Création du répertoire « /home/nextcloud ».

Et puis plus tard, on a le problùme de droits


Tout de suite, aprÚs tes essais infructueux, le répertoire /home/yunohost.app/nextcloud existe-t-il et quels sont les droits dessus ?


#136

Hello @JimboJoe,

  • Pour les accĂšs .well-known, je n’ai que Nextcloud sur ce domaine du type “nuage.monserveur.fr”. J’avais installĂ© Baikal mais c’était il y a au moins un an et retirĂ© depuis. De plus, il n’était pas sur le mĂȘme domaine.
    Y a-t-il un moyen de réparer ceci manuellement ?
  • Pour les index manquants, j’ai rĂ©ussi Ă  tout remettre dans l’ordre avec
    sudo -u nextcloud php /var/www/nextcloud/occ db:add-missing-indices

#137


 et je viens de remarquer que sur mes deux serveurs, la deconnexion ne fonctionne pas ? (on “retombe” sur la page d’accueil)


#138

Bon, nouvelle surprise aujourd’hui, toujours sur la version de test 15.0.0.
Le serveur m’affiche ceci :


Tout fonctionnait parfaitement hier soir, je n’ai pas fait de manips sur le serveur depuis, bizarre.
Les applis sont en rade donc je pense que tout le serveur Nextcloud est “down”.
J’ai tentĂ© de redĂ©marrer le serveur sans succĂšs.


#139

ProblÚme résolu avec :
sudo apt-get install php7.0-zip

Quant Ă  comprendre pourquoi cette erreur subite alors que ça fonctionnait la veille et que mon deuxiĂšme serveur tourne nickel sous la mĂȘme version exactement



#140

Juste pour information, j’ai mis à jour vers la version testing ce matin avec les notes suivantes :

  • L’utilisation de la fonctionnalitĂ© d’envoi d’e-mails native de PHP n’est plus supportĂ©e. Merci de mettre Ă  jour les paramĂštres d’envoi d’e-mails de votre serveur
  • L’en-tĂȘte HTTP “X-Content-Type-Options” n’est pas configurĂ©e pour ĂȘtre Ă©gale Ă  “nosniff”. Ceci constitue un risque potentiel relatif Ă  la sĂ©curitĂ© et Ă  la vie privĂ©e Ă©tant donnĂ© qu’il est recommandĂ© d’ajuster ce paramĂštre.
  • L’en-tĂȘte HTTP “X-Download-Options” n’est pas configurĂ©e pour ĂȘtre Ă©gale Ă  “noopen”. Ceci constitue un risque potentiel relatif Ă  la sĂ©curitĂ© et Ă  la vie privĂ©e Ă©tant donnĂ© qu’il est recommandĂ© d’ajuster ce paramĂštre.
  • L’en-tĂȘte HTTP “X-Permitted-Cross-Domain-Policies” n’est pas configurĂ©e pour ĂȘtre Ă©gale Ă  “none”. Ceci constitue un risque potentiel relatif Ă  la sĂ©curitĂ© et Ă  la vie privĂ©e Ă©tant donnĂ© qu’il est recommandĂ© d’ajuster ce paramĂštre.
  • Vous utilisez actuellement PHP 7.0.33-0+deb9u1. Mettez Ă  jour votre version de PHP afin de tirer avantage des amĂ©liorations liĂ©es Ă  la performance et la sĂ©curitĂ© fournies par le PHP Group dĂšs que votre distribution le supportera.

Les premiĂšres (sauf la toute derniĂšre) sont affichĂ©s en jaune dans l’interface d’admin.

Sinon, tout a l’air de bien marcher.

Ah et les applications ont été désactivées à la mise à jour, mais aprÚs les avoir mises à jour et réactivées, tout marche nickel.


#141

J’ai Ă©galement eu Ă  rĂ©activer les applications manuellement