[Official app] Nextcloud

fr
en

#183

New stable release (at last!) :tada::tada::tada:

  • 20 Feb 2019 - #152
    • Upgrade to upstream version 15.0.4

    • Don’t use /tmp

    • fix #153

    • Apply recommended maintenance operations after upgrade

    • fix #138

    • Upgrade to upstream version 13.0.6 #134


#184

Upgrade done (13.0.6 To 15.0.4) !
No problem for now.
Congratulations!

–
Mise à jour faite, aucun problùme pour l’instant.
FĂ©licitations !


#185

Upgrade rĂ©alisĂ© Ă  l’instant de la version 13.0.6 vers 15.0.4.
Tout semble s’ĂȘtre correctement dĂ©roulĂ©, seul php-fpm a dĂ» ĂȘtre relancĂ© manuellement.

Au niveau des avertissements dans l’interface admin de Nextcloud, seule l’alerte sur la version 7.0.33 de php subsiste (mais je pense qu’il s’agit de l’alerte normale dĂ»e Ă  la version de php de Debian).

:+1:


#186

Bonjour,

J’ai un peu peur de faire la maj, je viens de testĂ© sur mon serveur de test et ca Ă  plantĂ© nextcloud avec la suppression de l’apps.

Es que ca vaut le coup de tenter une installation sur mon serveur de prod ?


#187

Comme pour toutes les questions de support, pour comprendre et donner un avis, il faudrait les logs 



#188

Ca te paraĂźt logique a toi ^^, je demande l’avis avant toute chose et rentrĂ© dans le dĂ©tail :wink:
Et dans cette situation je ne sais pas quel log donner ?


#189

Bonjour, tu peux aller sur l’interface d’administration et donner les logs qui sont dans : Outils, Logs, et là choisir la ligne correspond à la mise à jour de Nextcloud. Eventuellement tu peux partager tes logs avec Yunopaste.
Bonne journée,
NH


#190

Bonjour,
j’ai essayĂ© de commenter le fichier de configuration mais cela ne fait rien j’ai mĂȘme essayĂ© de relancer le service nginx j’ai toujours mes warning dans cette version 15.0.4:

L’en-tĂȘte HTTP “X-Content-Type-Options” n’est pas configurĂ©e pour ĂȘtre Ă©gale Ă  “nosniff”. Ceci constitue un risque potentiel relatif Ă  la sĂ©curitĂ© et Ă  la vie privĂ©e Ă©tant donnĂ© qu’il est recommandĂ© d’ajuster ce paramĂštre.
L’en-tĂȘte HTTP “X-Frame-Options” n’est pas configurĂ©e pour ĂȘtre Ă©gale Ă  “SAMEORIGIN”. Ceci constitue un risque potentiel relatif Ă  la sĂ©curitĂ© et Ă  la vie privĂ©e Ă©tant donnĂ© qu’il est recommandĂ© d’ajuster ce paramĂštre.
L’en-tĂȘte HTTP “X-Download-Options” n’est pas configurĂ©e pour ĂȘtre Ă©gale Ă  “noopen”. Ceci constitue un risque potentiel relatif Ă  la sĂ©curitĂ© et Ă  la vie privĂ©e Ă©tant donnĂ© qu’il est recommandĂ© d’ajuster ce paramĂštre.
L’en-tĂȘte HTTP “X-Permitted-Cross-Domain-Policies” n’est pas configurĂ©e pour ĂȘtre Ă©gale Ă  “none”. Ceci constitue un risque potentiel relatif Ă  la sĂ©curitĂ© et Ă  la vie privĂ©e Ă©tant donnĂ© qu’il est recommandĂ© d’ajuster ce paramĂštre.

J’ai Ă©galement le warning php en plus.

Une idĂ©e de ce que j’aurai pu oublier dans la manip?
J’ai essayĂ© avec un # puis avec ## mais sans succĂšs.

Ces warning sont-ils critiques?

Merci


#191

Non je ne pense pas

A mon avis, ta conf nginx ne suit pas la conf recommandée.

Tu devrais vĂ©rifier ce qu’il en est Ă  l’aide de yunohost service regen-conf nginx --dry-run -d

Et si tout ces changements te semblent ok, tu peux les appliquer à l’aide de yunohost service regen-conf nginx --force


#192

Merci Aleks.

Je n’ai plus les warnings (à part le php
)
Quel support !


#193

Hello,
J’ai une erreur pendant l’upgrade car php-fpm n’arrive pas à se recharger, ce qui fait à la fin planter nextcloud :

root@YunoHost:~ # tail -n 12 /var/log/php7.0-fpm.log
[10-Mar-2019 14:23:09] NOTICE: Reloading in progress ...
[10-Mar-2019 14:23:10] NOTICE: reloading: execvp("/usr/sbin/php-fpm7.0", {"/usr/sbin/php-fpm7.0", "--nodaemonize", "--fpm-config", "/etc/php/7.0/fpm/php-fpm.conf"})
[10-Mar-2019 14:23:11] WARNING: [pool nextcloud] 'request_slowlog_timeout' is not supported on your system
[10-Mar-2019 14:23:11] WARNING: [pool nextcloud] 'request_slowlog_timeout' is not supported on your system
[10-Mar-2019 14:23:11] NOTICE: using inherited socket fd=8, "/run/php/php7.0-fpm.sock"
[10-Mar-2019 14:23:11] NOTICE: using inherited socket fd=8, "/run/php/php7.0-fpm.sock"
[10-Mar-2019 14:23:11] NOTICE: using inherited socket fd=7, "/run/php/php7.0-fpm-nextcloud.sock"
[10-Mar-2019 14:23:11] NOTICE: using inherited socket fd=7, "/run/php/php7.0-fpm-nextcloud.sock"
[10-Mar-2019 14:23:11] ERROR: An another FPM instance seems to already listen on /var/run/php/php7.0-fpm-nextcloud.sock
[10-Mar-2019 14:23:11] ERROR: An another FPM instance seems to already listen on /var/run/php/php7.0-fpm-nextcloud.sock
[10-Mar-2019 14:23:11] ERROR: FPM initialization failed
[10-Mar-2019 14:23:11] ERROR: FPM initialization failed

Pourtant, si je relance le service avec systemctl start php7.0-fpm, il redémarre tout de suite



#194

New testing release

sudo yunohost app install https://github.com/YunoHost-Apps/nextcloud_ynh/tree/testing --debug
or
sudo yunohost app upgrade nextcloud -u https://github.com/YunoHost-Apps/nextcloud_ynh/tree/testing --debug

#195

New testing release

sudo yunohost app install https://github.com/YunoHost-Apps/nextcloud_ynh/tree/testing --debug
or
sudo yunohost app upgrade nextcloud -u https://github.com/YunoHost-Apps/nextcloud_ynh/tree/testing --debug

#196

Hello,

Upgrade from v15.0.4 stable to v15.0.5 testing without any problem.
A backup archive have been made before applying the upgrade.
No need to re-enable my Agenda, Contacts and SMS apps.

Edit :
J’ai essayĂ© d’uploader un fichier mais j’ai un message au centre de l’écran du PC sous la barre d’adresse qui me dit qu’il n’y a plus d’espace.
Je suis Ă©tonnĂ© car le fichier fait 60 Ko et j’ai de la marge sur le serveur car j’ai 10 Go de libre.
J’ai regardĂ© dans les paramĂštres de Nextcloud et lĂ  il y a ce message malgrĂ© un redĂ©marrage de php7-fpm

Il y a quelques avertissements concernant votre configuration.

  • PHP ne semble pas ĂȘtre configurĂ© de maniĂšre Ă  rĂ©cupĂ©rer les valeurs des variables d’environnement. Le test de la commande getenv(“PATH”) retourne seulement une rĂ©ponse vide. Veuillez consulter la documentation d’installation :arrow_upper_right:pour savoir comment configurer PHP sur votre serveur, en particulier en cas d’utilisation de php-fpm.
  • La configuration du serveur web ne permet pas d’atteindre “/.well-known/caldav”. Vous trouverez plus d’informations dans la documentation.
  • La configuration du serveur web ne permet pas d’atteindre “/.well-known/carddav”. Vous trouverez plus d’informations dans la documentation.
  • Vous utilisez actuellement PHP 7.0.33-0+deb9u3. Mettez Ă  jour votre version de PHP afin de tirer avantage des amĂ©liorations liĂ©es Ă  la performance et la sĂ©curitĂ© fournies par le PHP Group dĂšs que votre distribution le supportera.

Que peux-tu me conseiller Ă  propos de ces remarques sur php7-fpm ?

Edit 2 @JimboJoe :
Alors j’arrive à uploader le fichier depuis mon smartphone avec l’application, mais pas depuis mon navigateur : “Espace disponible insuffisant”.
J’ai essayĂ© de dĂ©commenter env[PATH] = /usr/local/bin:/usr/bin:/bin et/ou clear_env = no suivi d’un redĂ©marrage de php-fpm et un rechargement de nginx sans succĂšs :frowning:

Thank a lot for the great job you’ve done once again <3

ppr


#197

Hello,
Can you please share the precise error message (or screenshot) and see if there is relevant logs in /home/yunohost.app/nextcloud/data/nextcloud.log, /var/log/nginx/yourdomain-errors.log or /var/log/php7.0-fpm.log?