No more access in NextCloud

In NextCloud, I wanted to verify some configuration.

Then I clicked on ‘Advanced’ (in top right) and I unchecked “Configuration Active”. This is something I should not have done :’(

I did not save any page and I got disconnected when moving to another page. Now I am unable to log-in with my credentials. What should I do to revert this situation?

Thank you in advance for your support.

Can you try this solution?

Hi JimboJoe,
I have tried the mentioned solution. When I am logging I am getting now the following error:

504 Gateway Time-out

Should I restart any service?

Well, I would say nginx, but I don’t see any reason for this.
Do you have any interesting log entries in /home/ or /var/log/nginx/yourdomain-errors.log ?

I don’t see anything special in logs. But at the same time I am not an expert reading logs. Should I insert a complete log here anyway, apart of my 2 following explanations?

  1. From what I see in the
    there is various message:login failed
    for different pages, as for example here: "url":"\/nextcloud\/index.php\/apps\/theming\/js\/theming?v=0","message":"Login failed
    This means that the connection with the suppose SSO is not working (if I am not wrong). Should I run again the following command?
  1. Now from what I see In my
    I can see:
    *2 upstream timed out (110: Connection timed out) while reading response header from upstream
    request: "GET /nextcloud/ HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm-nextcloud.sock"
    by example or for
    request: "POST /nextcloud/index.php/login HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm-nextcloud.sock"
    Is this something to do with php5-fpm-nextcloud.sock?
    At least I assume this is not a nginx problem but I problem with connection (SSO or something), right?

For information I have restarted 2 services using:

  • systemctl restart nginx.service
  • systemctl restart php5-fpm.service

and this issue is still actual.

Are you logging in from YunoHost portal or nextcloud login page?

I am logging from NextCloud login page.
But from the YunoHost page with the list of the available applications, when I clicked on the NextCloud button, the system tries to connect to the NextCloud application by default (using SSO I guess).

I have done both of these possibilities to enter into the NextCloud application. Without success, as described in the logs that I “analysed” (I am just a newbie). Should I annex the logs?

From the nextcloud documentation:
Configuration Active:
Enables or Disables the current configuration. By default, it is turned off. When Nextcloud makes a successful test connection it is automatically turned on.

So maybe this is more your LDAP config that has a pb?

Thank you for this update. Is that a way to reload or restart the LDAP service in YunoHost (if it exists)?

As far as I know, I did not touch any LDAP configuration. How can we further check the LDAP configuration ?

Hello guys,
How can I restart the LDAP configuration for NextCloud? I am still unable to connect to the application :-/