# No more access in NextCloud

**URL:** https://forum.yunohost.org/t/no-more-access-in-nextcloud/4170
**Category:** Support
**Tags:** english
**Created:** [January 20, 2018, 9:14pm UTC](https://forum.yunohost.org/t/no-more-access-in-nextcloud/4170 "2018-01-20T21:14:21Z")
**Posts on this page:** 11
**Page:** 1

<div class="post-metadata">

### Author: ![jef](https://forum.yunohost.org/letter_avatar_proxy/v4/letter/j/e5b9ba/32.png) [@jef](https://forum.yunohost.org/u/jef)
#### Post date: [January 20, 2018, 9:14pm UTC](https://forum.yunohost.org/t/no-more-access-in-nextcloud/4170/1 "2018-01-20T21:14:21Z")

</div>

Hello,  
In NextCloud, I wanted to verify some configuration.

- I went to Admin (last icon on top right and 2nd choice), I reached this page: [https://demo.yunohost.org/nextcloud/index.php/settings/admin](https://demo.yunohost.org/nextcloud/index.php/settings/admin)
- I clicked on LDAP / AD Integration (in the left menu), I reached [https://demo.yunohost.org/nextcloud/index.php/settings/admin/ldap](https://demo.yunohost.org/nextcloud/index.php/settings/admin/ldap)

Then I clicked on ‘Advanced’ (in top right) and I unchecked “Configuration Active”. This is something I should **not** have done :’(

I did not save any page and I got disconnected when moving to another page. Now I am unable to log-in with my credentials. What should I do to revert this situation?

Thank you in advance for your support.

---

<div class="post-metadata">

### Author: ![JimboJoe](https://forum.yunohost.org/user_avatar/forum.yunohost.org/jimbojoe/32/545_2.png) [@JimboJoe](https://forum.yunohost.org/u/JimboJoe)
#### Post date: [January 20, 2018, 9:32pm UTC](https://forum.yunohost.org/t/no-more-access-in-nextcloud/4170/2 "2018-01-20T21:32:05Z")

</div>

Hi,  
Can you try [this solution](https://forum.yunohost.org/t/fixed-sso-nextcloud-fail/3062/2?u=jimbojoe)?

---

<div class="post-metadata">

### Author: ![jef](https://forum.yunohost.org/letter_avatar_proxy/v4/letter/j/e5b9ba/32.png) [@jef](https://forum.yunohost.org/u/jef)
#### Post date: [January 21, 2018, 12:28am UTC](https://forum.yunohost.org/t/no-more-access-in-nextcloud/4170/3 "2018-01-21T00:28:34Z")

</div>

Hi JimboJoe,  
I have tried the mentioned solution. When I am logging I am getting now the following error:

> 504 Gateway Time-out

Should I restart any service?

---

<div class="post-metadata">

### Author: ![JimboJoe](https://forum.yunohost.org/user_avatar/forum.yunohost.org/jimbojoe/32/545_2.png) [@JimboJoe](https://forum.yunohost.org/u/JimboJoe)
#### Post date: [January 21, 2018, 8:14am UTC](https://forum.yunohost.org/t/no-more-access-in-nextcloud/4170/4 "2018-01-21T08:14:07Z")

</div>

Well, I would say nginx, but I don’t see any reason for this.  
Do you have any interesting log entries in `/home/yunohost.app/nextcloud/data/nextcloud.log` or `/var/log/nginx/yourdomain-errors.log` ?

---

<div class="post-metadata">

### Author: ![jef](https://forum.yunohost.org/letter_avatar_proxy/v4/letter/j/e5b9ba/32.png) [@jef](https://forum.yunohost.org/u/jef)
#### Post date: [January 21, 2018, 11:22am UTC](https://forum.yunohost.org/t/no-more-access-in-nextcloud/4170/5 "2018-01-21T11:22:48Z")

</div>

> [@JimboJoe](#):
>
> Do you have any interesting log entries in /home/yunohost.app/nextcloud/data/nextcloud.log or /var/log/nginx/yourdomain-errors.log ?

I don’t see anything special in logs. But at the same time I am not an expert reading logs. Should I insert a complete log here anyway, apart of my 2 following explanations?

1. From what I see in the  
`/home/yunohost.app/nextcloud/data/nextcloud.log`  
there is various `message:login failed`  
for different pages, as for example here:` "url":"\/nextcloud\/index.php\/apps\/theming\/js\/theming?v=0","message":"Login failed`  
&nbsp;  
This means that the connection with the suppose SSO is not working (if I am not wrong). Should I run again the following command?

> [@JimboJoe](#):
>
> Can you try this solution?

1. Now from what I see In my  
`/var/log/nginx/[sub-domain].nohost.me-error.log`  
I can see:  
`*2 upstream timed out (110: Connection timed out) while reading response header from upstream`  
for  
`request: "GET /nextcloud/ HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm-nextcloud.sock"`  
by example or for  
`request: "POST /nextcloud/index.php/login HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm-nextcloud.sock"`  
&nbsp;  
Is this something to do with `php5-fpm-nextcloud.sock`?  
At least I assume this is not a nginx problem but I problem with connection (SSO or something), right?

For information I have restarted 2 services using:

- `systemctl restart nginx.service`
- `systemctl restart php5-fpm.service`

and this issue is still actual.

---

<div class="post-metadata">

### Author: ![JimboJoe](https://forum.yunohost.org/user_avatar/forum.yunohost.org/jimbojoe/32/545_2.png) [@JimboJoe](https://forum.yunohost.org/u/JimboJoe)
#### Post date: [January 21, 2018, 2:41pm UTC](https://forum.yunohost.org/t/no-more-access-in-nextcloud/4170/6 "2018-01-21T14:41:07Z")

</div>

Are you logging in from YunoHost portal or nextcloud login page?

---

<div class="post-metadata">

### Author: ![jef](https://forum.yunohost.org/letter_avatar_proxy/v4/letter/j/e5b9ba/32.png) [@jef](https://forum.yunohost.org/u/jef)
#### Post date: [January 22, 2018, 6:53pm UTC](https://forum.yunohost.org/t/no-more-access-in-nextcloud/4170/7 "2018-01-22T18:53:37Z")

</div>

I am logging from NextCloud login page.  
But from the YunoHost page with the list of the available applications, when I clicked on the NextCloud button, the system tries to connect to the NextCloud application by default (using SSO I guess).

I have done both of these possibilities to enter into the NextCloud application. Without success, as described in the logs that I “analysed” (I am just a newbie). Should I annex the logs?

---

<div class="post-metadata">

### Author: ![Krakinou](https://forum.yunohost.org/user_avatar/forum.yunohost.org/krakinou/32/1702_2.png) [@Krakinou](https://forum.yunohost.org/u/Krakinou)
#### Post date: [January 23, 2018, 6:13am UTC](https://forum.yunohost.org/t/no-more-access-in-nextcloud/4170/8 "2018-01-23T06:13:59Z")

</div>

Hmmm  
From the nextcloud documentation: [https://docs.nextcloud.com/server/12/admin\_manual/configuration\_user/user\_auth\_ldap.html](https://docs.nextcloud.com/server/12/admin_manual/configuration_user/user_auth_ldap.html)  
Configuration Active:  
Enables or Disables the current configuration. By default, it is turned off. When Nextcloud makes a successful test connection it is automatically turned on.

So maybe this is more your LDAP config that has a pb?

---

<div class="post-metadata">

### Author: ![jef](https://forum.yunohost.org/letter_avatar_proxy/v4/letter/j/e5b9ba/32.png) [@jef](https://forum.yunohost.org/u/jef)
#### Post date: [January 23, 2018, 3:43pm UTC](https://forum.yunohost.org/t/no-more-access-in-nextcloud/4170/9 "2018-01-23T15:43:23Z")

</div>

Thank you for this update. Is that a way to reload or restart the LDAP service in YunoHost (if it exists)?

> [@Krakinou](#):
>
> So maybe this is more your LDAP config that has a pb?

As far as I know, I did not touch any LDAP configuration. How can we further check the LDAP configuration ?

---

<div class="post-metadata">

### Author: ![jef](https://forum.yunohost.org/letter_avatar_proxy/v4/letter/j/e5b9ba/32.png) [@jef](https://forum.yunohost.org/u/jef)
#### Post date: [February 2, 2018, 8:17pm UTC](https://forum.yunohost.org/t/no-more-access-in-nextcloud/4170/10 "2018-02-02T20:17:02Z")

</div>

Hello guys,  
How can I restart the LDAP configuration for NextCloud? I am still unable to connect to the application :-/

---

<div class="post-metadata">

### Author: ![Aleks](https://forum.yunohost.org/user_avatar/forum.yunohost.org/aleks/32/1704_2.png) [@Aleks](https://forum.yunohost.org/u/Aleks)
#### Post date: [January 18, 2023, 8:16pm UTC](https://forum.yunohost.org/t/no-more-access-in-nextcloud/4170/11 "2023-01-18T20:16:51Z")

</div>


