Nginx ne demarre plus nginx: [emerg] socket() [::]:80 failed (97: Address family not supported by protocol)


Matériel:Raspberry Pi à la maison

J’ai accès à mon serveur :En SSH

contexte particulier : systeme déporté sur un disque externe

Description du problème:

nginx ne démarre plus message d’erreur :

nginx: [emerg] socket() [::]:80 failed (97: Address family not supported by protocol)

une recherche sur ce message d’erreur fait etat de problème ipv6.

Le serveur est derrière une freebox qui utilise ipv6

Have you disabled ipv6 on your raspberry pi ?

Have you installed yunohost from raspbian or from yunohost rpi image ?

installation from yunohost rpi image.
I don’t remember if i have disabled ipv6.
In fact my provider now use ipv6 only.
in my registrar dns i’ve no aaaa adresse.
With yunohost admin it was possible to show this address ipv6.
But i don’t how to obtain this address via ssh


to get your ipv6

1 Like

Curl don’t work with subdomain

admin@cayra:~ $ curl
curl: (6) Could not resolve host:

Your ipv6 may be deactivated:

sysctl net.ipv6.conf.all.disable_ipv6

If it return net.ipv6.conf.all.disable_ipv6=1 configure it to 0

sysctl net.ipv6.conf.all.disable_ipv6=0
sysctl net.ipv6.conf.default.disable_ipv6=0

If it works, change permanently by editing the file /etc/sysctl.conf :

nano /etc/sysctl.conf

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.