# Nginx fails to start, related to ipv6

**URL:** https://forum.yunohost.org/t/nginx-fails-to-start-related-to-ipv6/21937
**Category:** Support
**Tags:** english
**Created:** [November 2, 2022, 11:24pm UTC](https://forum.yunohost.org/t/nginx-fails-to-start-related-to-ipv6/21937 "2022-11-02T23:24:24Z")
**Posts on this page:** 1
**Showing post:** 3

<div class="post-metadata">

### Author: ![Dams](https://forum.yunohost.org/letter_avatar_proxy/v4/letter/d/2acd7d/32.png) [@Dams](https://forum.yunohost.org/u/Dams)
#### Post date: [November 3, 2022, 9:50pm UTC](https://forum.yunohost.org/t/nginx-fails-to-start-related-to-ipv6/21937/3 "2022-11-03T21:50:57Z")

</div>

Right now I have written a script to disable ipv6 listening for ngnix. I would like to turn it into a hook. I have seen some samples from @metyun at [Share your "hooks" to apply custom configurations- Partagez vos "hooks" pour appliquer des configurations personnelles - #2 by metyun](https://forum.yunohost.org/t/share-your-hooks-to-apply-custom-configurations-partagez-vos-hooks-pour-appliquer-des-configurations-personnelles/17235/2) but I don’t know how to write a hook properly.

```auto
#!/bin/bash

# comment out lines containing ipv6 listening in nginx config files

sed -i "/listen \[::\]:/ s/^#*/#/" /etc/nginx/conf.d/domain.tld.conf
sed -i "/listen \[::\]:/ s/^#*/#/" /etc/nginx/conf.d/yunohost_admin.conf
sed -i "/listen \[::\]:/ s/^#*/#/" /etc/nginx/sites-available/default

```

---

_[View the full topic](https://forum.yunohost.org/t/nginx-fails-to-start-related-to-ipv6/21937)._
