# Nginx fails to start, related to ipv6

**URL:** https://forum.yunohost.org/t/nginx-fails-to-start-related-to-ipv6/21937
**Category:** Support
**Tags:** english
**Created:** [November 2, 2022, 11:24pm UTC](https://forum.yunohost.org/t/nginx-fails-to-start-related-to-ipv6/21937 "2022-11-02T23:24:24Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![Dams](https://forum.yunohost.org/letter_avatar_proxy/v4/letter/d/2acd7d/32.png) [@Dams](https://forum.yunohost.org/u/Dams)
#### Post date: [November 2, 2022, 11:24pm UTC](https://forum.yunohost.org/t/nginx-fails-to-start-related-to-ipv6/21937/1 "2022-11-02T23:24:24Z")

</div>

### My YunoHost server

**Hardware:** Raspberry Pi 3 at home  
**YunoHost version:** 10.0.10  
**I have access to my server :** Through SSH

### Description of my issue

Hi,

After a reboot, Nginx is not starting anymore.

```plaintext
nginx: [emerg] socket() [::]:80 failed (97: Address family not supported by protocol)`

```

I looks like I have no ipv6 but I can’t figure out how to fix this. Should I activate ipv6 and how? Or should I disable ipv6 for nginx? Any help welcome.

---

<div class="post-metadata">

### Author: ![Dams](https://forum.yunohost.org/letter_avatar_proxy/v4/letter/d/2acd7d/32.png) [@Dams](https://forum.yunohost.org/u/Dams)
#### Post date: [November 3, 2022, 9:50pm UTC](https://forum.yunohost.org/t/nginx-fails-to-start-related-to-ipv6/21937/3 "2022-11-03T21:50:57Z")

</div>

Right now I have written a script to disable ipv6 listening for ngnix. I would like to turn it into a hook. I have seen some samples from @metyun at [Share your "hooks" to apply custom configurations- Partagez vos "hooks" pour appliquer des configurations personnelles - #2 by metyun](https://forum.yunohost.org/t/share-your-hooks-to-apply-custom-configurations-partagez-vos-hooks-pour-appliquer-des-configurations-personnelles/17235/2) but I don’t know how to write a hook properly.

```auto
#!/bin/bash

# comment out lines containing ipv6 listening in nginx config files

sed -i "/listen \[::\]:/ s/^#*/#/" /etc/nginx/conf.d/domain.tld.conf
sed -i "/listen \[::\]:/ s/^#*/#/" /etc/nginx/conf.d/yunohost_admin.conf
sed -i "/listen \[::\]:/ s/^#*/#/" /etc/nginx/sites-available/default

```

---

<div class="post-metadata">

### Author: ![system](https://forum.yunohost.org/uploads/default/original/2X/f/f59fe8e3ee6b100b4f574d30d6e30479c68b89f0.png) [@system](https://forum.yunohost.org/u/system)
#### Post date: [December 3, 2022, 9:51pm UTC](https://forum.yunohost.org/t/nginx-fails-to-start-related-to-ipv6/21937/4 "2022-12-03T21:51:37Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
