Nginx detects ssowat.conf as buggy


since yesterday (upgrade of nginx on raspi B), nginx won’t load anymore.
I tried to identify where the problem was, and it appears nginx does not accept ssowat.conf file anymore.
Ssowat is up to date (2.2.1).
The conf file is the same as on the github repo
Any idea?

What is the error thrown by Nginx ?

Try to run yunohost app ssowatconf and restart Nginx manually.

the problem is that no error is thrown by nginx. Just this message in the error log (approximativly, I cannot copy paste):

[info]: Using 32768KiB of shared memory for push module in /etc/nginx/nginx.conf:64

This message also appear when the conf file is accepted.

This is not an error, just a notice.

What error do you get when you try to reach a domain name via your web browser ?

I can’t launch nginx, as it fails ti start. When I try to reach a domain, I get 503 code.

Another error I get in the log (could be linked) :
lua entry thread aborted : runtime error : /usr/share/ssowat/access.lua:13 attempt to index local ‘cache’ (a nil value)

One mode info, if I try to run

lua /usr/share/ssowat/init.lua

I get “Instruction non-permise”

It looks like the same problem as with metronome (mismatch between binary and architecture)

As lua is implied in both problems, and lua package was recently updated, could this come from a wrongly compiled package (with armv7 set of instructions instead of armv6)?

Yes it is the same issue than the one of metronome.

But once again, I especially rebuilt the image for Raspberry Pi model B compatibility… So I guess that we just have to wait until someone else come up with this issue again.

For the record, what are your metronome and nginx-extras versions ?

dpkg -l | grep metronome
dpkg -l | grep nginx-extras

Here are the versions :

dpkg -l | grep metronome
rc metronome 3.6-6.rpi armhf Lightweight XMPP server with advanced microblogging features
dpkg -l | grep nginx-extras
ii nginx-extras 1.6.2-5~bpo70+1.rpi armhf nginx web/proxy server (extended version)

They are the one from the stable/rpi repo. And i trust you when you said you compiled them properly. I was talking about the lua5.1 from the raspbian repo.
I commented the second line of the ssowat.conf file, and the configtest command worked fine

Ok, I will try out on my Raspberry Pi

I have the same problem on my Raspi B+

same erreur with strange behaviour .
Tried to re-install nginx, not way I have a probleme with my distrib ( wheezy)

Metronome illegl instruction same for nginx
no output at all , no text for error description
I will try the ssowat trick to see if it fix my problem

root@yunohost:~# dpkd -l | grep metronome
-bash: dpkd : commande introuvable
root@yunohost:~# dpkg -l | grep metronome
ii metronome 3.6-6.rpi armhf Lightweight XMPP server with advanced microblogging features
ii yunohost-config-metronome 2.2.0 all IM Server for YunoHost (meta-package)
root@yunohost:~# dpkg -l | grep nginx
ii nginx 1.6.2-5~bpo70+1 all small, powerful, scalable web/proxy server
ii nginx-common 1.6.2-5~bpo70+1 all small, powerful, scalable web/proxy server - common files
ii nginx-extras 1.6.2-5~bpo70+1 armhf nginx web/proxy server (extended version)

do you have an idea …

The last version of metronome is not compiled for rpiB or B+ (which explains the illegal instruction). You need to install le the last good version, and ask debian to not upgrade it later